Roon live radio not working

Roon Core Machine

Roon ROCK running on Intel NUC core I7

Networking Gear & Setup Details

Rock connected via Cisco MS220 switch in unmanaged mode, to Mikrotik CRS 212 router.

Connected Audio Devices

Naim NDS via ethernet (using Sonore Roon to UPNP bridge)
Naim Muso 1 via Airplay over Netgear ORBI mesh WiFi
Samsung Zfold 3 connected over Wifi
Local PC via ethernet

Number of Tracks in Library

1100 tracks only (use Qobuz mostly)

Description of Issue

Roon radio not working - I have had Roon ROCK in place for several years with solid performance on local files and Qobuz streaming for all endpoints. No other network issues in the house. E.g streaming HD video over WiFi is flawless.

I have only recently tried to use the Live radio function. No stations from Roons presets are working, with the exception of Radio Paradise (which I believe is FLAC). I have tested lets say 25 other stations at random, including my prefered BBC radio stations in UK. NONE work - “playback was interrupted because a file failed to load”. I have also tried manually adding stations but none work. Same condition on all endpoints.

I have checked and reloaded the CODEC file - extracting it and renaming to ffmpeg.tar then placing it in rock/data/codecs. No difference after rebooting twice…

Please help!

That’s not correct. You need to extract the downloaded codecs file, possibly twice (depending on the extraction program you use). In the end, you end up with an extracted folder that contains lots of files, among them a file named just ffmpeg. This is the one you have to copy to the ROCK. No renaming. Screenshot from mine:

From the instructions:

How To Add Codecs: Step By Step

  1. Download ffmpeg - Roon will need access to the required codecs via the /Data/Codecs/ directory. You will need to download these codecs on another computer before placing them on ROCK.

  2. For example, grab and uncompress it. Remember, no additional files from that package are required, only ffmpeg. You will need to uncompress the file twice.

  3. If you are using Windows and do not have the ability to uncompress .tar files, we recommend downloading the open-source program 7-Zip

  4. Connect To Roon OS - Roon OS exposes a shared network folder called Data. You can access this SMB share by following the instructions here here

  5. Copy Codecs to Roon OS - Place the ffmpeg file in the Codecs folder, which you can find in Roon OS’s Data directory

  6. Restart Your Core - Restart Roon Server using the Roon OS web interface


1 Like

That did it, thanks so much for explaining.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.