Roon Login Garbled

This is what I see when I try to log into Roon.
I see find my roon core. Then it goes to this crazy black and white garbled lettering.
Latest version of Roon for Windows 10 64 bit.

I7. 32G RAM. AMD 5700XT WIN10 V2004

Make sure your video drivers are up to date.

Also, Roon needs Open GL 3.0 or higher.

If those two things are in order, try running the 32 bit version of Roon or, as a last resort/experiment, RoonServer. For that you’ll need a Remote as RoonServer doesn’t have a GUI.

Well, still no luck. At this point this is whats happening:

  • AMD 5700XT supports Open GL 4.6

  • Installed the 3 versions of the driver which are listed on AMDs site.

  • Uninstalled Rooninstaller 64 and reinstalled 32bit version. Still no luck.

  • The main login screen shows up but when I move my mouse to find the core, the screen goes to the black background with the inverted text which I displayed in my original post. When I resized the frame, the option to find the core shows up again, and when I move my mouse to the blue box to find core, it returns to the problem screen.

  • The previous video card was an AMD R9 390 and Roon ran fine.

I can run Roonserver but would prefer to the the standard 64 bit software.

Hmm, this is happening on your Core machine or on a Remote?

No matter. Tagging @support for this.


Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link? Thanks!

1 Like

Hello @HIFIGUY, and thanks for your patience while we discussed this item with our senior technical team. The font package you’re seeing isn’t one utilized by Roon. So we’d like to help narrow down where this package is coming from, would you kindly check the following for me? Thanks!

  1. Are you able to reproduce this immediately after rebooting before you open any other software?
  2. Do you have any sort of overlay software running on this machine? Perhaps something with a similar loading animation as what’s shown in the screenshot you sent?
  3. Can you link me to the drivers you downloaded?

Lastly, our team would like to capture a set of diagnostics from when Roon crashes. Could you please reply here with a timestamp of when you see a crash, and we’ll enable diagnostics and get this information over to our team?

Core Machine (Operating system/System info/Roon build number)

i7 32GB Ram. 1 TB SSD AMD 5700XT Graphics. 28" 4K Samsung 4K Monintor.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Hardwired to Asus Router AC87U. Running Server on NUC.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

No connected audio devices
Description Of Issue

Garbled text. I reported this in September. Still no fix. Drivers fully updated. Running Roon Server on an Intel NUC. Client software on my main PC is the problem.

I moved your post back to the original topic. Let’s continue here.

It seems you didn’t respond to @nuwriy questions.

This issue happened after I had installed a new Radeon 5700XT running Win10. Recently updated the OS to 20H2 and the same issue remains. I have attached a screenshot of the AMD driver: I had been running Roon Server on this machine as I could not run the local client due to the error I had presented. I now run server on a NUC but still cannot login to the client at all on this machine. Its odd. If I expand the active Roon window, the login button will appear but the second I go to select that button, the garbled graphics appear. See first image below which I did while typing this response. I can drag the top part of the roon box, but the second I move from the top to select " I agree", it goes to the black. I can never select " agree ". I cannot tab to it. Lastly, I figured it was likely a driver issue, so I waited a number of months. No such luck. I have tried the font resizing, using different resolutions and still nothing.

As for the crash log, I am not sure where I would find the piece of information you are looking for in regards to this event. Please advise.



Please read what @nuwriy wrote. He’s asking you to state the time and date when a crash (the garbled text) occurs. Once he has that, then he will retrieve the logs from your Roon server remotely - you don’t have to access the Roon log yourself.

Could you answer the three questions that @nuwriy asked? That might help

I think I answered the question providing screenshots. But I’ll lay it out more simply.

  1. Is a fresh reboot and me not operating any other programs, when I start Roon it happens.

  2. I screenshotted the driver version and provided a screenshot of running processes.

  3. I’ll grab the log for his instructions and provide it although it was not clear whether he was going to remote access the log or whether I had to provide it for him.

As the Folding client uses the GPU to do it’s calculations I’d try stopping it’s processes and see if that is interfering with Roon.

Hello @HIFIGUY, please also check for overlay software like MSI Afterburner. I’ve seen a few similar threads resolved by disabling such software.

MSI Afterburner appears to have been the culprit. Tried to open Roon client with it on and the garbled font issue occurred. Closed Afterburner and then attempted to open the Roon client and success.
After Roon client was open I was able to run MSI afterburner which did not alter the operation of Roon.

More interesting is that once I have run Roon client and then close it down, I can then start MSI afterburner and subsequently launch Roon client without issue.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.