Roon loops scanning and adding

Windows 10, Built 710

Fritz!Box, Wired


Roon loops scanning and adding. After installation of built 710 roon seems in an infinite loop of scanning and adding files. Was responding sluggish before, so maybe the issue developed recently and came to my attention just now!

Hello @Joachim_Herbert, if you reboot the core does the scan change? I’d also like to know more about your core, can you tell me its specs? Lastly, I’m going to enable diagnostics on your account to help track the issue, while I’m doing that, could you please do the following and make a note of the time you do each:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

Once we have this information I can present it to my team for further analysis. Thanks! I look forward to receiving the timestamps from you.

I’ve managed to reproduce this behaviour, though this isn’t guaranteed to be the same cause. I did it by creating a recursive symbolic link or two in a directory in the scan path:

cfw@roon:/music/ssd/rec_test$ ls -alh
total 24K
drwxr-xr-x   2 cfw cfw   4.0K Dec 16 16:10 .
drwxrwxrwx 545 cfw users  20K Dec 16 16:08 ..
lrwxrwxrwx   1 cfw cfw      2 Dec 16 16:10 parreclink -> ..
lrwxrwxrwx   1 cfw cfw      1 Dec 16 16:08 reclink -> .

Roon’s basically following a recursive link here so it’s getting pinged back through the structure. Roon itself continues to work as normal, though it is a little sluggish. The instructions here might help you to find any links on a Windows file system:

Edit: FYI if anyone needs to perform this check on a Linux system then find -L <root-directory-path> -type l will do the trick.

1 Like

Hello @nuwriy, thank you for looking into this. I rebooted the machine several times last night, just to find everything working just fine this morning. So thank you a lot, but this case may be closed. Sorry for bothering you.

Just to add missing info: roon core is running on a HP microserver gen8, Intel Xeon, 16 GB memory, OS and database on SSD, files on WD red hd.

Importing and scanning the library is pretty fast in this configuration.

Thank you, @killdozer. Cure were some reboots in my case.


Hello @Joachim_Herbert, glad things are working again. If you have any further issues, please let us know!

Hello, Alex here, new to Roon and enjoying it so far.
I’m having a similar issue here with two folders locked on scan mode with nothing hapening.
Core server on an old Lenovo D30 win 10 workstation, 64 GB ram, two CPU Xeon.
Library on local drives.
Tried to reboot several times: no success.
Looked for symbolic links: none.
Tried to find information in the logs but I don’t know where to start from.
I would appreciate further guidance. What am I looking for?
Best regards,

My version of Roon: Roon 1.8 build 783, 64 bit,
Computer: Lenovo 4223, 64 Gb ram
Microsoft Windows 10 Pro, Version 10.0.19042 Build 19042,
Graph card, NVIDIA GeForce GTX 1650

i have the same problem since weeks.
and i there are more problems/bugs which makes roon totally unusable

Well as I didn’t get any feedback and was still within the 14 evaluating days period, I decided to terminate my trial. I’m a bit sad because this product is well thought.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.