Roon looses connection to Linn Akurate Streamer after 20-30 min


see below

Roon Core Machine

MacOS BigSur
iMac (Retina 5K
3,5 GHz Intel Core i5

Networking Gear & Setup Details

Fritz!Box 6590 Cable
2x TP Link Mediaconverter (LWL) MC200

Connected Audio Devices

Linn Akurate DS/3

Number of Tracks in Library

No Idea

Description of Issue

I tried to use he Roon Core on a mac, and on a Windows machine - both time with the same problem.
I activate my Linn Streamer (with Linn Streaming, not Airplay) - start music, after 20-30 minutes the music stops and it says that the device is lost… it takes then some time (or restarting Roon) to reconnect.
Quite frustrating! And a pity for the money Roon costs.

What happen when you just use the Linn App? If you have same problem, than you know that Roon is not the problem.

PS - I have a Linn Akurate DS/3 with QNAP HS-264 and don’t have that kind of problems

Hi, the Linn App works perfectly fine for weeks without any interrupt.
(Also Linn Akurate DS/3)

(I found that others reported similar problems here in the forum btw…)

As a fellow Linn owner who has worked through and helped debug various issues between Roon in the past: it’s important that you fill all the support information relative to your networking setup, because in my experience most issues are caused by Linn’s sensitivity to particular network configurations.

Ok, did it.

One suggestion, even if only temporary for testing: try something like this

Linn cropped

(for “dumb switch” this is a good choice).

What’s called “Linn Streaming” in Roon is (I believe) an instantiation of Linn Songcast whose original purpose was to connect multiple Linn streamers and so may not be as well tested with Roon (my impression anway). This protocol implementation seems to be quite sensitive to network configuration. In contrast, when you control your Linn streamer with the Linn app, the streamer pulls music directly from either your local UPnP/DLNA server or from a streaming service, which is a lot less touchy from a networking point of view.


Hi @Sebabe ,

Is the Linn the only device which has this issue? Are you able to also able to reproduce when using Airplay streaming to the Linn? If you are able to add an unmanaged switch, I would be curious to know if it helps.

Hi, yes it is the only device that has problems.
I can try a switch, but don’t really like to have another device in the chain that I do not really need…

I hate to say it, but it works with the switch like proposed. It even sounds better…
Hm but sad that it needs again another device.
Strange network world…
Regards & thanks!

1 Like

Hello I have a person who called me, being a dealer of Linn. He has the same problem but with a Majik DS. Tried everything but nothing helps. Ask Linn and from Linn’s side everything is ok. What to do

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.