Roon loosing sight of qnap files

Hi guys I have an issue with my library it seems to wipe out the 38000 albums and start rescanning again from zero which takes about 3 days to complete…

Core is running on a Mac mini
Flac Files held on qnap 8 bay Nas
both connected to the same asus router via a switch… all my flac files are stored locally I don’t use tidal

Can anyone offer any help as this is getting a headache… anyway for now it’s scanning again :sob:

I am an extremely new Roon user so please forgive me if this reply isn’t as helpful as it might be: it’s only an idea!

I have a QNAP NAS on which my music is stored but I use RoonServer on the NAS—so that both my music and RoonServer are on the NAS. I don’t know if that helps you but in my case my files were scanned reasonably quickly (and with the advantage the scanning could continue in the background even when I was not using my Mac).

I’m also running Roonserver on the NAS and was using the Mini just as a bridge until I got an UltraRendu.

Still, you shouldn’t be having an issue. If it is rebuilding your library every time, that would point to the Roon database file having problems?

How is that Mac mini specced (age, model, CPU, RAM)?

With 38.000 albums (400.000+ tracks?) could very well make that machine run out of steam. This could give you some reference:

Hi thanks for the replies, I had this issue last week and again this, I’ve took a look at the Qnap and can see there’s a job that runs at midnight for raid scrubbing, for now I’ve flipped this to monthly instead of weekly because i can’t remember if it happened last Sunday as well, certainly close…

|Model Name:|Mac mini late 2012
| Model Identifier: Macmini 6
| Processor Name: Intel Core i5
| Processor Speed: 2.5 GHz
| Number of Processors: 1
| Total Number of Cores: 2
| L2 Cache (per Core): 256 KB
| L3 Cache: 3 MB
| Memory: 8 GB 1600Mhz DDR3

with a 500gb SSD installed

This is in all likelihood more related to your Core (on the mini) than it is to the QNAP (all it has to do is serve out the file via SMB).

From the article (written by @brian, Roon’s CTO) linked above:

If you’ve got a 4k monitor and 20,000 albums, look for a big scary Core i7 with plenty of ram, an SSD, and discrete graphics.

With a collection that size, I’d look for a dedicated modern-day i7 machine with 16GB of RAM for running Roon Core. A top of the line NUC running ROCK could do the trick.

Roon @support may have something to add as well.

Didn’t Brian say ‘Discrete Graphics’ which implies NOT a NUC.

I have managed to obtain a free RAM upgrade to 16GB ill give this a try to see if there’s any improvements

Hello @Neil_Haskins,

Apologies about the delay in getting back to you here, just to confirm here, the NAS is using a reserved IP address and it is not changing?

What kind of ASUS router and switch are you using here? We have seen some Asus routers need to have to have “Disable Smart Connect” setting applied to it as per out Networking Best Practices.

Please note the exact local time in your country (ex. 4:59PM) that you notice the next rescan kick off, I can then enable diagnostics mode for your account and take a look around that timestamp to see if Roon lists a reason as to why the rescan is occurring. Please let me know if the RAM upgrade helps here too.


Hi Norris

Thanks for getting back,

The Qnap is statically assisted on the router to keep the same IP.
The Router is an asus RT-ac5300 running merlin firmware, I have just disabled smart connect and already had multicast enabled.
The switch is a basic non managed 8 port device that is cables directly to the router.

I am now waiting for the library to fully populate before fitting the RAM upgrade as I took another hit on this the other day…
Hopefully tomorrow it will be complete then I’ll power down and fit the 16Gb upgrade to the Mac mini… and see how it all goes
I’ll keep an eye on it over the next few days to see if there is any improvements

1 Like

Hey Neil,

Noris and I were just discussing this and something occurred to me – since you’re running an extremely large collection on an older machine, I’m wondering if Roon isn’t able to complete the periodic re-scan in time.

For reference, I run with over 10k albums and that scan takes less than 20 minutes, but your numbers seem way off from that:

So there might be a bottleneck here somewhere – might be worth confirming Roon and your NAS are both running SMB3, and connecting over gigabit.

Moreover, you might want to change the automatic rescan interval in Settings – I suspect that will get things more stable here. You can find this setting in the Storage tab, next to your folder, by clicking Edit in the “3 dots”.

Hope that helps!

Hi Mike,

I have checked both the network interfaces and can see they are both running at 1Gb.

My Nas was running SMB2 so I have changed this as suggested.

I have changed the automatic rescan to 24hrs to see if this settles things down.

Additional ram is in and database is back for now so monitoring with the changes made…

1 Like