Roon Loses Contact between my Mac and my Topping D50s

Using: IMac for Roon Control; NUC for Roon and a Topping D50s as a DAC, running via USB from my iMac. Topping is using “exclusive” mode for best sound.

The Mac forces me to use the MIDI setup to enable the Topping and direct audio through it. If I use the Topping (and, hence, my desktop stereo) for any other source besides Roon, Roon will literally lose sight of the Topping and it will not show up in my Audio devices. The only solution then is to reboot.

Can you guys maybe assist me? I thought my DAC was defective/incompatible, but others have asserted that this is some software issue.


I’m unable to reproduce this, but my devices are little different. Maybe we can walk thru and see.

I have the Roon Core (server) on an Mac mini, I do control from my working computer, an iMac. I did connect to my iMac a spare dac, iFi hip dac 2. Roon did see that and appears on the audio settings screen. I did play something from roon and the hip dac did play. I opened an YouTube on my iMac and did play thru iMac speakers, so both roon on the dac and YouTube on iMac speakers do play. Than I stop roon and using iMac audio (right upper os bar, the speaker icon) I did switch the YouTube to play thru the dac. Then I stop the YouTube, get back to roon, hit play on roon and roon playing thru hip dac again, the OS X options did change themselves back to internal speakers.

Here are the screenshots from the story. Maybe we can find the not working link

Screenshot 2022-11-30 at 14.58.00
os seeing the dac

roon seeing the dac

Screenshot 2022-11-30 at 14.59.18
roon playing on dac

YouTube paying on internal speakers. If I try to play YouTube thru the dac while roon is playing the os would not let me select the dac.

Screenshot 2022-11-30 at 15.05.38
If I pause roon then I can put os on the hip dac.

If I start playing on roon the YouTube from safari it is transferring to the internal speakers. Now if I again stop roon the YouTube will regain access to the dac and switch itself from internal speakers to the dac.

Tell me what to try

I can play YouTube from Mac internal speaker no problem. If I switch to the D50s as a source, to hear through my stereo speakers (per the Mac “sound” menu icon, pic attached), once I try to switch back to Roon, it does not show the D50s at all (pic attached). The D50s is powered throughout; many thought it was a power issue. It’s not. Only way to have Roon recognize D50s again is to reboot.

Ok so I understood like this:

Roon plays ok, when you switch the OS X output sound to d50 roon looses d50 as output.
This is not happening to me :frowning:
Roon plays ok, and I have to hit pause to switch system output to dac. OS X plays but the dac is still in roon. More, if I hit play on roon using the dac the OS X is stopping using it and output the YouTube to the default internal speakers.

I’m trying to use midi setup to create a multiple output virtual device in order to combine the two together (Roon and OSx). For ten minutes I was happy as this works… But this is not a ok way as you have to define the Format (bits/kHX) for it. This means that any mismatch that is coming from roon it will get upsampled or downsampled in OS X

I’ll play with it more maybe I’ll find something. Or maybe a more experienced user will have an answer

YES, this is exactly what happens: when I switch sound output Roon loses the D50s. FWIW, using Ventura 13.0.1

Thanks to you and others for any help. This is maddening!

Ha… Thanks for saying Ventura

I did moved to my M1 mini that has Ventura. And I’ve got almost same behaviour. Roon sees the dac, plays. I have to stop in order to let Ventura select the dac. Play YouTube. Roon can see the dac but no sound or play, all the sound system settings are now not responding.

I’ll try more and let you know

If I start the dac and let Ventura to take it Roon is freezing on enabling the dac

Screenshot 2022-11-30 at 16.29.48

Hit disable and enable again, the dac and all the Mac mini outputs are gone from roon. Have to restart dac and roon.

Now I’m on hold, but I will try more. At least we know it is a Ventura problem

Screenshot 2022-11-30 at 16.35.24

1 Like

If I do not use the dac in roon as exclusive mode I can overlay roon over the os (yt and roon play at the same time).

If I select exclusive for the dac in roon and the dac is in use by the os roon does not play and it has lost the connection, safari is non responsive, the sound settings are non responsive. I have to restart all.

Strange on the older Catalina this it is not happening.

If another idea pops in my mind I’ll try. If you have something let me know and I’ll try

EXACTLY!!! Same result here!

I have been this over again (also tried to make a duplicate of the dac in audio midi setup so one copy for Ventura and one for roon to use in exclusive mode), whatever I do if I use the dac with os when before was set in exclusive mode in roon makes roon loose the dac. Only in non exclusive mode it works sharing the dac between roon and os. If you do not switch all the time between Ventura and room keep it exclusive in roon and when you want to use the dac with Ventura uncheck exclusive before selecting the Ventura output. If you do switch a lot between Ventura and roon then I would just leave the dac on roon without exclusive turned on.

Yeah, this is what I have landed on. Curious as to what kind of a hit you get on sound quality by not using exclusive. Any ideas, anyone?

I have the same setup, mac mini running Ventura as my Roon Core. I listen via Roon (+Qobuz), Spotify, Soundcloud and Youtube. I used to just run everything via System Output (44khz 16 bit) that was the default Core Audio output for everything. It sounds fine but I have a fantastic dac that I felt was not really getting the best use by have everything be down sampled via the operating system.

Today I run in the following config…

Roon (+Qobuz) - Exclusive mode with my TotalDAC. It sounds incredible. I love listening to it and get a lot more clarity from tracks. If I play anything outside of Roon that tries to use the dac then it will crash Roons output I will no longer get any sound. This means you need to set a second output as your default output in Audio Midi Setup.

Spotify, Soundcloud, Youtube (everything else) This is all routed via the default output which is set to the internal output on the mac mini, I then route from the minis output into another input on my amp. The audio is absolutely fine and it really doesn’t bother me that it isn’t using my Totaldac as most things aren’t very high resolution on these services.

Here is my config

Roon Core/Mac Mini - Audio Midi Setup - Remember to set the internal mac mini speaker output to default. Just right click and set as default. This frees up your topping to work exclusively with Roon.

Roon Config

TotalDAC Config - exclusive mode - ensure that the bit rate is set correctly. I’ve seen Roon sometimes switch between 24 bit and 32 bit after upgrades and this can mess with your dac if it doesn’t support it by crashing the output.


Great, thanks. This is the setup that I use on my desk iMac, 1. roon (from the Ventura mini core) ethernet to iMac usb dac that outputs to headphones, 2. osx with build in speakers. In my old Catalina if I want osx to use the usb dac I only have to pause roon, choose output on osx to the usb dac, play the osx and while osx is still playing I can also hit play on roon. The osx will kindly remove itself from the usb dac and roon takes it exclusive control. But in Ventura it is as you said, crash. So the only way to use roon and Ventura on the same dac is to uncheck exclusive mode in roon before selecting usb dac from the osx outputs.

Thanks for the detailed explanations and taking the time to do it.

I have forgotten about this thread that explains the following: “Ventura contains an Accessibility update that allows for different configurations of voiceover and background sound. This places a new layer in the System Mixer when engaged,[…]”

Many thanks!

No input from anyone from Roon here??

Hi Peter,

My apologies for the delayed response from Roon support.

I would like to take a look at your diagnostic logging from one of the events. Can you please repeat the process of duplicating the issue and provide me with the date/time/track playing information?

It may end up being that I need to escalate this issue to another party so I want to be fully armed with as much information as possible.


I will do this as soon as I can, my internet is down for a few days. thanks!

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.