Roon loses control of audio device

Hey @Johni – sorry for the trouble here.

We are trying to reach out to Weiss to get some more information or perhaps some loaner gear to look into this. Unfortunately, this appears to come down the Weiss interface or its drivers, and it may be hard for us to work around these issues if we’re not able to get our hands on the gear. We’re working on it, and we’ll update this thread when we have some news to report.

Hopefully we have some good news soon. In the meantime, you may want to explore other possibilities for going USB out of your Core into the Elgar’s digital inputs.

I’m still having recurrent problems with “Roon lost control of the audio device” randomly occurring in the middle of songs. I’m using the ASIO driver as the WASAPI driver isn’t working properly with bitrate changes. Annoying that Roon isn’t working properly for me even after all this time. If there’s anything I can do to help sort this, please let me know!

/irony start

You can always buy a new 5k USB Dac…
/irony end

But seriously. I tried writing Weiss, nothing. Roon doesn’t seem to care either. I now hacked together a solution with which i can now use Jriver together with Tidal and Qobuz. It’s not as pretty but at least it works flawlessly!

This isn’t the case, but we’re blocked here – if we had the device in front of us, we could probably determine if this was happening on our side, or the Weiss side. Then, we could try to implement a bug fix or workaround depending on the underlying cause.

As it is, there’s not much we can do without looking at this in a development environment. We have tried to reach out to Weiss but we haven’t had any luck.

We’ll circle back and see if we can make any progress, but we are as frustrated as you are to not have their help resolving this.

1 Like

Surely there is an audiophile in the vicinity who is willing to lend their Weiss DAC to help sort this?? :slight_smile:

Hi @extracampine,

I use the roon with Weiss Minerva flawlessly on pc for quite long time.
I use nuc with thunderbolt converted with original apple thunderbolt to firewire.
Using native firewire card was always a pain - even prior to roon.
I use intel nuc with thunderbolt port, not easy to come by.

Actually managed to get Weiss to work with roon on top Mac as well, 30 min after posting this.
I’ve reverted to using exclusive mode on playback with roon - that way you can guarantee locking of device to roon only and than it allows you to change resolution in dac on the flight. Also bit perfect files works now and testing shows it’s bit perfect.

Let me know how your pc is built - maybe I could offer help here.


Hi Lior, that sounds promising so perhaps there is hope for me yet! Any help would be greatly appreciated. You can see exactly what my build is here:

Let me know if you have any other questions!

I had the same problem before, I am using a Mcintosh C47 as a DAC and Preamp. Finally I set the Max Sample Rate and Bit Rate as same as my USB driver output then the problem gone.