Roon loses control of SONOS devices when grouped


At this moment again I can’t play any tune from Roon, and Yes the Fing app can see the core machine in this situation. Actually not even the core machene itself can play a tune…it says that Roon lost control of the audio device. The weird thing that I found today is that the problem seems to be with Sonos Speakers since I could play from Roon through my Naim Uniti Atom. Something is happening with my Sonos Setup.

Actually I rebooted the core and was working fine until a grouped some Sonos zones and becomes immediately unusable…Roon Lost Control of The Sonos Device message

Hey @Enrique_Donoso,

I’ve moved these posts over to it’s own thread so that we can track it separately from the remote connection problems in the other thread.

Can you give me some more information about your current SONOS setup? What SONOS devices are you using? How are they connected to the network? Are you using a SONOS Boost device?

How many SONOS devices are you able to successfully group before this behavior occurs?


Thanks Dylan,

My current Sonos setup consist of:

1 playbar
2 Sonos 1
2 Sonos 3 In stereo mode paired with a Sonos Subwoofer
1 Sonos 5
1 Sonos connect

All the above equipment are located in different rooms and the Sonos connect
is the one connected tho the router. All the rest obviously WiFi.

I think I can successfully pair 3 or 4 but this should be done from a clean start (rebooting the Core) but then if a make any changes like pairing o dis paring the problem begins…also I think that if I use the Sonos App in the meanwhile, triggers the issue as well.

Yesterday I rebooted the Core and started using Roon just with one Sonos device, everything was working well until I paired 2 more devices and Roon start loosing the connection with the devices…this was done from the Core machine so I guess that the issue is not necessarily or exclusive of the remote iOS devices.

Thanks for the info, @Enrique_Donoso!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


Hi I reproduce the error @11:20AM Chile time. Roon could not play to a single Speaker…you can press play but nothing happens…it play bar status does not move at all.

Hey @Enrique_Donoso,

Thanks! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Ok thanks. Just for your information, I tried again to play some music @17:15 Chile time but nothing happens…always Roon lost control of the audio device.

Do you continue to use the Sonos controller after initializing a group in Roon?

  • I’ve found this trends towards causing transport issues. Bit I can’t confirm 100%. I have pretty good results by first setting my desired grouping in Sonos, then quitting the app all together and only using Room there after.

What about your network path? You can get a screenshot of your network matrix by logging on to one of your Sonos speakers from a web browser and clicking the “Network Matrix” link at [Sonos speaker IP address]:1400/support/review

-Currently, Roon doesn’t enjoy having to begin playback with a full array of grouped Sonos zones. In my experience, it’s best to start with a single zone, and add to the group one Sonos speaker at a time.

-I find when I go over 3 visible zones (sub is a 4th hidden zone), I run the risk of dropping control of devices.

-Also, if Room shows a zone being grouped, but you’re not getting any audio from the speaker, I find that by adjusting the physical volume button on the speaker (up and down) seems to reliably get audio playing to that zone . Somehow spamming the transport API seems to result in renegotiating the connection, or maybe I’m just superstitious, but it seems to help in those cases.

Lastly, since you have both, I’m curious what your personal thoughts are on the quality of a Play:3 vs Play:5. I went with all play:5 and Play:1s, but will be getting a Playbar soon, and debating two more 5’s, or 3’s. I’m afraid 5’s will be too boomy for voice. Do your 3’s sound clearer/cleaner than your 5 in your opinion?

Hey Ian many thanks for your comments…make much sense, since I was thinking that one of my problems was that we are still using the Sonos app and sadly I can’t avoid it, since I’m the the only one using Roon in my home.

You are totally correct with the way one should start grouping Sonos speakers if you want to use Roon…I found that as well. Also I will try the physical volumen adjustment, which I never thought could help.

Anyways, if this is the current situation with Sonos equipment, it’s clear that Roon has a lot of space for improvement, since the experience is very frustrating…I purchase my license About 4 months ago, but with this situation I barely use it.

In relation to your Sonos Play 3-5 question, I can say that it all will depend on the space you are going to use them and the type of music you hear…but what I’m pretty sure is that a pair of Play 3s will need a Sub for sure, which I should say sounds great! the other case a pair of Play 5s not necesarilly will require it.

Also since you are considering a Playbar, I must add that I’m not totally impressed with it…I use it mainly for leastining music in my bedroom (6x4) and Ifeel it lacks depth, somehow hollow and once again a Sub is needed, which I’m this case I don’t have it.

Again many thanks for your thoughts and @dylan…It seems Roon has a lot to improve with Sonos equipments.

Do your problems go away when your group only 3 or 4 zones grouped?
It’s not a solution, just curious, because in my experience, all these issues start cropping up when I add 5, 6, 7 zones, and there doesn’t seem to be very many users out there with “large” arrays to ask. We may be a small minority, so documenting your issues and submitting logs after you “lose control of audio devices” may be very helpful.

Hi Ian, not really…could happen with two or three zones grouped as well…it is true that with more zones is even more difficult to have longer leastining session.

Hello @Enrique_Donoso,

The team met to discuss the SONOS behavior you’re experiencing, and we are hoping to gather some additional information about what exactly you are experiencing. The team has proposed some tests that will give them some greater insight into this behavior.

Please see these tests outlined below:

Test 1

Group 6 SONOS devices before playback has started. Once the group has been created start playback in Roon.

Once playback is started let us know how things go. Do you immediately receive an error? Does playback work as expected? For how long?

Once you’ve completed this test in Roon, can you try doing the same thing in the SONOS app and let us know how that goes compared to Roon?

Test 2

Start playback to a single SONOS zone in Roon with nothing grouped. Verify that things are working as expected.

Once you’ve confirmed all is well with this first zone, group another SONOS devices so you’re playing to 2 zones. Verify whether or not things are working as expected.

Continue doing this and grouping in more zones until you experience an issue. Let us know when this behavior occurs and how many you were able to successfully get working.

After doing this test in Roon, try doing the same with the SONOS app and let us know how that goes in comparison.

Test 3

We’d like to see how things work without the SONOS network in play. Instead of using your SONOS Connect device, connect your SONOS devices directly to the router (via Ethernet if possible). Try grouping zones and playing back like normal. Does the same behavior occur in this configuration?

Hi Dylan,

I tested the first two options:

Test 1

  • Roon played 2 minutes until lost control of the Sonos device.

  • Sonos played perfect.

Test 2

  • Roon Played correctly until the 3rd zones was grouped and when I added the 4th one, Roon started to play erratic and finally paused. I assumed that lost control of the Sonos device.

  • Sonos played perfect

Test 3, not done yet since Im not sure if the test should be done with Roon or Sonos or again both.


Thanks for the testing, @Enrique_Donoso. I’ll pass your results along to the team. For test 3 please perform this test with Roon.


Not sure I’m following you with the third test. I have my Sonos Connect connected to the main Deco router and also I have the Sonos Playbar connected to one Deco extender. I can’t connect any other Sonos device via Ethernet. Pls advise.

Hi @Enrique_Donoso,

For the third test, we essentially want to test things without the SONOS Connect device. You can connect your SONOS devices to the main router however possible. If there aren’t enough Ethernet ports then WiFi is fine.


But the Sonos Connect is a Sonos device that is connected to the main router. With only wifi, the Sonos setup is unusable.

Hi @Enrique_Donoso,

If you don’t use the Sonos Connect and just use WiFi to connect your Sonos devices to your router, you’re not able to use Sonos at all?

Very limited and erratic usability…but I will run that test in order to understand what happens with Roon without the Sonosnet network. I´ll let you know.