Roon Lost Connection Problem


Intel NUK 10 Intel Core i3 Processor
SK hynix Gold P31 500GB PCIe NVMe Gen3 M.2 2280 Internal SSD
Crucial 8GB Single DDR4 2400

Networking Gear & Setup Details

Roon Core hardwired to the internet via Ethernet to Xfinity Wifi Modem

Network Properties:
Protocol: Wi-Fi 5 (802.11ac)
Security type: WPA2-Personal
Network band: 5 GHz
Network channel: 157
Link speed (Receive/Transmit): 585/585 (Mbps)
IPv6 address: 2601:647:5500:8310::5864
Link-local IPv6 address: fe80::acaf:f3cf:c459:fd5c%11
IPv6 DNS servers: 2001:558:feed::1
IPv4 address:
IPv4 DNS servers:
Manufacturer: Intel Corporation
Description: Intel(R) Wireless-AC 9560 160MHz
Driver version:

Roon is up-to-date. The latest version is installed last week.

Connected Audio Devices

miniDSP SHD Studio > DAC > pre-amp > amplifier > speakers
Bluesound Node 2 > integrated amplifier
Schiit Modi 3 to Magni to headphones
Apple Home Pod Mini

Number of Tracks in Library

Mainly in Tidal library (c. 150,000 tracks)
Music on flash drive about 200 GB. (currently 399 albums)
No NAS, 2 Samsung USB Flash Drives (128 GB x2) inserted to NUK.

Description of Issue

I’ve been using Roon for the last 6 months without any problem. Today, the roon suddenly lost connection to the core and popped the “Lost Connection” error. This would last for 2 minutes up to 5 minutes & then it finds the core but it has never stayed connected for longer than 7 minutes without loosing the connection again. No changes had been made to the network. Everything remained the same but it started to happen. The system tries to reconnect to the core and connects to the core after 3 to 5 minutes of endless loop, but loses the connection again and popped “Lost Connection” error. It only stays connected for 2 to 7 minutes (actually timed) before losing the connection again - the issue repeating. Sometimes, it cannot re-establish the connection until I reboot the system, then loses the connection again after a few minutes. Can you run the diagnostics? I am quite frustrated.

The screenshot is attached.

Note: no problem accessing \ROCK\data while the system is trying to reconnect to the core.
The Roon software was removed from the remotes I am using (on the controlling PC, iPhone, iPad) and reinstalled again but drop outs occur regardless of the remote or interface.
I tried a different core (my la-top - Window) to run Roon in the same network・Had no issues at all. Just my dedicate roon core (ROCK) is having this reported issue.

This is similar to the problem I’ve been seeing since build 918. Win10 remote loses connection and goes back to finding core.

I’m seeing a similar issue on Ubuntu. I tried uninstalling and reinstalling Roon, but the problem persists. I keep seeing the attached screenshot in the logs when I get dropped. Probably a coincidence, but Airplay seems to cut it out more than playing via Ropieee.

Now I am receiving this new problem after I attempted to restore one of my backups. Roon doesn’t let me log-in. Checked the internet connection but it has no problem.

Some of these look like different issues. For clarity, mine is temporary - every time I wake up my win10 remote, the core seems to be sluggish and connects/disconnects repeatedly for a few minutes. Then it seems fine, albeit I have not had much of a chance to play with it. This is new behavior I have never seen before, seems to coincide with build 918.

Give this a shot (for the random, periodic disconnects):

  1. Shut down Roon or RoonServer (whichever one you use)
  2. Go into your Roon database directory (More info here)
  3. Navigate to theDatabase -> Orbit folder
  4. In that folder you will find up to three subfolders. Delete the one named orbit_v3.db
  5. Start Roon or RoonServer and see if the behavior improves.

If this fixes the issue for you then you’ve encountered a known bug. We anticipate releasing a fix for this next week.

Hi Andrew,

Thank you.
I deleted orbit_v3.db folder and restarted the core.
I still receive these screens.

I put my log-in details.

when I hit go back (there’s an arrow “go back” on the top left)


Now I wanted to try logging in with a different core - my laptop (running Windows) but receive this screen. I cannot unauthorized the ROCK. The “Unauthorize” button is not responding.

Should I try a clean installation for ROCK?? Roon Database & Settings Reset doesn’t respond.


Did the suggestion from Andrew resolve your issues? I think this might have worked for me but I now have the new issue which prevent me logging in to my account.


You may want to try what Andrew suggested in this thread. Hope this resolves your issue.

1 Like

Fixed! Yay!

This appeared to have worked for me, but time will tell. I deleted that folder (or actually renamed it) and then woke up my Win10 remote machine and it seemed to connect and be able to maintain it. We’ll see if that changes tomorrow.

I follow this troubleshooting method and fixed the problem:
“There was an issue loading your database”


  • Stop RoonServer from running in ROCK’s WebUI

  • Navigate to your ROCK’s Database Location

  • Find the folder that says “RoonServer”

  • Rename the “RoonServer” folder to “RoonServer_old”

  • Restart the RoonServer in the WebUI to generate a new Roon database folder

  • On the Roon Remotes, press “Use another Core” and connect to the new database

  • Restore a backup

Also, the intermittent drop-out problem was fixed. Only complaint is that it takes too long to load the library at the start up after rebooting the Roon Server but I can live with that for now. Now I got my favourite toy back!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.