Roon lost control of audio device KEF LS50W for My Live Radio

Roon Core Machine

Windows 11, i7-9700K, 32GB RAM

Networking Gear & Setup Details

All ethernet wired (except iPhone used for control).
ASUS RT-AC68U router - ASUS GT-AC5300 in access point mode and meshed with other RT-AC68Us and RT-AC5300s; D-Link DGS-105 and DGS-108 switches

Connected Audio Devices

KEF LS50W (connected via AC68U mesh access point | DGS-105 | GT-AC5300 | AC68U router)
(Core is connected via DGS-105 | GT-AC5300 | AC68U router)

Other audio devices not affected include Ruark MR1 Mk2 connected to Core PC; Topping D10s via USB from a Windows 11 PC (Ethernet); Innuos Zen Mini MkIII (Ethernet).

Number of Tracks in Library

6,250 tracks

Description of Issue

When I try to stream My Live Radio in Roon to the LS50Ws, it takes about 30 seconds for the speakers to respond to the play instruction from the iPhone, the stream may play very briefly, or for 30 seconds or so before dropping. The Roon app on the iPhone shows “Roon lost control of audio device”. Pressing Play in the Roon app on the iPhone (or Stop, whichever shows) will usually restart the stream, which will run for about 30 seconds. This does not happen with locally stored tracks (on a NAS connected to the GT-AC5300, or on the Zen Mini).I have checked connections through to the internet using Speedtest and they are good from the PCs and from the wifi (checked by iPhone) of the relevant access points. I have only noticed these symptoms recently (last few days), although I cannot recall how long it is since I last tried to use My Live Radio with the LS50Ws.

1 Like

When you say “My live radio” what station and what type of stream are you playing? Can you pick a stream that uses lower bitrate MP3 to test?

Are the KEF hooked up with ethernet? If not, can they be? Might be a bandwidth issue with the type of stream you are using.

My experience with my LS50W tells me that the WiFi is spotty with high-res files and streams.
One last thing to check is if the firmware is updated on the KEF.

Thanks Bear,

I was using Classic FM - DAB MP3 128kbps and I did try others. I’ll look out for a lower bitrate station to try and will post back.

Yes, the KEFs are connected by ethernet (and use the current firmware).

Ack, that’s strange then. I am listening to that statin now with no issues on my KEF LS50W, streaming form a NUC/Rock direct to KEF. I wonder if it’s a setting somewhere? Might try switching around the KEF device setup in Roon? Are you using DSP to the KEF?

Thanks again Bear

I’ve tried lower bitrate internet radio stations - they all behave the same: slow to start (need to click on the square - Stop - in the Roon iPhone app to start playing); then stops playing after about 30secs.

I’ve tried streaming internet radio from my iPhone via Bluetooth - that’ works fine, but it’s not what has worked for a couple of years (until recently) and it’s not what I want.

I’m not using DSP to the KEFs and I’m not sure what you mean by switching around the KEF device setup in Roon.

I’ll try taking the meshed router out of the signal path and have the KEFs connected directly to the main access point (but not tonight!)

I have tried various low bitrate stations, but they all behave the same.

I’ve also tried changing each of the settings in Device Setup, but again no change in behaviour.

I’ve also tried (again, I think) deleting and reinstalling the iPhone app - no change.

And I’ve tried rearranging the network to cut out the access point and meshed routers, connecting the KEFs directly to the main router - still no change.

I’m not using DSP.

One thing that strikes me as odd and may give some clue (although not to me) is that internet radio doesn’t play when I press the play triangle on the iPhone app, but it starts playing when I press the stop square - but then only plays for about 30 seconds.

I’m not sure what else to try.

That is strange.
What is your internet speed? Not that it should make a difference with the KEF connectivity, but might with the radio issue? Might try changing your DNS servers? to and

Are you using a VPN? if so, might try turning it off and test.

Internet speed 210Mbps.

I’ve set the DNS servers to and No change to the radio problem.

I’m not using VPN.

One last question are the KEF also connected to your WiFi as well as ethernet? This is how I have mine, added to the WiFi network and also plugged into the ethernet.

After the last question, I am stumped on this one.
Like I said above the station you are having issues with works fine for me.

May need @support to help?

Thanks again Bear. I’ve set the KEFs to be connected via wifi as well as plugged in by ethernet. It didn’t make any difference.

One thing I noticed was that when playing a track from the NAS, it took about 15 seconds to start playing. It’s usually instantaneous. Also, I had to click on the stop square rather than the play triangle to get the track to play. However, the track did play normally - it didn’t stop after 30 seconds like the radio stations. I repeated this exercise with other tracks and the behaviour was the same…

@support , what do you suggest please?

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.