"Roon lost control of the audio device" - Occurs constantly with McIntosh C47 USB connection

Core Machine (Operating system/System info/Roon build number)

NUC8i7BE with ROCK. Installed (and then redownloaded and reinstalled) on 5/29/19.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connection to NUC/ROCK.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

McIntosh C47 USB (Firmware version 1.04)

Description Of Issue

I have ROCK configured on a NUC8i7BE with recommended specs. I have that connected to my network through a switch, and my Roon setup synced with my Tidal account. The ROCK unit connects to my C47 via USB.

Every time I try to output to my C47 through USB, I get “Roon lost control of the audio device” errors (multiple times per song, often every time I click play - it’s unusable). This occurs whether I’m playing local files off my network or streaming through Tidal. The only files I’ve tried are mp3, FLAC, and Tidal’s stream - no exotic hi res stuff yet.

I think I was able to perceive very subtle clicks or a stutter in the music immediately before the lost connections, on the occasions that it played long enough…

I’ve tried the default C47 settings in Roon, as well as various experiments with changing delays, buffers, and other settings. I changed the USB cord twice (regular consumer USB cords - nothing proprietary or fancy). Nothing helps. My C47 firmware seems to be recent (1.04). I have no network problems or issues streaming with my Sonos setup. In fact, if I output Roon through the Sonos Connect connected to the same C47 via optical, I get no disconnects or dropouts whatsoever.

I would greatly prefer to use the USB connection (ideally with the ROCK), but I’m flummoxed and need help!

Thanks very much!!

Hi @shahnm,

Thanks for reaching out to us regarding this issue. You mentioned that you tried several USB cables, but can you also try a different USB port on the ROCK?

In addition, let’s try to separate if this behavior occurs on multiple cores, would you by any chance have another PC you can use to temporarily host the Roon Core on and see if that performs as expected?

You can switch Cores as often as you’d like using one license but it is suggested that a Backup of the Roon database is performed before switching the Cores (in case you have made edits to your library).

Can you give another Core a try and let me know how it goes? If we are able to isolate the issue to just the ROCK that would rule out the Endpoint + the cable used which would be a good step in the right direction.

– Noris

Hi Noris,

Thank you for the reply!

I already tried different USB ports on the ROCK. All of them. It made no difference.

I just got and ran a long USB cord to a Windows computer in the same room, installed McIntosh’s Windows driver, and have been able to stream to the USB input of the C47 without glitches.

My next step will be to do as you suggested and make the currently connected Windows computer a core and see what happens.

As a related side question: If we determine that the C47 just doesn’t want to play well with the Linux based ROCK core, would I lose any quality, functionality, or “whatever” by just installing Windows on the NUC, installing the Windows version of Roon on it, and making that the dedicated core? I’m not in love with that idea, but I could live with it if it gives me a quality, functional Roon core…


You’ll get it working. Might take a little troubleshooting but it should work fine.
But FWIW you can install Windows 10 on a Nuc and it runs Roon server just fine. Windows will require just a bit more maintenance but performance-wise I doubt you’d know the difference.

Nope, should work just as well. I use Windows as the OS for my Roon core and have for years.

Hi @shahnm,

No, you will not lose anything by making it a Windows Core, except for the fact that a little more maintenance will be needed as Scott mentioned. Do let us know how it goes!

– Noris

I had all kinds of USB problems even after changing to Windows. After a while, in sheer frustration, I started messing with the NUC’s BIOS settings. To make a VERY LONG story short, turning off hyperthreading and processor “boost” seems to have fixed the problem. My USB connection has been rock solid ever since I made those changes.

As an aside, I thought there was something wrong with my C47 DAC, as I was getting a ton of digital crap noise playing SACDs through the McIntosh’s proprietary MCT connection to the SACD player. It turns out that the NUC processor was probably throwing off a bunch of digital noise that was backfeeding into the C47’s DAC. After I pulled the plug on all of the processor enhancement settings, everything started working correctly, including the SACD/MCT stuff.

I don’t exactly get it. I’m happy it all works though. I’m about to become Roon’s newest lifetime member.

Thanks very much to all who chimed in to help!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.