Roon message error: “Audio device in use”

Roon Core Machine

NUC7i3, 8MB RAM, ROCK OS

Networking Gear & Setup Details

Router>switch>NUC>Devialet all connected by Ethernet wires

Connected Audio Devices

Devialet D200 (ethernet)

Number of Tracks in Library

35k tracks

Description of Issue

A lot of times, when I start play Roon playback throught ethernet input of my Devialet, the sound doesn’t start and the screen show the message “Audio device in use”.
I have to unplug/plug the ethernet wire connected to my Devialet or reboot the Roon OS to start playing.
I tried re-installing both the firmware on the Devialet and the ROCK on the NUC but nothing.
The others devices connected to Roon works perfectly.

Here are some other threads with the same issues, it might help with your issue:

  1. Devialet “Audio Device in Use” - #2 by ged_hickman1
  2. "Audio Device in Use" - Devialet D200 - #13 by Ced_Rachmad
  3. "Audio Device in Use" message - #6 by john

Thank you for the threads list, but unfortunately no one has been useful…

any idea to solve the issue?

Hey @Alberto_Medioli,

Thanks a whole lot for not hesitating to let us know of the issue you ran into. We’re sorry that none of the steps suggested for similar cases worked in yours.

We’re terribly sorry that we didn’t get a chance to get back to you until today. We’d love to help if you’re still running into this. Would you be able to share an update on where things stand?

Yes, I’m having still the same issues.
I’ve tried to connect both Devialet and NUC directly to the modem/router (bypassing the switch) but nothing has changed

news about my issue?

Hey @Alberto_Medioli,

Thanks a lot for following up :pray: . I just returned to work on Monday, after the holidays, and saw both of your messages.

Is your Devialet set up as a Roon Ready device? As a test, if you navigate to Settings → Audio and enable it as an AirPlay device, does it work with Roon?

Hi Rebeka,
my Devialet is listed as “Roon Tested” via DevialetAIR. My Devialet model is a D200, so doesn’t support AirPlay.
Alberto

Hey @Alberto_Medioli,

I just now realize for how long I’ve missed this thread.

If you can, would you please check for a firmware update for your Devialet speakers? If any is available, it should help :pray:

Devialet amplifier has the latest firmware (for my D200) version v10.1.0

Hey @Alberto_Medioli,

Thanks so much for that :pray:

Would you please make sure you back up Roon to a safe location and then follow these steps:

  • Stop RoonServer from running in ROCK’s WebUI

  • Navigate to your ROCK’s Database Location

  • Find the folder that says “RoonServer”

  • Rename the “RoonServer” folder to “RoonServer_old”

  • Restart the RoonServer in the WebUI to generate a new Roon database folder

  • On the Roon Remotes, press “Use another Core” and connect to the new database

  • Restore a backup

Many thanks :pray:

Done…… but doesn’t work

Hey @Alberto_Medioli,

Thank you for your patience while we circled back and for trying all the steps we suggested so far.

Would you be able to please try one more thing? Adjust your Devialet Settings for your AIR driver:

Please, let me know if that helps :pray: