Roon Metadata Improver Update? [Fixed]

I have a warning sign on Roon (Windows and iOS) that I need to update Roon.
I have downloaded the latest Windows 64 version and run it, but the indicator is still there. I rebooted and then restarted Roon. No change.
If I select the indicator, I see this message:

What am I supposed to do to updated whatever this message is about?

Let’s shift this to Support and ask @vova and @eric. I haven’t seen that message before.

Has Mike got the weekend off?

SJB

2 Likes

@vova and @eric are front line Support for when we can’t help each other out. @mike and @danny will still have a role in Support but will also be spending time on New Toys (We like New Toys).

No, there’s no software update here. Since the server thinks that it needs to be updated, it probably will not attempt to speak to the metadata service again until it is restarted–so the first thing to do is restart your Roon Server and see if the message goes away.

That message means that your Roon Server got a response from something that looked like a “nope, your software is too old” message. The thing is–we haven’t obsoleted any software versions yet. Support for that error case is in the Roon software in case we need to someday, but the code in our cloud services that would send that message back doesn’t exist yet.

Is there any chance that a proxy, WiFi access confirmation screen, national firewall, or something else got between your app and our metadata services and inserted a web page or error? It’s possible that the client would go into the “halted” state if it got a totally nonsensical response like one of those things.

We did try to replicate this from multiple locations and were not successful. Our server monitoring doesn’t show any crashes or problems. We ran through some QA processes on the servers just in case and everything went properly. This includes things like importing large TIDAL collections + thousands of albums and letting the identification process completely, browsing to every kind of TIDAL page to confirm that they are working, checking that “identify album” is returning results appropriately, confirming that artwork is loading when it should, and other similar things.

I had the same thing tonight on my roon core and client. I restarted them and it was fine. I also regularly lose contact with Tidal after Roon has been up and running for several hours and have to restart Roon for Tidal to come back. I don’t know if that’s related, but I thought it might be worth a mention

Just to note that I do not use the Tidal service.
Brian, that is a little spooky: I am receiving messages from software code that is planned but does not yet exist…
I had no changed my library in the period around this error - no new files or editing of metadata.
Yes, it is always possible that something got in the way of access to Roon metadata. I use a wired network directly connected to fibre optic. I never observed such an outage, but something could have gone wrong. If so, it appears to not recover itself when the connection is restored.
I will reboot the server when I get home tonight and I expect it will work fine, which does not explain the existence of error messages that do not exist!

Yup, I rebooted the server machine and the message no longer appears on the server or clients. The message from software that doe snot exist yet! Thank you.

Have been seeing the same message as the original post. Rebooted the Roon server and it disappeared along with troublesome connection to TIDAL.

I am seeing this error message on my Mac Book and it has erased some of the album art metadata. I have rebooted Roon and computer and hasn’t helped.

Hi @Ricky_McGrath ------ Thank you for the report and my apologies for the inconvenience. Can you please provide me some details about your network configuration/topology, as well as some insight into any networking hardware you maybe implementing. The more detailed you can be, the better.

-Eric

Eric thanks for responding. I am running 1.2 on a MacBook Pro running Sierra. My watched folder is a iTunes Media file stored on a Seagate external hard drive. Upon further investigation have determined that only cover art is missing from CDs I ripped yesterday…with bizarre exception that a few random CDs I ripped a while back were now listed as having been imported yesterday and no longer include the cover art.

Hi @Ricky_McGrath ----- Thank you for the feedback! Have you tried manually adding the cover artwork in Roon?

Furthermore, can you provide me screenshots of what you are seeing in Roon as well as a screen shot of your folder structure from where the content is being pulled from?

-Eric

Same problem, not sure when it started, but every album I add now gets stuck in this process. Does not add album art or metadata and have warning stating that Roon needs a software update…

Hello,

I’m experiencing an issue with Roon.
When I add new music, the albums are added to the collection but the metadata is not enriched.
There’s a warning that explain the Metadata Improver has Halted. Roon needs a software update.

I’ve rebooted the Roon code multiple times over several days to no effect.

The first time I noticed it was when adding new music to my library.
I assumed it might’ve been metadata related (special unicode characters)
but since then I’ve removed all music files from disk and cleaned the Roon library.
Now even albums that were identified before are not identified automatically.

Note that identifying an album manually still works.

Could you help me in debugging this issue?

Thanks in advance,

Dominic

My setup:
Roon Core 1.2 (build 161) 64-bit
Mac OS X 10.8 Mountain Lion
Mac Mini (late 2012) w 16gb of RAM
Music files stored on local disk (all flac, uploaded remotely via ftp onto mac mini, folder watched and managed by Roon)

screenshot

Hi @Dominic_Cuynen,

I’ve move your post in with some others.

Cheers, Greg

As per @Dominic_Cuynen

Issue is exactly the same in my setup. Rebooting Roon Core does not resolve the issue. Rebooting mac mini does not resolve issue. Editing the metadata manually brings up correct album artwork/track listings.

Setup:
Roon Core 1.2 (build 161) 64-bit
Mac OS X Yosemite 10.10.5
Mac Mini (late 2014) 16GB Ram

Nothing has changed with this setup today with the exception of adding new tracks to Roon…

@Ricky_McGrath / @Sean_Bovaird / @Dominic_Cuynen ----- Thank you for all of your feedback and my apologies for the troubles.

I met with my team today to discuss this issue as we have now had multiple reports of this problem. We have scheduled a meeting with our developers for Monday and would like to gather the following information to help aide in our investigation. Please see below.

  1. Can you please provide a description of your network configuration / topology, as well as providing insight into any networking hardware you may be implementing.

  2. Sean and Ricky: Dominic has mentioned that manually identifying an album is still working, can you confirm the same?

Trouble shooting
This behavior is indeed very strange and would seem to point to an issue with your core machines not reaching our servers correctly. The next step here should be to troubleshoot network configurations.

I understand that this process is often very tedious, as it is reliant on trial and error. Our best option for finding a solution is reducing the complexity of the setup and adding one variable in at time until the issue is reproduced. The first and most basic step would be to try and remove WiFi from the equation first, assuming your core is communicating via Wifi, so the test conditions would resemble something close to this:

Modem - > Router - > Ethernet Cable - > Core machine

I look forward to hearing your feedback and observations as we are eager to get this straightened out.

  • Eric