Roon needs SMB cache cleaning every day (Solved)

Every day Roon won’t connect to my NAS stored media anymore.

I have to reset the SMB 2 cache on my Synology NAS and force a rescan of media files.

Sometimes then Roon counts down all my media files resulting in -228 tracks, yes minus 228…

After the rescan, which takes hours, everything works again.

This also happens, when I stop and restart the Roon core…

Here is my setup:

Roon core 64bit 1.3.b 208 on SonicTransport i5 connected directly to my ASUS (DSL-AC68U, newest firmware) router
Synology NAS with media folders (Music and DSD Audio) connected directly to the router, SMB 2 active
Bluesound Node2 as a wireless endpoint
Roon Remote on PC Win7 64 bit

Everything worked more stable with the other versions before.

This is, what I already did:

  • Re-install Roon core
  • Rebooting router, ST, NAS
  • Deleting the shares on my PC
  • Re-Edit the path to my media files…just tells me “empty folder”

The only thing, which works is resetting the SMB cache in my NAS

I already prepared my logfiles for upload…
May I ask for help, please?

Thank you

Hi @Olive_Pix — Thank you for the feedback and my apologies for the troubles here. I am going to reach out to you via PM momentarily so we can grab your logs for evaluation.


Hey @Oliver_Pix – can you tell us exactly how you’re mounting the Synology in Roon? I assume you’re logging in with user name and password? Are you using an IP address or hostname? Feel free to just post a screenshot.

Also, on the Synology, can you confirm what SMB setting you’re using if you go into DSM > Control Panel > File Services > SMB tab > Advanced? If you’re not using SMB2 or SMB3 I would try that.

Hi Mike,

Thank @mike you for getting back to me. I’m logging in with my hostname (but also with my ip address ), both had the same problem.
I’ m using SMB 2.

I updated the Synology Disk Station Manager last night to 6.1 (coming from 5.1, since I am very reluctant in updating the DSM because of the sometimes reported critical bugs…) with the idea, that this may be a root cause, too.

So i choosed the option “Minimum SMB1, Maximum SMB2 (without large MTU)”.
Additionally I activated the option “Enable SMB durable handles” and until now Roon is working stable, even when I restart the Roon Server.

Not, that I am very familiar with those things, but it seemed like a good idea…Hopefully this will be the solution.