Roon no longer finds Aries mini or Airport express

Roon Nucleus 1.7 build 528

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Google Nest on wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Auralic Aries Mini wireless, firmware 6.3, Roon Ready enabled; Airport Express Firmware 7.8.1

Roon suddenly lost both devices, but still finds other Airplay devices (AppleTV and Pioneer amp). I have restarted everything multiple times, reset both from factory, set each to older firmware build, and nothing. Apple Music finds both, but I want to use the Mini for hi-res streaming, and my iTunes library has been left behind for quite a while.


Hi @Zoren,

Can you please share a screenshot of your Roon Settings -> Audio tab? Are these devices missing from multiple remotes controlling your Nucleus?

The remotes on my iPhone and iPad no longer find the core.

Hi @Zoren,

Have you tried rebooting your router yet? I would give that a try as well if you haven’t done so already.

I’ve rebooted everything.

Hi @Zoren,

If you try to temporarily host the Roon Core on your PC instead of the Nucleus, do the devices then show up? This would be a good test to see which direction we should troubleshoot in, if it’s the Nucleus specifically or any Core on your network. To switch Cores:

  • Create a Backup of your Roon database (just in case)
  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Switched the core to my computer and it found those devices, switched it back to the Nucleus and they were gone again.

Ok, I fixed it by plugging the Nucleus straight into the router vs the Netgear switch I have most of the house routed through. Don’t know why this suddenly mattered when it has been set up like that for months.

1 Like

Hi @Zoren,

Ah, thanks for checking. I didn’t see you mention the Netgear switch in your original post, so I was unaware this was even part of the chain.

If it’s a managed switch, these are often times trickier to get working properly with Roon, see our Networking Best Practices for more information on this.

Generally speaking we recommend using unmanaged switches (“dumb switches”) as these have work the best in the past with Roon.

In any case glad to hear that bypassing the switch resolved this behavior!

Sorry for not mentioning it, but it’s an unmanaged switch, so I thought the passthrough wouldn’t cause a problem.

No worries @Zoren, thanks for confirming it’s unmanaged. It is possible that the switch might be having some hardware issues, hardware can sometimes break down over time. If there are further issues with devices connected to the switch, you might want to replace it with another one.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.