Roon no longer working with Linn DSM

Core Machine (Operating system/System info/Roon build number)
I run my Core on a portable SSD attached to a QNAP HS-251. Latest QNAP operating system, latest Roon software.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
QNAP and Linn are both on the same network and connected by Ethernet cable to my Virgin Superhub 3 router/modem.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Linn Majik DSM.

Description Of Issue
Hi, wonder if people can help me work out what’s wrong with my system.

Until recently, all has been ok working with my Linn Majik DSM. Linn is on the latest stable (ie not beta) Davaar operating system. I haven’t updated anything recently.

What I have done though is had the builders in to do some work. To be on the safe side, I disconnected the QNAP from everything (it was in the room they were working in).

When I reconnected everything, first impressions were ok. Plex could find my movies on the QNAP and Roon found my Library and played everything OK.

I then tested whether the Linn Kazoo control point worked (I have some playlists on there that aren’t in Roon). It didn’t.

Some digging around showed that the QNAP had been allocated a different IP address by the router when switched back on - odd because I had set it to be a static IP address (I’m wondering if I inadvertently plugged the QNAP back in using its second Ethernet port and whether this has a different MAC address and therefore would not have been given the static IP addresss). Anyway, I just reallocated the old static IP address to the QNAP and hey presto, Linn Kazoo found all my music files again and its playlists played fine.

Problem is Roon now doesn’t play through the Linn. The Roon Control Point on my iPad and iPhone sees and connects to the Core and can play music - including AirPlay to a B&W Speaker is have in the kitchen.

However, when I queue music up to play through the Linn, no joy. I get the little purple stars showing quality source and streaming to the Linn, for files on the QNAP and in my Tidal library, but no sound comes out and after a few seconds, Roon seems to work out it isn’t playing and moves on to the next song. After a few tries it gives up, saying something like “Too many failures. Stopping playback”

Any ideas? Apologies if I haven’t given enough technical info.


Hi @Ian_Forber — Thanks for reaching out.

I noticed that the QNAP you’re using for your Roon Core falls short of our recommended specs.

Because this device uses an Celeron processor, you may experience performance issues, particularly with larger libraries or DSP, or if you don’t use an SSD for your Roon database.

It’s hard to say whether the issues you’re experiencing are related to performance, but we do like to give people a “heads up” when their system is under spec, since it can impact the product in a number of ways, and you may encounter some limitations going forward.

With this in mind, there is some information that would be helpful in understanding exactly what you’re seeing here:

  • Are you using and DSP features with this zone?
  • Are you experiencing similar behavior with any other zones?
  • Can you share a screenshot of Device setup?

Hi Dylan, thanks for the reply. I am aware my NAS falls short but it’s worked fine to date until I switched the NAS off for a few days and then started it all up again.

I don’t use DSP. Database is held on an external SSD (music files on the NAS HDD). Behaviour not replicated with other zones (ie they are working ok - it’s just the Linn that isn’t)

Not quite sure which screenshot you are looking for but try these. Shout if I have got the wrong ones.

Hi @Ian_Forber – Thanks for the details.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


Thank you. Problem just replicated at 21:37 London time. First tried playing files off my NAS, then tried playing music from my Tidal playlists. No luck on either.


Thanks, @Ian_Forber — Diagnostics have been enabled. Once the diagnostics report reaches our servers I’ll pass it along to the team for review and will follow up once I’ve received their feedback.

After this have you power cycled both the QNAP and the Linn?

1 Like

I power cycled the Linn twice but can’t remember whether I did so for the QNAP. Let me try that and see what happens…


Ha! Success at last - when I’m doubt I should learn to just switch EVERYTHING off and on again!

Thanks for all your help.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.