Roon not adding new albums without using Force Rescan

For the first 375+ albums (~6500 tracks) , albums added to the NAS /music directory would appear automatically in the album catalog. Recently, ripping a CD to the /music folder creates the new, correct subdirectory structure and the full set of .flac files, but the recognized track count does not change and the album is not added. The files are not in the Skipped list. A Force Rescan finds the files and album and it appears in the catalog. This is a nuisance to have to do this for every CD added as it was automatic until recently, but I can do this if there is no workaround. Any suggestions would be appreciated. The setup:

  • Synology DS920+ w/ 8gb RAM
  • DSM 7.1.1
  • Roon Server 20220216 (as service on NAS)

Thanks

It’s a known issue with NAS. A workaround is to schedule rescans.

That’s not true if core is on the NAS device, it only if it’s just acting as networked storage to a core on other hardware.

I should add to the above that I have rebooted the NAS, stopped and restarted the Roon server, disconnected the link to the NAS music directory in the Roon app Settings and reconnected. Each time, the first album ripped will appear automatically, as it should. Subsequent rips, however, go back to requiring a Force Rescan.

Ah didn’t realise the core was on there too…

I do not have the ability to adjust rescan timing with Settings as you suggest. It does not seem to be an option. The Storage screen shows the rescan as “watching for new files in real time”. Thanks.

Here’s the Storage screen settings on my app for reference.


That was due to my misunderstanding as pointed out by @Simon_Arnold3 I thought your core was on a separate device not on the NAS.
You won’t find the schedule as it’s on the NAS itself.

A couple of times, after waiting 12+ hours, I’ve needed to ‘Force Rescan’ in order to pick up adds on an internal drive connected in my ROCK machine.

It’s happened a few times after an update for me, a reboot usually clears it.

Yes, one time a Reboot was the only thing that cleared it.