Roon not connecting to NAS drive

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Virginmedia hub 3.0 cable connection
NAS QNAP TS-228A 2-Bay (1GB RAM) 6TB 2x 3TB WD Red Hard Drive.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Linn Majik DSM

Description Of Issue
Roon is not connecting to my NAS, please see attached screenshots and error message.

I don’t recall the :8080 as being required.

The SMB protocol does not use port 8080 by default, and it would surprise me if it suddenly does so in your case. Remove the ‘:8080’ as suggested in the post above.

I actually inserted SMB instead of http because I read somewhere in the Roon guidance that it was advisable, but I’ve now tried both without the 8080, and unfortunately am still getting the same error message. Could it be something to do with the NAS itself, I’ve tried rebooting it but to no avail either.

This is sometimes related to permissions settings in the shared folder. This post might give you an idea of places to look:

I’m sure the Roon Support folks will have some other recommendations.

Content Stored On a NAS Drive

  • To add network storage, we recommend using your NAS drive’s hostname, such as \\DISKSTATION or smb://MyNASDrive . You can usually find this information by logging into your NAS.

  • You can also use your NAS drive’s IP address, but note that this can change, depending on your network’s settings.

  • Note: AFP Share are not supported, you must use SMB or hostname to connect to the NAS share. You can find more information about why AFP is not supported here.

  • If you are still having issues with setting up the NAS share, further suggestions can be found in our NAS Troubleshooting FAQ

  • After you’ve entered the network path in Roon, enter the credentials required to access your NAS. If a username, password, or workgroup isn’t required to access your NAS, just leave the relevant fields blank and click Add Folder

1 Like

Hi @andrew_duncan,

Has this NAS drive ever worked with Roon?

Are there any special characters in the password for the share?

Go the same problem some days ago.

In my case my NAS use SMBV3, Roon only can use SMBV1 or SMBV2

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.