Roon not finding Hegel H190

Roon Core Machine

Roon core on MacBook Pro.
Mac OS Sierra (10.12.6)

Networking Gear & Setup Details

Ethernet directly from MacBook to Hegel H190 (note: new Roon ready update software installed on Hegel — version p5117.31.1)

Connected Audio Devices


Number of Tracks in Library

6,000 tracks

Description of Issue

I upgraded my Hegel’s H190 so it is now Roon Ready.
However Roon does not detect the Hegel H190. Tried rebooting everything. Still invisible.

This may be it.

Why not ethernet directly to the amp?


I might be misinterpreting this, if so my apologies, perhaps you could elaborate further.

The Hegel H190 should be connected to a network switch via RJ45 not directly to the MacBook.

Also for best results Roon recommend that devices running the Roon Core are hardwired to the network via RJ45 rather than Wifi (it’s also avoid Powerline adapters as well).

Yes the Hegel H190 is connected to a network switch via RJ45.
The core (on MacBook Pro) also is connected to this network switch via RJ45.
All hardwired – no WiFi.

Then it remains to check that IP addresses for the MB and 190 are in the same network. Like or for both. If they are and it still doesn’t work, check that cables are good.

EDIT: is the switch manageable or is it a “dumb” one?

It’s a “dumb” switch.
Will check on the IP addresses next. More news coming, thank you!

I would also suggest reserving the IP addresses for your core and H190 via your router.

When you say Roon does not detect the 190, you mean you do not see it as a new audio zone in settings:audio ready to be enabled?

I see the message, "No Audio Devices Found.
Underneath there is the button, “Manage audio devices”
After selecting that button, there are several outputs to ‘enable.’ Under ROON, the Hegel H190 is not an option. (I have updated the H190 to latest software version, which is RR.) The H190 is not shown.

Have you power cycled everything (H190, core machine, router) and restarted Roon?

I’m not familiar with Mac, is there a firewall in Mac OS that could interfere?

Even if it’s not showing up as Roon Ready, it should be there as an Airplay device that can be enabled, as shown for my H390 (which is not RR yet). Do you see this? Also is the little tick mark showing on the H190’s display meaning it’s connected to the network?

Yes, I’ve rebooted everything – multiple times!
I attempted to change the IP address on the Hegel H190 – but it’s too complex for me (subnet mask, etc) so no news about that…

I was able to get Airplay for my Tidal app. But the SQ is nothing like Roon so I don’t want to go down that path.

The SQ is so much superior with Roon. I know this because the SQ with UltraRendu SQ was immensely superior. (UltraRendu just went on the fritz…)

I get that Airplay is not ideal, but if your H190 is properly connected to the network you should be able to see it as an Airplay device in Roon as per my screenshot, and there should be the little tick mark showing in the H190 display. If you can’t see those, there is an issue with your H190 connecting to the network, which could well be some IP address problem.


Now the problem is the sound level is very low – even when the volume on the hegel is set to 100 (max.)


Now the problem is the sound level is EXTREMELY low – even though the volume on the Hegel is set to 100 (max.)

Good news. Have you checked the volume controls in Roon (after turning down the volume on the H190) as shown below - bottom right of the play control screen? By the way, I’d strongly recommend setting a maximum volume on the H190 to something like 65 to avoid any nasty surprises.

Screen Shot 2022-03-13 at 13.04.12

Try doing a factory reset on the Hegel. I saw that in another thread as the solution to the volume problem.

1 Like

The factory reset fixed the volume problem 100%.