Roon not loading TIDAL - Too many failures

Hi there!
I had the same problem few days/weeks ago. I had to rebuild my database from scratch. It worked thoug. Untill yesterday… Too many failures and tidal login problem @support again
I will wait for help.

Hi @Pawel_Rybak,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Is there any change in behavior if you reboot your Core and networking gear? Does (TIDAL web player) work properly with the same TIDAL account you’re using in Roon?

A month ago I had the same problem and I posted a topic:
New database worked about a month. Now I have to reboot core once a day to have Tidal working.
So my setup is in a previous post…

Hi @Pawel_Rybak,

I’ve been looking over the previous thread and I’m extracting the important bits below for easier reference:

To recap, we have now confirmed the following:

  • This is not an account issue
  • You have cleared Roon’s cache with no change
  • You have rebooted the Core machine with no change
  • You changed DNS settings without change
  1. It started about 2 months ago
  2. It is depended on a computer with roon core.
  3. This MacMini is connected directly to Cisco router with cat5 ethernet cable.
  4. I changed DNS settings for
  5. Switched firewall, add roon server to a list
  6. Deleted roon cache few times rebooted few times
  7. Tidal problem (logout timeout?) occurs randomly, but mostly when I stop playing music, after a while (10-50min) when I press eg. TIDAL button it says Bad login or Password.
    I have to reload roon core and it works again
  8. Few words about MacMini, OS is high sierra 13.6 It was installed fresh 2 months ago, there is only Roon Core installed. It is only for that purpose. 16Gb RAM, SSD

I installed Core on other comp and for 2 days no problems with tidal.
But this my main Mac for work…

From what I can tell this issue seems to be intermittent and only affects your main Mac PC, is this correct? And this PC is also used for work?

I wonder, do you by any chance have any VPNs on this Mac and the issue only occurs when turning the VPN on? Or perhaps some other kind of network traffic shaping software?

I propose a test here (if possible). Can you please try using a hotspot with your Roon Core and verify if the same behavior occurs on your work PC a different network?

I bought Roon and Tidal few years ago and didnt change anyhing in my setup since then.
As I found on this forum thera are users with the same problem. I played with network connection (connected using virtual network - ethernet goes into mac and using thunderbolt to ethernet connector it goes to streamer) few times but problems always returns. I know it started with one of roon updates. About december/january maybe? I dont use VPN. Should I clear raat folder?

I’ll try with wifi hotspot…

1 Like

Hi @Pawel_Rybak,

I don’t believe that clearing the RAAT folder would help too much with this issue. The error messages I saw in the screenshots seem to indicate that this is an issue with accessing TIDAL content in general, not just starting playback.

Do let me know how the hotspot test goes, as this might reveal some further clues.

Hi Norris!
When switched to hotspot there are new problems - when playing some Tidal albums eg jay electronica there is no music and orange diplay says that some files load slowly and that may be hardware issue…
Tidal login problem is still present.
It is Tidal intergration issue… there are growing numbers of members that reports same problem since last Roon update.
Please fix this or maybe could You offer me some mopney back since you cannot fix this?
So disappointed
Im not IT but I spend hours trying to play around my network gear - rebooting, updating firmware (cisco router)

Hi @Pawel_Rybak,

Thanks for checking the behavior on the hotspot, this helps confirm that the external ISP connection is not part of the issue, but doesn’t tell us if something regarding the internal network is causing this behavior.

Can you please confirm, does this behavior only occur on your SMS-200 zone? If you try to output to your Core’s “System Output” zone (the internal speakers), do you notice this behavior occurring there as well or is it only limited to the SMS zone?

Hi Noris! Imagine this:
before roon update when i wanted to play music (eg. coming from work), I woke up my ipad or iphone or Macmini and push a little play icon. after2-4second music palys
now: it is like this: I open ipad remote and see purple notiffication or smoething else, when I want to play some music from my library I cant there is some other notiffication. I have to login to my core macmini kill roon proces and restart it. wait few minutes, then hurrey musc plays…BUT it can stop playing in any minute or hour, You never know when,
Why did You do it - this badluck roon update. In my audio setup everything works flawlessly except roon and tidal integration.
So what I need:

  1. Facts - this whole problem is on YOU
  2. You dont have any idea how to fix it.
  3. I send you my logs 3times but you never dowloaded
  4. It taking too much time - I really like roon (its a grate software) but some dev kill seamless tidal integration.
  6. If it requires more money I’m prepared. Can I buy a premium support? paypal or card.
  7. Usually money can repair every audio sysytem so be so kind and tell me the price for your work.
    cant wait for your answer
    And yes problem stays with every zone

Hi @Pawel_Rybak,

Noris spoke with me about this today and I wanted to follow up with you. I had worked with you previously on this and it looked like things were working for you for some time until the issue returned.

To be clear, this is not something that is affecting a vast majority of our customers. For most, TIDAL continues to work without issues. There have been some reports of issues with the login procedure and we are testing improvements to that process which we hope to release soon. Note that this is strictly with the login process, and that TIDAL playback is not affected in the way you’re seeing here in those cases.

What I did with you previously, and what Noris is trying to do now, is work with you to better understand what makes your setup different than the thousands of similar setups where TIDAL integration is working correctly. I’m not saying this to discount your report, but understanding and resolving this issue will require some troubleshooting since this isn’t something we can reproduce in-house and it’s not something we are seeing widely reported.

Testing things like what Noris suggested above will help us to narrow down the issue. You mentioned previously that you used your Roon Core on another machine without issue for some time as well. This narrows things down to something specific with this Core machine and possibly the way it interacts with the network.

Your issue is something that has been discussed not just between me and Noris but with our QA team as well. Our entire team has monitored and provided feedback on this issue and we are confident that we can help you get up and running here with a bit more troubleshooting. If you have any ideas about what makes your setup different than the thousands of other similar setups that do work, I’d be happy to present that theory to the team. For now, though, our recommendation is to continue forward with the troubleshooting that Noris has recommended above.

If you have any questions please do let me know!

Thank You for long email. I didnt answer because I dont belive You can help me. I erased roon folder and rebuild whole data base it takes 3days to fully index all song (very annoying). From that point everything works ok. No problem with roon - tidal interface. So this is a solution for me to rebulid my database every month… pretty nice for 500dollars software…
Now few more information:
to Noris - Yes it happens on every output - bluetooth speaker, apple tv.
few info about my network: My internet provider suplied me with modem/router it acts as a switch than with a short Cat6 is my cisco router and my mac is connectted to cisco. my sms-200 is connected with ethernet cat5.
Any logs or other info?
I think it I will write when problems come back

Hi @Pawel_Rybak,

We have recently made some improvements to our TIDAL login flow with the latest build of Roon which we released yesterday (build 536). Can you please upgrade to this build if you haven’t already and verify if it helps with the TIDAL login issues?

Is the Cisco the router in this case or is the ISP modem/router combo acting as the router? If you’re using the Cisco router instead of the ISP one, you might want to look into putting the modem/router combo unit into Bridge Mode, basically removing the DHCP Server from it and having it act as just as modem. Right now if you have the two routers both active, you could be creating a double NAT situation.

Thanks for explanation.
So far so good. Usually it takes about 3 weeks for problems to show…
Stay safe

1 Like

Hi Noris!
I updated core. Rebuilded library. 2 days ago some tidal roon problem. I gave You my setup twice. Dont ask me to that third time. I now people have this problem, please help

Some problem. Hope for new update. Nothing works: deleting roon cache, google dns, restarting core, rebuildig lubrary. Didit 3-4 times…

Hi @Pawel_Rybak,

Did you get a chance to investigate my previous suggestion? Is your modem/router combo unit now in Bridge Mode and the primary router is handling the networking side?

A post was merged into an existing topic: Cannot play from Tidal. Too many failures. Playback stopped

Yes i have double nat problem. cannot put mu isp router to bridge mode.
But this setup is few years old and problems showed 3 monts ago…