Roon not playing music on Bluesound after some time

I’ve been experiencing the same issue with my Blueosund devices for the last couple of weeks. Roon will queue up the music, but, will then wont play it. Although, via USB from an iMac to a Sennheiser headphone amp or iMac system output still plays fine. I believe, but can’t be absolutely certain that the issue started with the last Roon update. I’m also on version 1.7 (build 571).

Roon is running on a Roon Nucleus, trouble end-points are a Bluesound Node 2 & Flex. I’ve found that even if I’m only trying to play back stored music on the Nucleus, I have to sign out of Tidal (which wont load) and back in again and then reboot the Bluesound device that I wish to play on, after which it usually works again. But as you say, it then stops working again by the next day.

Needless to say, it’s driving me nuts.

Hi,

The Roon @support team prefer one topic per customer’s issue… so they are able to track it and focus on each individual problem. hence I split out your topic.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hi @SuperNate,

Can you provide some details on your networking setup? Are the Bluesound devices connected via Ethernet?

Hi Dylan

The Bluesound devices are connected via Wifi, as is the Roon-functioning iMac mentioned earlier. The modem/router is a Technicolor TG799vac.

My stored music collection is on a SSD inside the Nucleus. Streaming is via Tidal.

Hope this helps.

Hi @SuperNate,

If you try connecting the Bluesound devices via Ethernet as a test, do they then work as expected?

Hi Noris

I have tested the Node as requested and not looking good so far - by which I mean;

Once connected via ethernet, I attempted to play from Roon but the same problem - nothing happened.

I then rebooted the Node and tried again but still no playback.

I then signed out of the unresponsive Tidal (navigating to the Services menu shows a spinning loading circle next to the Edit button), signed back in, tried Roon again, no playback.

I then rebooted the Node once more after which Roon then worked.

The reason I say that it’s not looking good is that these are the same steps I seem to have to take to get things back up and running on WiFi. But, I’ll attempt to play something again in 24hrs and report back.

Curiously, every time I do get back up and running, the first track I play only plays for 2-3 seconds before pausing itself.

Hi @SuperNate,

Thanks for running those tests. I suggest that we try a cache clear as the next step, perhaps this will help:

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to /Library/Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Firstly, the Node was working on ethernet 24 hours later, however, failed again when I returned to WiFi.

I cleared the cache as instructed using the steps above; the Flex came back to life for one track (after pausing itself 3 seconds in as per usual), but failed again as soon as I selected another track. Didn’t have any effect on the Node.

Hi @SuperNate,

Just to confirm here, you are saying that the Flex had the same behavior, weather plugged in via Ethernet or on WiFi?

Do you have the latest BluOS firmware installed on both the Flex and the Node? You should be able to confirm in the BluOS app.

The Flex is showing the same behaviour, yes. And yes, both Bluesound devices are up to date.

After a couple of days post-clearing-the-cache as instructed, playing back stored music has been working, however, Tidal is still bringing everything to a holt. To expand;

I can, for now, play back music stored on the Nucleus, but, as soon as I select a track/album from Tidal, I’m back to the original issue where it cues up the track/album but refuses to start playing after which if I then try to go back and play from my stored music, it will no longer play that either. If I go to the Tidal tab, I get a blank loading screen with animated Roon loading icon. To get back to playing music, I have to either sign out and back in to Tidal via Roon and reboot, or sign out and reboot without signing back into Tidal.

Come to think of it as well, around the time when all this started happening, I seem to remember constantly loosing Roon connection to Tidal and having to sign back in over the period of maybe a week? Not sure if that helps you. I haven’t had any issues with Tidal when using the Tidal app.

Hi @SuperNate,

Can you please reproduce this issue and let me know the exact local time + date + track you play that exhibits this issue? Once I have the timestamp, I can enable diagnostics mode on your Nucleus and see if there are further clues contained there, thanks!

Hi Noris

Since your last reply and without any further intervention, it’s all of a sudden decided to behave itself.

Figures crossed, but, I will certainly let you know if the issue re-appears.

Until then, thanks for your assistance so far.

1 Like

Thanks for the update @SuperNate, do keep us posted if the issues return.