Roon not playing to compatible device (Trinnov Amethyst) [Resolved]

I just installed Roon (version 1.3, build 269) for the first time and it imported my library of 18,000 tracks from a Synology NAS. Roon recognizes my Trinnov Amethyst but when I play a track there is no sound. It shows the Amethyst as the zone but the play button in the “zones” window is grayed-out while the System Output play button is active.

System information:
Roon version 1.3 (build 269)
O/S = OSX 10.9.5
Computer: Mac Mini
Storage: Synology NAS

Hi @Gabriel_Bustamante ----- Thank you for the report and sharing your feedback with us. Both are very appreciated!

Moving forward, to help us better understand why you are experiencing this behavior with the Amethyst, may I very kindly ask you to please provide me with the following information:

  • A screenshot of the “playback” settings being used in Roon with the Amethyst. If you are making use of the DSP engine please be sure to include those settings as well.

  • I know the Amethyst has numerous input/output options. Can you please provide further insight into the configuration of this endpoint?


Hello Gabriel,

do you have the latest sw version on your Amethyst ?

Yes, they updated my Amethyst for the Roon update on 10/9/17 with version 4.2.5
FYI, I’m using the Network input on the Amethyst and it’s connected via Ethernet to a switch where the NAS and Mac Mini (Roon Core) are also connected. Roon only plays to a zone called “System output” which doesn’t sound. The only other zone is the Amethyst but it shows “Nothing playing”

See screenshot attached
The Amethyst is set to the “roon” source.
The Amethyst, NAS and Mac Mini (Roon Core) are all connected to a switch via Ethernet

Here’s another screenshot showing the available zones with “Nothing playing” on the Amethyst
52 PM

Check if there a difference between my sw and your sw 4.2.5
here are some screenshots from my application

Device setup




“zone grouping”

Zone settings


“zone setting”
Zone setting 02

Zone group


Zone group 02

Transfer zone


“transfer zones”
Transfer zone 02

It looks like I have the same menus. I changed some of the settings to match yours in the General and Playback tabs except for the Channel Layout which I kept at 2.0. After making the changes, the Trinnov’s play button is now active and the play indicator shows movement when playing a track, but I still get no sound. I still need to review the Zone Settings, Group Zone and Transfer Zone this evening. Thanks

Hi @Gabriel_Bustamante ---- Thank you for touching base with me and providing the requested feedback!

One piece of information I am a bit unclear of still is what the Amethyst is feeding into. I understand that it’s communicating with network via an ethernet connection to the mentioned switch but can you please confirm what the chain of communication looks like after that?

Lastly, please also provide the make and model of switch that you are implementing.


The entire audio chain is a follows:
Mac Mini* (modified by Mojo Audio), Synology NAS and Trinnov Amethyst are all connected to a D-Link 1000M switch. An Apple Airport router is also connected to the switch for internet service. The Amethyst is connected via balanced interconnects to a pair of Pass Labs XA 60.5 amps. Roon Remote is installed on an iPad but not used yet.

*Roon Core audio is installed on the Mac Mini.

I checked all the zone settings and don’t see anything that may help. I even tried transferring the System output to the Amethyst and still get no sound

Hi @Gabriel_Bustamante ---- Thank you for your patience and my apologies for the delayed response.

To bring you up to speed we would like to discuss this behavior you are experiencing with Trinnov and are working on getting some feedback from them. Once I have received an update I will be sure to share any information we receive in a timely manor.


Update: I was able to get Roon to play music to the Mac’s internal speaker by changing the the System Output zone Playback options to a max sample rate of 96kHz and a max bits per sample to 24. These are the same settings as the Amethyst zone’s Playback options but still no sound. I’ll wait for your instructions.

Hi Gabriel,

If you can give me the serial number of your Amethyst and make sure it is online, I can set up a secure connection to it and look to see what may be going on.

Jon Herron
Trinnov Audio

Hi Jon,

It’s 176. I appreciate your help with this.



Hi Gabriel,

Try it now.

There are two important steps to getting our preamps to work properly with Roon:

  1. Update to the latest software (which you had done)
  2. Configure an input to use the “Roon Ready” Input Connector.

We do not do this last step automatically with existing installations because we do not want to inadvertently over-write one of your existing inputs. (New machines have this input fully configured.) I just jumped into your Amethyst and saw that the roon input was referencing a different input connector… hence your difficulty.

Please let me know how it goes.


Thanks Jon. So is it now referencing the Ethernet connection into the Amethyst (similar to the Network input)?

Hi Gabriel,

The Roon Ready “Input Connector” is rather more than a pointer to your LAN. It also includes the entire Roon Advanced Audio Transport (RAAT), the software that allows the Amethyst to operate as a Roon Endpoint. The default NETWORK input uses UPnP/DLNA. Both use your LAN, but that’s about all they have in common.

IMHO, there is no comparison. Roon is the way to go.


Thanks, I’ll try it this evening

I just tried to play something and am still getting no sound