Roon not recognising connected devices

After 6 months of enjoying Roon playback, it suddenly stopped working–meaning it did not output the music to the Perfectwave Dac and could not be controlled by the Mac Ipad which had been running roon for the last 8 months. Roon will only play back to my iMac, which is where Roon was downloaded.
My system consists of the following devices:
1/ Imac, MacOS Sierra, Version 10.12.6.
2/ PS Audio Perfectwave Dac Mk II.
3/ Cocktail Audio X50D.
4/ Mac Ipad, Version 11.4, Model MK9Q2Z/A–which I bought to specifically remote control the Roon system.

Roon can detect the library files on the Cocktail Audio–but is now unable to play those files through the Dac.
The network is intact as I had, previous to having Roon, been using JRiver. I am still able to play the 2 stored Libraries through the Dac, using the iPad as a remote controller. So I don’t think it’s the network connections.

The technical people who set up the Roon/Dac/Cocktail Audio configuration have been unable to get the system working as it did when we started in January, 2018, and which was working fine up until 10-14 days ago. So, we are at a loss as to why we can’t get Roon to recognise the connected devices–something which I
understood Roon did automatically.

Please Help Me. Not only can I NOT fully utilise the Roon features–but I cannot use TIDAL either,

Look forward to you solving this problem for me.

Thanks. Gary D Dere

Gary, have you examined your network to see if your devices (eg DS) are found on the network (either within Roon or outside of Roon). I would suggest you reset your network (modem/router) and verify the correct IP addresses. Sounds like a network issue to me.


Thanks for reaching out, @GARY_DERE!

May I ask that you please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating. Based on your description it sounds like there may be some networking difficulties at play here, so knowing more about your network will definitely help!

Since noticing this behavior have you tried power cycling your Core machine and networking hardware?

Have you tried using the TIDAL app or web player on the Core machine? Are you unable to play TIDAL there as well or just not in Roon?