Roon not recognizing Devialet Phantom

Core Machine (Operating system/System info/Roon build number)

MacBook Pro (Mac OS X (Mojave)/Roon 1.7 (Build 505)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

On WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet Phantom connected via WiFi.

Description Of Issue

This is the third Phantom I own. The other two were recognized by Roon. Using one phantom at a time. I gave each a different name in Roon. This third phantom does not appear when I launch Roon.

Hi @Daniel_Castro,

Has this Phantom ever appeared in Roon?

Are all of the Phantoms connected via WiFi? What is the router you’re using?

This Phantom has never been recognized by Roon. All phantoms we’re connected via WiFi. The router in use is AT&T Uverse model 5268AC FXN.

Hi @Daniel_Castro,

Is the 3rd Phantom up-to-date on latest firmware?
Are there any notable differences between the Phantom that’s not working vs the other two?

Third Phantom is up to date on the latest firmware. There are no differences between the Phantoms. All have connnected to the WiFi network but the third is not recognized by Roon. I am only connecting one at a time.

Hi @Daniel_Castro,

Does the 3rd Phantom receive an IP address in your router configuration? Is there any change if you try to factory reset it?

I don’t know how to determine if the Phantom receives an IP address in my router configuration. How can I find this?

Hi @Daniel_Castro,

An app such as FING can be used to run an IP search to verify if all Devialets have IP addresses. The other method would be by logging into your router (typically this can be reached at but for the router aspect you may want to refer to instructions from the manufacturer.

In case you haven’t done so yet, I would also suggest rebooting the Networking Gear, Devialet and Core (in that order) to see if it helps.

I tried rebooting with no success. I’ll look into FING.

FING shows the following IP address for the phantom Can I use that to have Roon find it?

The address is There are several devices with similar addresses except for the last three digits (110, 109)

What is the IP address of your MacBook Pro running Roon? All of your devices should be on the same subnet 192.168.1, so I would think there would be a lot of devices with those same first digits.

It may be a pain to do this, but have you tried swapping the non-responding Phantom in the same setup as a responding one? The Phantoms do odd things like switch to Network over powerline, and you don’t really have control over that. Might be good to know if it is the device, per se, or the location.

Hi @Daniel_Castro,

No, there’s no way to manually specify an endpoint IP.

I would verify this aspect next:

The MacBook Pro IP address is

I have successfully connected the other 2 Phantoms. I will try connecting one of the others again to confirm.

Hi Noris,
I have disconnected and reconnected the Phantom and also took it through the connection sequence involving pressing the back button three times. Is there a different factory reset sequence?

Hi @Daniel_Castro,

The factory reset instructions from Devialet can be found here:

Can you please give those a try?

I was able to determine the reason for this problem. Apparently my Phantom is not airplay compatible.

The Roonbridge endpoint like Danny talked about works very well with Roon. I have ethernet to the Roonbridge and SPDIF out to the Phantom. That allowed me to smash my Dialog to pieces with a sledgehammer (which gave me much joy). It works better than it ever had before. It shows up as the Ropieee device, not the Phantom.
To make it wireless you could probably just put a wireless access point in front of the whole thing.
Thanks for the update. It’s helpful to learn how all these things work, and sometimes don’t work.

That’s strange… I thought all these phantoms were the same model, no?

If it’s not airplay compatible then the next best solution would be a RoonBridge.

1 Like