Roon not recognizing my Mcintosh preamplifier

Core Machine (Operating system/System info/Roon build number)

Dell OptiPlex-3040 running the Roon operating system (Roon Version 1.7 (Build 528)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Running on an Apple Network running on Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mcintosh C2700 Tube preamplifier

Description Of Issue

Every time I power on my PreAmplifier and load the Roon Software on my iPad, I am asked to select an Audio Zone. The Mcintosh preamplifier doesn’t display as an available defice to select. I have to go into Settings, Audio, where I see the Mcintosh preamplifier with the message “Device Not Found” under the devices listed as being Connected to the core. I select the gears, then select Retry and the preamplifier is ready to go. Once it is enabled it plays fine. However, each time I turn off the preamplifier, I have to go through this process again. There surely has to be some way to keep the device active so I can simply open up the app on my iPad and begin playing music. Thanks.

Are you using USB? With my C52 it doesn’t show In Roon unless I have the USB input selected in my preamp. If the input is on something else like my TT then it doesn’t show in Roon. As soon as I change input to USB it appears as an endpoint.

I typically just have my input set on the USB input as I don’t use other inputs very often. I haven’t tried changing inputs and changing it back to USB to see if it recognizes it. I will give that a try as it would be easier than drilling down into the app every time to reactivate it. It still is not the way I would think it should operate.

Hi @Mike_Hedge,

Are you using the latest firmware version on your McIntosh PreAmp?

As far as I can see on McIntosh’s web site there has been an update to the Windows USB driver software, but I am not using a Windows operating system. I wouldn’t think that would make a difference when I am connected to a computer running ROCK.

Hi @Mike_Hedge,

Do you by any chance have another PC running a standard OS that you can try to temporarily use as a Roon Core? I wonder if this is related to having ROCK (technically MOCK) on your OptiPlex.

I loaded Roon Server onto my MacBook Pro and connected via USB to my Preamplifier. I used my iPad Pro to control music playback. When I powered down the McIntosh and turned it back on, the preamplifier came back online and was available. I am not sure what the next steps with the OptiPlax might be.

Hello @Mike_Hedge,

It’s possible that the McIntosh could be powering down its USB input while other inputs are selected. This could interact with the USB detection on the USB host—we often see DACs that connect to one computer fail on another because of how the USB 5V power pins interact on a per-motherboard or per-OS basis.

I would experiment with different power up and inter-connect order-of-operations with the Optiplex and McIntosh to see if you can narrow in on what’s causing this behavior.


Thanks. The person who set up the Optiplex for me disabled all the power saving features thinking that might have something to do with the USB powering down. No luck. I never turn on and off the Optiplex. It stays on all of the time and only power up the McIntosh with this single input as I don’t have any other devices I run through this preamplifier, other than I use a passthrough mode to allow the preamplifier to pass the signal to my mains when I run through another processor for my home theater application, which shouldn’t have any impact on this port. I have also tried all of the different USB ports to see if any of them were powered differently. No luck with that either. I am out of ideas other than maybe configuring another computer.


Hello @Mike_Hedge,

My only next step would be to determine if this issue is listed to Roon playback by testing with another audio application on your Optiplex (Chrome YouTube playback, iTunes, foobar2000, etc). If other applications are unable to play to the device, in all likelihood there will be little we can do to resolve the issue.


I would test by putting Windows on the Optiplex and seeing if the same symptoms occur. I would make a database backup first, so you could restore it. That way you can narrow down whether it is the Optiplex hardware, or, ROCK on the Optiplex hardware.

ROCK is specifically tested, and has the drivers for, the Intel NUCs on the approved hardware list. Using a PC not on the list can work, I know I’ve done it many times over different hardware, but, it is not a guarantee.

(Personally, since I have a ton of drives lying around, I usually pull the OS drive, use a new one and if the test didn’t pan out, just pop the original drive back in for a quick return to the original setup)

Thanks John. My IT guy asked me yesterday if I wanted to try to install Windows 10 on the computer.
I am concerned about a Windows computer on my network without the necessary virus software, etc. As I have only Apple computers on my current network, I was not that excited about having a Windows computer unless I knew that getting it hacked was a very remote possibility. My company went through a data breach last fall and after I saw what happened to our Windows computers, I am a little gun shy to use them right now. I have been trying to repurpose a computer we already have at my business, but if I have to buy something, I would likely either purchase a NUC or an Apple Mac Mini. I haven’t really researched which would be preferable.

One thing I found out yesterday as I was reading the setup information for the NUC was to set the bios to use legacy setting other than UEFI. When my IT guy set up the Dell, it was set up using UEFI. I moved it to Legacy yesterday and at that point it didn’t recognize my hard drive. Not sure if that was because everything was set up with UEFI enabled. He is talking about rebuilding a server using an IBM computer that we have retired at my company to see if it interacts differently. Other alternative before going the windows route may also be to reformat hard drive on Dell and reinstalling OS while in the Legacy mode.

I did make one interesting discovery yesterday. When I boot up the computer from a powered off state and then turn on the McIntosh preamplifier, the preamplifier is immediately available when I power it on. So the disconnection would appear to happen during the powering down of the preamplifier.

I appreciate your ongoing suggestions. I am sure I will get this figured out at some point.


HI Mike,

Your issue seems that ROCK on that specific hardware has an issue with detecting USB connections which drop (i.e. device was turned off) and are then restarted.

FYI: ROCK OS is specifically tested for use with the approved hardware. The approved hardware list is found here:

Now, the Optiplex is not on that list. In fact, only official and specific models of the Intel NUC are on the list. ROCK on non-approved hardware, colloquially known as a MOCK (i.e. Fake ROCK) build, is not tested; and using non-approved hardware falls in the tinkering area.

Here’s a relevant quote from the KB, as it probably relates to your USB issue (Bold items are not added by me but exist in the KB article).

Will ROCK run on my existing hardware? How about this other hardware?

We have only tested with the above-mentioned NUCs. It may work with other machines, but the drivers needed may not exist there. Try it out and let us know. We can not comment on whether any different hardware will work, as we have not tested it. We will not make any guesses, educated as they might be.

If you do manage to get it to run, that’s great, but we can not guarantee it will continue to work with future builds. Consider yourself warned.

So, my suggestion is to ditch the Optiplex and build a real ROCK NUC using approved hardware, if you want to go with ROCK.

OR, you could get a Mac Mini run MacOS and load RoonServer on it, good because you are familiar with MacOS.

1 Like

Thanks for all of your assistance. I have one more thing to try before going that route.


Problem solved. I swapped SSD’s and started the setup process from scratch. In questioning my IT guy today, I found out that he liked Ubuntu and hadn’t followed the instructions exactly as laid out and was trying to run it using Ubuntu. The RockOS system hadn’t been set up on the box as I asked him to. I replaced the SSD, downloaded and installed the RockOS, following all of the instructions as laid out and everything runs perfectly. I appreciate your advice Rugby and should I have any further issues I will definitely go the NUC route. Thanks. Mike


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.