Roon not recognizing my NAS after upgrading Router

I have rebooted all devices multiple times to now avail. I am struggling to figure out how to reattach a NAS storage device. Any suggestions would be appreciated.

Perhaps your new router uses a different IP address range to your old one? This happened when I bought a new router, went from to

Start a new support thread and fill in the system information.

How do you determine your router address?

Thanks. I have already done that.

You’ll need to access the software, through a web browser, that allows changes to the router settings - instructions should come with the router - on mine it is - then you can identify the address range and the ip addresses of connected devices. You can make sure the ip address of the NAS is correctly identified in Roon/Settings/Storage

I found my new router IP address and its different than the one in Roon settings but I am struggling with how to edit the address.

Make and model of router?

Even if you change the address range back to where it was chances are your Roon Core will still get a different IP than what it had unless your Core is statically addressed.

Your router will give you a list of attached devices. In that list, find the ip address for your NAS and go to Roon/Settings/Storage and add the ip of the NAS in the same format as in the screenshot below, including the folder where your music is stored on your NAS (in my case \music). I’m assuming your core is not on your NAS:

1 Like

Have a look here

Hey @Kenneth_Brown,

In checking your system diagnostics it appears that you were able to get your NAS reconnected. Can you please update us on your current status? If you’re still having trouble and need help we’re happy to lend a hand! Thanks!

Thanks for checking in. I was able to reconnect my NAS.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.