Roon not releasing audio back to Windows 10

Core Machine (Operating system/System info/Roon build number)
Qnap - TS-1685 Intel XEON with 32GB RAM
Version :** 1.7 (build 511) stable
QPKG-Version :** 2019-06-09
Process ID :** 5361

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet connection via Netgear M5300-52G
No Wi-Fi is used

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
PC running Windows 10 Pro 1909 O/S build 18363.657
Roon v1.7(build 511) stable 64bit
Roon Bridge v1.0(build 172)

USB to Astell &Kern L1000 DAC/AMP
USB to Chord Hugo TT

Description Of Issue
Once Roon is used to play music, audio is not released back to Windows 10. Even after closing Roon, disabling any Sound Devices, no audio will play again, EXCEPT for Roon.

Via ASIO and WASAPI, this occurs.
Only a reboot restores audio to the Windows 10 machine.
But once Roon is played again, no more audio can be played by any other Windows program than Roon.

Hi @rpadole,

Does the same behavior occur if you only have Roon Bridge running on the Windows PC and use an audio endpoint?

Great test idea!
Just tried it and without running the Roon front end on the PC and only playing via an iPad and Roon Bridge…audio is once again only available to Roon and no other Windows resource. (Using Sound Control Panel and TEST).
P.S. I had freshly reboot PC before testing.

To reiterate - this bug is still an issue.

Any other suggestions for a fix?

Hello @rpadole,

Does this behavior impact just one of your zones or does it occur on both the Hugo and the A&K?
Is there any change in behavior if you disable Exclusive Mode when using the WASAPI output?

WASAPI with Exclusive Mode turned off, does correct the WASAPI issue. Thank you.

However, the my preferred playback method is ASIO for as it exploits the full capabilities of my DACs.
I notice there is no way to turn off Exclusive Mode with ASIO.

Is there any other method to cede control back to Windows once Roon is done? This was not an issue in the past.

Now running - Roon 1.7 (Build 521)

Hi @rpadole,

Apologies for the delay in getting back to your here and glad to hear that WASAPI without exclusive mode is working as expected. I have tried to reproduce your findings on my end and I have been unable to do so.

Is there any change in behavior if you temporarily host the Roon Core on your Windows PC? I would advise making a Backup of your current database (for safe-keeping) and then you can you to Roon Settings -> General -> Disconnect -> Use this PC.

These steps will set your Core to the PC, and you might be presented with an Authorizations page asking you to un-authorize the QNAP, which you can do so. You can switch between Cores as often as you’d like, but you are limited to one active Core at a time is all that page is saying.

Does the same behavior occur when the QNAP is not the Core?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.