Roon not seeing NAS when connected to iMac

I have my large library stored on a NAS drive(Synology) I have me NAS plugged into my late 2013 Apple IMac via The Ethernet plug. Both Amarra and Audivarna apps see and play from the NAS in this set up but the Roon app doesn’t. I have the NAS set up this way due to the poor internet service/connections in my home. When I have the NAS plugged into my router it switches IP addresses twice a week which means switching to the new IP address and re syncing 13k plus albums which is a day and 1/2 process. Any way to get Roon to see the NAS when plugged directly into my Mac computer?

Can you plug it in via usb? With an Ethernet cable you’ll need to set a static ip address on both devices.

No I can’t plug the NAS in Via usb do to the fact the NAS has a mini computer in it so it’s usb dosent allow another device to control it. Tried it.

Any help in setting up a static IP address would be greatly appreciated!

Have to be careful with static IPs. What is better is IP address reservation in your routing software.

What router do you have?

Well, I’m sure we can set the NAS up for static in its configuration GUI, but this isn’t really recommended. It might be better to set your routers dhcp function to use DHCP reservations.

I have the I got the one piece router/modem from Spectrum

What is this and how do I do this?

First see if you can log onto your router software. My router is located at I don’t know how Spectrum addresses its routers, but try either or, or call up Spectrum tech and ask them what the address is. Enter correct address in a browser window.

If one of those addresses are good you will find yourself at the opening page for your router software. It will ask for a Userid/password. Usually, unless it’s been changed (which it probably hasn’t), that would be admin/password or user/admin or some combination like that. Google the Spectrum router model to find the default combination, or call up Spectrum tech support and ask them what the defaults are.

You should then see menus/submenus. Find one that speaks of something like Address Reservation. In that submenu, in the appropriate place enter the MACD of your NAS and associate it with an IP of your choosing, but not one that’s already in use. You can, however, use the IP that’s currently assigned to your NAS. Don’t forget to reboot router.

You now have reserved that IP and associated it with your NAS. No more need be done.

Or you can have a Spectrum technician come to your house and do it for you. Before you spend money on that, ask Spectrum whether their software lets you set a reservation, some don’t.

Just setting static IPs on your devices isn’t a good idea because the DHCP process within your router might reassign that IP to another device, in which case you will get IP collision.

Hmm, seems like this should work, thereby avoiding having to set static IPs or address reservation. Did you change the file address in Settings->Storage after you connected to Mac. They won’t be the same as when the NAS was on the network.

@support ???

Hello @Artez_Eugene,

If you wish to have the Mac hosting the NAS then you can follow this Knowledge Base Article as a guide. I would however go with @xxx’s suggestion and perform an address reservation in your router so that the Mac does not need to be powered on all the time to access that share.

If you can provide the model/manufacturer of the router you have I can take a look to see if there is a guide available online for Address Reservation. Also often times for these modem/router combos, the password to get into the router settings page is located physically at the bottom of the unit itself, but asking Spectrum will not hurt so I’d give that a shot too. Please let us know how it goes.


Man sounds like a nice undertaking. I’ll give it a try when I get home tonight.

Anyone have any thoughts why Roon dosent reconize it in this set up when Audivarnia does?

Tried sharing but the NAS drive doesn’t show in any of the screens in the knowledge base you suggested?

This is a pic of the NAS as seen by my IMac when connected via Ethernet from the Mac to the NAS but when I go to add a folder in Roon it doesn’t see however audivrvana sees it with no problems?

Here’s a pic of Roon but it doesn’t see the NAS?

Here’s a pic of Audirvana and it sees the NAS and the folders in the NAS with no issue when the Mac and NAS are connected to each other via Ethernet

Hello @Artez_Eugene,

Can you post a screenshot of your “Sharing” settings? This should look something like this:

You would need to enable the share there, add it as a shared folder, and then enable “Share Files and Folders via SMB” (as outlined in the documentation).

The NAS will not automatically show up in the sidebar, you need to press “Add Network Share”, and then post the ComputerName.local (Gregs-iMac.local in the above screenshot) into the Network Share Location along with your OSX username and password:

All of these steps are outlined in the documentation, please let me know if that helps.


I just got your reply I will try this and update you

Thanks for those screenshots @Artez_Eugene, I believe I see the issue with the configuration you have in place.

First, I would go ahead and add your NAS as a shared folder on that list:


Make sure that you enable “Windows File Sharing” for that NAS Location under “Options…” after adding it on the Sharing screen.

Then, for the “Network share location” in Roon, please place this information on that line:

If your music folder for the NAS is not called “Music” then please change it to the actual folder name and insert your username (which appears to be “imac”) and password to log into your computer underneath.

All of these steps are highlighted in the Sharing folders Knowledge Base Article (<- this is a clickable link).

Please let me know if they work for you or if you have any other questions!.


In Roon do I use the name and password for the Mac or for the NAS?

Also that’s the NAS in the top folder under the shared folders tap