Roon not seeing RAAT devices when Naim app does

Roon Core Machine

Intel NUC- NUC5i5MYHE - I5 5300U, 8GB RAM, 120GB M.2 SSD, 4TB2nd SSD

Networking Gear & Setup Details

TP-Link AC2800 Wireless MU-MIMO Modem Router
Netgear GS108T Gigabit 8 port Hub
Hardwire Ethernet connection to ROCK
TP-Link Deco M5 Mesh wifi network

Connected Audio Devices

Naim ND555 Streamer with hardwired Ethernet connection to same hub as ROCK
Naim Muso 2nd gen x2
Naim Muso SQ 2nd gen
Naim Unitiqute (connected via squeeze2upnplms plugin on Win10 headless client)

Number of Tracks in Library

40,000 tracks

Description of Issue

All Naim units are seen in Naim app and play with no problem. (see attached image)

Only ND555 and one of the three Muso’s are seen in Roon Ready list (see attached image) and can be seelcted
One Muso is seen via Airplay, but not the 3rd![Roon ROCK|690x375]
Only started happening after the installation of the TP-Link AC2800 Wireless MU-MIMO Modem Router

(Some?) Netgear managed switches come with a default IGMP configuration that prevents Roon from discovering some remotes and endpoints. In my experience, you can fix that issue by logging into the switch’s Web management page and turn off IGMP snooping.

Thanks. I’ll check that but it has worked in this configuration previously.

If it only started after the new router then I’d check that it has IGMP set. If it is set then switch it off and vice versa.

Hi. Did that - no change. Tried rebooting the ROCK after that change. Can only see one Muso now. Not even the ND555!

A bit exasperated with all this high value kit not working with Roon after it did before!

You’ve got at least two subnets being used. Everything needs to be on the same subnet.

1 Like

Ensure you mesh system is not assigning IP addresses via its own DHCP server. It should be in bridge mode so your router deals with DHCP for the entire network. You have two networks running by the looks of it with some devices on one and some on the other. Roon will only see devices on the same network subnet as the core. Naim app will see them as it’s likely on the same subnet as the Naim kit, where your Roon core isn’t. Remotes work ok across subnets which is why your can still use the remote, but as stated core won’t see endpoints not on the same network.