Roon Not Starting Correctly

Hello everyone.
This is my first message and this is the discussion most similar to my problem I found. If I made a mistake to post here, I apologise but I think it can be useful here.
I don’t think I have the same problem as stefano but the effect is identical and arose practically at the same time: I try to launch the program but nothing happens.
I’ve been opening a ticket for many days but I haven’t received support from support yet.
It all started after the last update of windows 10 and I think it all depends on that: I compromised the boot of the operating system with the words “inaccesible boot device” .
Through a restore point I managed to reactivate the boot and now the PC works. I disabled automatic updates because after the first crash, immediately after the update, it repeated the lock.
Now, however, the operating system does not detect audio devices, despite the fact that everyone appears correctly in the management of the maintenance menu devices and the drivers are all updated. Despite all this, I can send the digital stream to the dac with usb cable, reading the files with jriver.

But Roon doesn’t start, it doesn’t even tell me mistakes, it just doesn’t open.
Reports like this continue to accumulate in the Logs folder:

04/21 22:32:06 Info: Starting Roon v1.8 (build 931) stable on windows
04/21 22:32:06 Trace: [roondns] loaded 19 last-known-good entries
04/21 22:32:06 Info: [URI] Checking that FriendlyAppName == Roon
04/21 22:32:06 Info: Registering for URI scheme: Roon, roon
04/21 22:32:06 Info: URI scheme executable path remains "C:\Users\MuzAudio\AppData\Local\Roon\Application\Roon.exe" "%1"
04/21 22:32:06 Trace: Checking if we are already running
04/21 22:32:06 Trace: Nope, we are the only one running
04/21 22:32:06 Info: Is 64 bit? True
04/21 22:32:06 Debug: PathForResource, filename: winversion.exe
04/21 22:32:06 Debug: PathForResource, candidate: C:\Users\MuzAudio\AppData\Local\Roon\Application\winversion.exe
04/21 22:32:06 Debug: PathForResource, candidate: C:\Users\MuzAudio\AppData\Local\Roon\Application\100800918\winversion.exe
04/21 22:32:06 Trace: [realtime] fetching time from NTP server
04/21 22:32:06 Trace: [broo/imagecache] loaded 9644 cache entries from C:\Users\MuzAudio\AppData\Local\Roon\Cache\brooimages_1\index.db, current: 512mb / 572mb
04/21 22:32:06 Trace: [orbit] init seq=5997, pending=77, spcount=7, uidcount=2
04/21 22:32:06 Trace: [realtime] Got time from NTP: 21/04/2022 20:32:06 (3859561926795ms)
04/21 22:32:06 Trace: [realtime] Updated clock skew to 00:00:00.5857415 (585,7415ms)
04/21 22:32:06 Info: 
Local Time:            04/21/2022 22:32:06 +02:00
Device Serial Number:  EB1DB3A1-5585-491A-874C-5CAA59818D5F
Roon Version:       1.8 (build 931) stable
OS Version:            Windows 10

Application Domain:    Roon.exe
Assembly Codebase:     file:///C:/Users/MuzAudio/AppData/Local/Roon/Application/Roon.exe
Assembly Full Name:    Roon, Version=, Culture=neutral, PublicKeyToken=null

CPU0 Description:      AMD64 Family 25 Model 80 Stepping 0 3201 MHz (64-bit)
CPU0 Num Cores:        Physical: 8 Logical: 16

GPU0 Description:      AMD Radeon(TM) Graphics 512 MB
GPU0 Video Mode:       1366 x 768 x 4294967296 colori
GPU0 Driver Version:   30.0.13014.8

SCREEN0 Name:          \\.\DISPLAY1 (primary)SCREEN0 Bounds:        0,0 1366x768

   Exception Source:      Roon.Client.Models
   Exception Type:        System.Exception
   Exception Target Site: ApplicationCommon.PickLanguageBrooX
   Exception Message:     failed to find broox file
   Exception Data:        none

   --[ Stack Trace ]------------
   Sooloos.Client.ApplicationCommon.PickLanguageBrooX(SooloosSettings setting, String& broolang)
       Roon.Client.Models.DLL, IL 80, N 214
   Sooloos.Application.Main(String[] argv)
       Roon.exe, IL 1331, N 3225

Thanks for your help.

Hi @Mauro_Emiliano_Demon ,

It seems a bit different as you don’t have IP addresses problems.

But the result is the same… :frowning:

Best regards.

I’ve been stuck for days.
I’d rather not uninstall Roon because I don’t have a recent backup of the settings and all the tags.

Hi michael, thanks for your attention.
I tried to disable the firewalls (in any case Roon is already among the allowed apps) but nothing happens.
My problem seems to be this:
"Exception source: Roon.Client.Models
Exception type: System.Exception
Destination Site Exception: ApplicationCommon.PickLanguageBrooX
Exception message: The broox file could not be found
Exception data: none "
I obviously don’t know what that means :sweat_smile:
I confirm that it showed up after windows update, presumably these two:

  • Security Intelligence Update for Microsoft Defender Antivirus - KB2267602 (Version 1.363.675.0)
  • 2022-04 Cumulative Update for Windows 10 Version 21H2 for x64-based Systems (KB5012599)

Mauro - I’ve moved your posts into a new thread.

From your last message, it looks as though something has corrupted the Roon installation on your PC.

I suggest that you do try and uninstall and then download and reinstall a fresh copy of Roon.

When you uninstall Roon, you will get the option to also delete your database and settings. Don’t do this - that way you will preserve your settings and tags.

You mentioned that you have already opened a Support ticket. How did you do this - I don’t see a Support Request from you in the Community Forum?

Mauro they are the updates I would expect to see, and I clearly have no idea what the messages mean either. Hopefully someone from @support can pick them up though. I just searched some of my logs and I have never seen a message regarding “broox” in any of them

If you try to move the RoonServer folder somewhere safe as a backup does the Roon app then restart.

Hi Geoff, from the site I sent a message to I was told that the request is being processed.
Thanks to everyone anyway, tomorrow I’ll try to do as you suggested and I’ll let you know.

So, last night late in the evening I did the test by uninstalling and reinstalling.
In fact, it seems that settings and tags have remained unchanged. At the start he no longer read the dac, despite being in use with jriver. I reinstalled the dac drivers and it recognised it. At a quick test everything worked.
This morning, however, when the PC restarts and then Roon releases this message as soon as I start playing:
“initialisation of the audio device failed”

What DAC do you have? Does it help to restart the DAC before starting Roon? Or vice versa?

I have already tried, but I have not had any result.
I have a North Star Design Supreme.
With jriver I can reproduce the audio, but now with Roon not.
from the Roon settings menu everything seems fine, however like last night it was playing … it doesn’t give me any indication of how to intervene.
I used the search button but even on the forum I don’t find discussions on a similar problem.

I would post the system log, but it’s a bit long … 830 lines.
If someone tell me what to look at in that flood of data, I look for the precise passages


Roon support staff are able to turn on enhanced logging and normally will ask you to upload the logs with the additional information.

Sadly you are unlikely to get anyone until Monday now as they do not work weekends.

So … I was able to ascertain the following situation:
the problem lies in the output of the audio stream in wasapi.
Because if I send the signal to jriver, or to the Oppo 105 (both in asio) Roon starts.
If, on the other hand, I send it to the North Star dac that has always worked in wasapi for me, it tells me “audio device initialization failed”.
As a counter-proof also the Oppo, if set in wasapi, has the same problem.
So asio yes, wasapi no.
Except my main dac always worked in wasapi, it never worked in asio (not even on jriver).

Hello @Mauro_Emiliano_Demon ,

Sorry for the delay in getting back to you here, are you still having issues with Roon? The error you were getting is interesting, it almost looks like either your system or the Roon install is missing a language pack, this is the first time I’m seeing such a trace.

Are you using any antivirus applications? Perhaps it accidentally picked up one of the files needed during the Roon install. I suggest you try to install Roon and RAATServer on your Core again and see if this helps:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.