Roon not working as it should

Hi. Roon is not loading properly. Cannot search for titles in Tidal, Tidal does not open properly, “unexpected error loading album. Please try again later (unauthorised)”. Also an alert appears “Metadata improver halted. Roon needs a software update”. However I am running V1.8, the latest version. This is the first glitch I have encountered with Roon and Tidal. Quite frustrating because solution is not obvious. Can you please help? Thanks in advance.

Always a good one idea to restart your core if you haven’t done this already.

There can unfortunately be the odd cloud glitch that leads to issues like you describe - which are usually sorted quite quickly.


Hi John B. Thanks for the reply. Have rebooted computer, restarted core several times but no improvement. This issue began for me around 24 hours ago and still persists. Just tried again, same issues. Thought it may be a Tidal issue but can access Tidal through BluOS Controller app so I presume my Tidal account and function is OK. So the issue seems to be with Roon. Any help much appreciated. Thank you all.

Tidal is working fine for me here in Dublin- which I know doesn’t help you much!

Also can be worth trying logging out of Tidal in Roon and logging back in again.


Thanks again John B. Logged out of Tidal in Roon then logged in again. Now have error message “error loading page. Please check network connection”. Network is working fine here. Try to reload page, same error message appears. Also the alert for metadata improver persists - “halted. Roon needs a software update”. Thanks for your help John B.

Yeah, it’s frustrating when these things happen but I usually find they are time limited.

If you can perhaps change your title of the post to something like “error loading page errors - Tidal issue perhaps?”

You might get more feedback from someone experiencing something similar.

If not I’m sure @support will be here to help soon.


Thanks so much John B. I’m new to all of this. Roon has been working seamlessly up 'til now. Only when it’s gone do I realise how much I appreciated it. Have a good friend who also has Roon/Tidal. Awaiting his return from work to see if he has the same problem. Regards Peter G.

1 Like

There are a couple of us down in Oz who seem to be experiencing same/similar problem: Unexpected error loading album. Please try again later. (Unauthorized) - #8 by Richard_Neale

Couple of thoughts

Have you restarted the network?

Try turn everything off , wait 5 mins , restart router , allow it to settle down make all connections etc. another 5 minutes. (Restarting the PC before all the network stuff is done causes funnies)

Then. Restart the core PC

Also if Windows have you installed the manufacturer video driver not the Windows one.

For weather reasons I power down everything every day in summer and never see these issues, this is how I start up . Lots of cups of tea in the waits :stuck_out_tongue_winking_eye:

Hi Mike. Thanks for your help. I restarted the network modem and router. Roon then took 4 minutes to fully open but all the same as before. I then logged out of Tidal in Roon and logged back in again. However same issues persist. A good friend here in Adelaide also has Roon/Tidal but he is not experiencing any issues. Wondering what to do now?

I should add that this computer is an Apple Mac running OS11.2.2.

Thanks Richard. Have you resolved as yet? I’m becoming quite frustrated by it all. A friend here has Roon/Tidal but everything is working OK for him.

Hi Everyone. Miraculously Roon is back in all its glory. John B was right. Happy (listening) days again. Thanks for all.


I’ve had a number of issues with Roon 1.8 not being able to identify end point hardware until the update of the latest build (764) was installed. All things appear to be working well on my end. Greg

Hi Greg. Thanks for the reply. Roon/Tidal working properly for us now. Great to have it back. Again, thanks to the community for assistance.