Roon not working on QNAP NAS

Core Machine (Operating system/System info/Roon build number)

QNAP TS453D ~Roon

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired through a HP 1820 switch to Roonbridge on a Raspberry PI

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Justboom Amp HAT on Raspberry Pi

Description Of Issue

I have a TS453D and since I updated the firmware to Roon does not work.
On the endpoint it starts up and says “Looking for your Roon Core” but never finds it, even if I point it to the IP address.
I have restarted the Roon Core on the NAS and I have also re-installed it. I have restarted the NAS.
Some of the endpoints are wired and some are wireless but none will connect. All have previously connected and were working until I upgraded the firmware on the NAS.
I rolled back the firmware upgrade and Roon worked again. I re-did the firmware upgrade and Roon stopped working again.
I rolled the QTS firmware back from to and Roon was working again.
So the sequence was:
Last week:
Upgraded the QTS firmware to 1540, rebooted, Roon was broken.
Restarted Roon on the NAS, Roon was still broken.
Checked the version of ffmpeg, replaced it with the version from QNAP Club, Roon was still broken.
Rebooted all the network equipment and endpoints, Roon was still broken.
Reinstalled the Roon Core, Roon was still broken.
Rolled back the QTS firmware to 1495, rebooted, Roon worked.
This week:
Did all the same things, with the same result.
Today I deleted Roon from the NAS, upgraded the firmware to, restarted and re-installed Roon, Roon did not work. I then installed Roon on another Qnap NAS with firmware, Roon worked. This is not a long-term solution because this is a backup machine and is not always on.

On the original NAS (Roon not working) the Roon Server log looks like:
01/20 18:16:26 Info: Starting RoonServer v1.7 (build 710) stable on linuxx64
01/20 18:16:26 Trace: Checking if we are already running
01/20 18:16:26 Warn: get lock file path: /tmp/.rnsems0-roon
01/20 18:16:26 Trace: Nope, we are the only one running
01/20 18:16:26 Info: Is 64 bit? True
(Log ends here - no more lines under this)

On the backup NAS (Roon is working) it looks like:
01/20 18:18:53 Info: Starting RoonServer v1.7 (build 710) stable on linuxx64
01/20 18:18:53 Trace: Checking if we are already running
01/20 18:18:53 Warn: get lock file path: /tmp/.rnsems0-roon
01/20 18:18:53 Trace: Nope, we are the only one running
01/20 18:18:53 Info: Is 64 bit? True
01/20 18:18:54 Trace: [orbit] init seq=52, pending=1, spcount=7, uidcount=2
01/20 18:18:54 Info: Command Line Argument: -watchdogport=44193
01/20 18:18:54 Trace: [childprocess] using .NET child process
01/20 18:18:55 Trace: [realtime] fetching time from NTP server
01/20 18:18:55 Trace: [realtime] Got time from NTP: 1/20/2021 6:18:55 PM (3820155535270ms)
01/20 18:18:55 Trace: [realtime] Updated clock skew to -00:00:00.3923560 (-392.356ms)
(and then goes on for many lines)

This morning I installed QNAP firmware so that I could compare the Roon installation to the working installation on my backup NAS.
This is the fourth or fifth time I have installed it, I have rolled it back each time because Roon would not start.
Today, Roon has started and is running properly. Comparing the two installs, they both appear identical. I don’t know what happened al the other times I tried this and I am not going back to find out.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.