Roon Nucleus and Mcintosh MCD12000

Roon Server Machine

Roon Nucleus

Networking Gear & Setup Details

Araknis network consisting of router, WIFI access points, and network switches. The Roon Nucleus in this system is hard wired to an Araknis switch.

Connected Audio Devices

Roon Nuclues connected USB to the DAC in a Mcintosh MCD12000 CD player. MCD12000 CD player is hooked up XLR to a Mcintosh C2700 preamp. The C2700 preamp is hooked up XLR to a Mcintosh amp. Focal floor standing speakers are hooked to the amp.

Number of Tracks in Library

We are the Roon dealer. We sold this unit to the client and are trying to help him with Support. I believe this unit is only used for streaming. I don’t believe there is a music library.

Description of Issue

When we turn on the system. We get a high pitched squeal sound out of the speakers that persists until we start playing music. This is repeatable every time we turn on the system. We rebooted the Nucleus by unplugging it and then made sure firmware was current. We rebooted the Mcintosh equipment by unplugging it and made sure firmware was current. Since the sound continued we factory reset the Mcintosh equipment. We then experimented with using different USB cables. That did not help. We then messed with the audio settings in the Roon app. We made sure MQA was off as Mcintosh doesn’t support MQA. That didn’t fix it either. Is there a certain sample rate or bit rate we need to be set at to eliminate this?

Only a Roon user here.

Have you tried another DAC?

1 Like

Yes we have tried the DAC in the Mcintosh C2700 preamp in his system and we did not get the sound using that DAC at least during our testing

I’d reach out to McIntosh based on that and discuss with them the possibility this one is faulty.

To help, has another Roon endpoint been connected to the USB and tested?

No we have only tested with the Nucleus which is the only Roon device he has on site. This install happened about a year ago. This issue just started happening so it is possible the DAC in the CD player could be the issue you are correct.

If the owner has a smartphone or tablet to control Roon with, this can also be an endpoint, for testing purposes.

A suitable USB cable for such device should be easily found.

You’d enable it in the Roon settings > audio tab

Good call. Thank you!

1 Like

2 posts were merged into an existing topic: Nucleus plus producing loud static noise periodically when no music is playing


As we are dealers for Roon I have reached out to our dealer support team to help find a resolution. We too have tried the clients Nucleus with other DAC’s now and it works fine. It’s just the connection between the Nucleus and the MCD12000 that seems to be the issue. I’ll be going out to the clients house this week to try another Roon device hooked up to the MCD12000 to see if it behaves the same way or not. As soon as I get a response from them I’ll let you know what is suggested we try next.

1 Like

We have Lumin U2 / U2MINI users with MCD12000 and they did not experience this problem.

At your own risk, try using a cheater plug temporarily for the Nucleus and see if it makes a difference.

Do you mean reverse the polarity on the power supply?

No. Please Google cheater plug, for the purpose of dealing with a potential ground loop.

The power supply does not have a ground pin on its AC connection. It has only positive and neutral.