Roon Nucleus cannot power on

My Nucleus shut down automatically during play back today, after that no matter how I tried, it cannot be turned on again, including disconnect nucleus from all cable attached, leave it there over 30min, then long press power button over 15sec for few times, nothing works actually.

What can I do now? Pls advise, btw, I bought Nucleus (not nucleus +) from Norman Audio in Singapore on 07/Aug/19, should I just send it back to the seller?

Hi @Chuan_Wang,

Are you using the standard power supply that came with the device or something else?

If you connect it to a different outlet is there any change?

Does the LED on the back or the Ethernet port light up at all?

Hi @dylan,

Actually I have used JS-2 linear power supply to power Nucleus since day 1, after it turned off automatically, I also tried stock power supply and different power socket, nothing happened, no any LED on on the back, neither the Ethernet port light.

I have returned it to local agent last Mon but no feedback was given yet, I called them and they told me already informed factory. It is one more week already, never heard from them, actually I use it on a daily basis so really want to have it fixed asap, anyway can expedite it? Thanks

Hi @Chuan_Wang,

Do you know the serial number for the Nucleus? I will check with the team on the current status of this.

Hi @dylan

Actually I cannot recall the serial number and currently it is in local agent’s hand, but I heard from them this morning that factory already shipped out the parts to them, hopefully it can be fixed in next 2 weeks, thanks

1 Like

Happy to hear that you’ve received an update from them, @Chuan_Wang. If you have any other questions please feel free to reach out.