Roon Nucleus cannot tag files on Synology 218+

Core Machine (Operating system/System info/Roon build number)
Nucleus Core, Roon Version 1.6 (build 416) Latest version installed
Nucleus and Synology+ Connected by Ethernet Cable to Asus RT-AC1750 router.
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

USB connected to Nucleus to McIntosh 5300 integrated amp with D/A converter
Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

I finally got the files transferred to the Synology 218+ hard drive (two 3 TB Seagate Ironwolf drives in Raid 0 config). Cannot get the file path for Roon to track the files for play. Roon works fine in streaming from Qubuz or Tidal. Tried file path shown in Synology file manager: smb://My Music Storage/volume1/MusicFiles/MusicFiles Keep getting error message: Could not connect to share host not found or Invalid network path specified. Very frustrating. This is the worst part of the setup, was much easier on the desktop computer with the files on the c drive. I bought the Nucleus to get the program and files off the desktop computer and not have to deal with windows.
Description Of Issue


Hi @Michael_Gormley,

Starting out, I definitely recommend taking a look at this article for information about adding media from a NAS to Roon.

About the path you’re using:

smb://My Music Storage/volume1/MusicFiles/MusicFiles

Does this path work for you from File Explorer on Windows?

Typically it would be something a bit more simple like:

smb://My Music Storage/MusicFiles

Can you share screenshots of the music folder on the Synology you’re trying to share so we can see the path?

Thanks for your prompt response. I will see if I can send shots of the Synology files to figure out the file path. May be a bit of a “science project” but I did see the “snippet” app. I did thoroughly read the Roon article for configuring the NAS to Roon, but still find it challenging. What does “smb” mean?

I hope these screenshots worked. Not sure whether I should be doing the route of smb://MyMusicStorage… or… If I can get past this step and play my music library I’ll be very happy.
Mike Gormley

Looks like it sent multiples of one screenshot instead of the separate screens. Will try one at a time.

Another screenshot:

smb is enabled.
Do you need any other shots? Can’t find one of the actual file path.
Mike Gormley

On my Synology, I’m using this storage location in Roon:
\\synologyserver\NAS Music
I believe your location would be:
\\mymusicstorage\music files
An alternative would be \\\music files

BTW, using spaces in these file paths isn’t a good idea. I have it on my NAS, but it works so I never changed it.

Tried both suggestions, get error replies for both.

Pretty frustrating. Do I need the smb\ before the mymusicstorage?
Mike Gormley

Did you enter your username and password for the NAS? (workgroup can be blank)
Also, if I’m not mistaken, the folder name is music files (with a space), not musicfiles (that is how it’s listed in your screenshot up above)?
Is that correct? (this is one reason why spaces are a problem…)

1 Like

Thank you Scott! Your last suggestion worked!! Thanks for everyone’s help.
Mike Gormley


Great news!
Enjoy the music. -Scott

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.