Roon Nucleus does not see my Linn Accurate DSM

Roon Server Machine

Roon Nucleus with music in built in SSD

Networking Gear & Setup Details

Ethernet with Netgear router as primary connection for Roon Nucleus and Linn Accurate DSM. Wifi via Amazon Eero home network (WiFi 6) for connection for Roon remotes (iPhone, iPad).

Connected Audio Devices

Linn Akurate DSM, Linn Majik DSI, Exakt enabled, Linn Keilidh Aktic speakers.

Number of Tracks in Library

About 3-4,000 tracks.

Description of Issue

I was recently away for about 4 weeks and on returning, was not able to play any music using Roon. My Roon Nucleus and Linn systems have been left untouched, but the Roon remotes do not see the Linn system as an audio output (Audio zone). The Roon devices (Nucleus and remotes) are up to date, as is the Linn Akurate system.

This has happened some months ago and required me contacting Roon Support . “Miraculously”, the Roon remotes started seeing the Linn system after that. Could this be the same issue, and can something be done to prevent it from happening again?

Many thanks for your help.

Did you already reboot the router like last time?

Yes, Rebooted the router. The Roon Remote sees the Linn as an Airplay device (“Linn Lounge”) now but not as the wired network device as it once was.

I’m not familiar with Linn devices, but I notice that it is showing up on the Linn subnet. What happens if you enable it, are you able to then change the connection from Airplay to Linn streaming?

Oops, now the Linn Lounge (via Airplay) has disappeared. So was not able to enable it as suggested.

I have almost the same issue. I’ve moved from 1.8 to 2.0 Roon version and my Linn DS-I moved from Roon tested section to Airplay one. Why is that? The sound quality with wireless way is much poor in my case. How to get back Linn to Roon tested?

UPD. it has appeared somehow and I don’t know how it added itself…

Hi @Colin_Chan

I could be wrong, but you’ve got 2 subnets on your network.

One with your Netgear Router for your ethernet wired devices.

One with your Eero for WiFi.

Are the Eero in a bridged/AP state?

Might be causing some of your issues.

1 Like

No, the WiFi is not on bridge mode.

Hi @Colin_Chan,

Thanks for writing in!

From your account info, I see this as well - if you can, please temporarily disable one of your local subnets and confirm all your Roon devices are on the same 192.168.X network.

Let me know if your issue persists after this! :+1:

1 Like

I have removed the Apple AirPods that was on that subnet. The network that remains is 192.168.X.

Still does not see the Linn Akurate DSM (Screenshot provided).


I’ve rebooted the router to no avail.

Looking forward to hearing from you.

Hey @Colin_Chan,

Thanks for the update! As a next step, can you confirm that no other programs are interrupting the connection on the DSM? From a recent diagnostic review, we’re seeing requests from Open Home potentially relating to the DSM.

Can you confirm the DSM has been disconnected from all other devices before attempting to connect it to Roon?

Can you also temporarily get your Nucleus hardwired to the same router as your DSM / other devices?