Roon Nucleus not connecting ARC

I have a Roon Nucleus that is hardwired to a Cisco switch. I have wireless connections on the same switch. My iPhone will connect to arc immediately but my wife’s iPhone (same model IPhone 15) will not find the nucleus. There is no difference in setup whatsoever.

I’ve deleted my wife’s Roon and arc apps and reinstalled which did not help. I gone into Roon arc setup and it says Roon arc is established.

I cannot figure out what is different between our iPhones that one connects and the other does not.

Also to not when opening arc on the network it will say it found nucleus but when connecting I just get the circular spin and it will say how long it last saw the arc nucleus. So it is finding it at some point but then never actually connect.

Please help. I’m trying to get my wife to buy into using Roon and without arc it hard to sell this to her.


Is there a guest WiFi and is her mobile maybe booked in there?

Thanks for the reply. There isn’t a guest WiFi and I did verify we are connected to the same ssid and receiving the same subnet range/ip range.

What is interesting is that we both have 1 iPhone and 1 iPad. We both use the same wireless access point at home. Both my iPhone and iPad work seemlessly when connecting at home as a test to arc but both my wife’s devices fail. They get an endless circle and a calculation of how long arc has last seem the Nucleus.

I’m pretty good at troubleshooting but within Roon/Arc I don’t know what is providing what services and how to troubleshoot. Would these logs people mention help me? Else the only troubleshooting I have been able to do is to very Roon arc is ready using the Roon arc section of the Roon app. I can also verify we are all using the same port numbers and the Roon app verify it had been tested and verified to be Roon arc ready.

Where do I go from here?

Thank you kindly for responding earlier.


Just following up with anyone who could point me in the right direction.

I want to try and simplify my issue as much as I can:

2 devices connect to arc with no issues (both are my IOS devices)

2 devices do NOT connect to arc but the arc test passes on these two devices. (Both these devices are my wife’s IOS devices). She can access Roon locally with no problems at all. This is only when trying to connect to Arc. I’ve tried opening Arc remotely as well as within the local network and the same response is a spinning circle.

Also to note prior to running on the Nucleus I used a Synology NAS and all my devices worked with arc perfectly fine. This issue started when I purchased and installed the Nucleus about a month ago.

I made a significant investment in a Nucleus+ and without he ability to troubleshoot this and get this working I feel like I made a mistake with this investment. I’m also under pressure from my wife to validate the $$$ and lifetime memberships.

Some questions:

  1. I see references to Roon logs. Could these logs help me or are they for Roon support staff only?
  2. Since the two devices not working are my wife’s IOS devices it appears some how to be linked to her overall Apple account. Just my opinion. If this were try are there ANY settings at all that I should be looking at on her devices.

***3. Finally, support. If I cannot get this working, what options for support do I have? I assumed when purchasing the Nucleus+ I had the full backing of Roon to get me up and running. I have poured over articles for support and I cannot get this resolved on my own. Can I pay for support? Is there a way to open a case up with Roon directly?

I am at a total loss here. I hope some one in the community either has had a similar issue or someone from Roon support can provide me th4 proper guidance needed to get this all working.


I am moving your topic to Nucleus Support because official support will usually not see it in the discussion area of the forum where you posted it (ARC)

To rule some things out: If you - temporarily - spin up a Roon server on a laptop (or your NAS if it’s still around) once more, would the problem remain?

Hi @John_Klimaszewski,

We’d be more than happy to assist you in troubleshooting this issue - you have my apologies for the delay in getting to your thread!

Could you provide the make and model of each device?

With that, if you could reproduce the issue and grab the specific date and time when attempting to connect, that would be helpful! We can then enable diagnostics and take a closer look into what might be going on behind the scenes.

I’ll be on standby for your reply. :+1:

Thank you kindly for the reply. So I semi-fixed my issue but added more questions to completely solve my issue.

My original setup was that I purchased a lifetime membership running on a Nucleus+. For my arc client I log in using my master login, the same login the core is signed into.

For my wife, I purchased an annual subscription using her email address and login info. When logging into her account with her paid membership Arc does not find the Nucleus. So I did a test and tried logging into my wife’s arc on her iPhone using my master account and to my surprise it found the Nucleus and Arc is now working.

So this leads me to licensing questions. For a family with multi users (for me it is just my wife and I) did I need to buy a new license and have her log into her own account (ie email address/password) or should she be just logging in under my master account. For now this is the only way I can get her Arc app to find the Nucleus.

Do I need to somehow register her separate account to my core to allow her access?

Final question, right now I have setup two profiles one for each of us and that seems to work fine. Is this the way I am supposed to do this with multi users? The only issue I found is that our playlists can’t be shared at the moment. I used to be able to select my playlist vs my wife’s playlist and as long as she turned the share playlist option on. But now when I select my wife’s playlist it says she has no playlists which is not accurate. Could this be a sideffect of how I am logging into her account now using my ID?

I have scoured the support community for similar situations but have not found anything that represents what is going on with me.

Thank you,


Also since we have narrowed this down to a login issue I didn’t think you would need the device make and model. If you still would like to review, please let me know.



Hey @John_Klimaszewski,

Thanks for the additional info!

An easy way to think of things is 1 License = 1 Roon Server. So in your situation, if you’re only planning to use one server for your household, you’d only need one license - and like you mention, share the same login information but create separate profiles.

If you have two separate locations needing to run on two different servers, two licenses is the way to go.

Head into the playlist you’re having issues with > click the three dots > edit > owner drop-down> select 'Shared (visible to all profiles). Do you still have the issue after this?