Roon Nucleus Will not boot up

Roon Core Machine

Nucleus Plus.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

My Roon Nucleus Plus will not boot up.

I powered it down for a couple days and unplugged it when doing some electrical work on the house.

I have tried connecting it to a TV with HDMI and even though the light comes on the power button in back, it gives no signal to the TV and in my iPhone Roon app the Nucleus is no longer found.

That doesn’t sound good unfortunately.
How old is it and where did you purchase it?

Just a few months old. From a dealer in Seattle area.
Should still be under warranty…

Similar thing happened about a month ago, I posted it under the following topic:

Nucleus + is not found anymore after it had been powered off for a few days

The problem seemed to resolve on its own later that day, although I never figured out why.

Tbh these type of problems usually do not fix themselves permanently.
I would be taking it back to the dealer myself but as it’s the weekend you might want to wait and see if official Roon @support have any other ideas first.

I agree. I think something is wrong with this Nucleus.

Anyone from Roon want to comment before I bring this back to the dealer?

With it being the weekend I doubt there will be much action from Roon before Monday.
I have already tagged support so just give them a chance to get to it.
Unless you desire to take it back right away which I can fully understand.

Thanks Ace. I can wait till next week.

Isn’t there some sort of reset inside the Nucleus?


We’ve tried to enable diagnostics on your Nucleus but it doesn’t seem to be online at the moment or communicating with our diagnostics servers. If you experience the issue again and you are not getting anything on the HDMI output of the Nucleus, please let your Roon dealer know and ask them to take a look over the unit.

Typically when there are Nucleus hardware issues, they are not intermittent (unless it is a failing hard drive - but then the unit would still be booting). I would also investigate the power adapter, if you had some electrical issues and the adapter was shorted due to electrical issues, testing another adapter is suggested.

Thanks Noris. The issue is ongoing, not really intermittent. I do think it is likely a hardware problem. Since I posted this, I have not been able to get the Nucleus to do anything, although the power button does light up. Tried different ethernet cables, HDMI cables, reset modem/router/switch. A similar incident happened about a month ago, and it started working again later that day, and worked all the way up until last Friday, and it has not worked at all since.

I do not think the adapter (or anything else) has shorted due to electrical issues at the house, since our home is new (4 years old), the Nucleus is plugged into a dedicated 20 amp circuit along with a dCS DAC/streamer, Shunyata Venom Defender, and basic small gigabit ethernet switch. Plus. we have whole home surge protection. I understand nothing is bulletproof, but surge damage seems pretty unlikely to me.

I will plan to take it back to the dealer…

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Please see my previous post “Roon Nucleus Will not boot up” which support has recently closed.

I took the Nucleus back to the dealer (Burt at Seattle HiFi). He says the Nucleus cannot boot up or connect to his network either and will have to go back to Roon for repair/replacement.

He asked me for a case or reference number, but none was provided. Can someone at support please provide one here or to him?


Reopened and post merged.
Tagging @support for you.


I will follow up via private message for next steps. We’ll need to create an RMA case to have you send your Nucleus in for repair.

Please keep an eye out for a direct message from me :+1:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.