Roon on 1.5 323 crash after update win10 to 10.0.17134 [Solved by Database Refresh]

Posting this as maybe a new WINX issue that hasn’t hit too many others yet?

As a new Roon trialer, (1.5 build 323 stable)was ok for about a week, but appears there is a new issue now I have upgraded WINX to 10.0.17134 . Roon starts, but crashes within about 20 seconds . Maybe Soolos related?

error in the Application WINX - logs says:

18/05/2018 8:30 PM	Application Error	Faulting application name: Roon.exe, version:, time stamp: 0x5af3b543
Faulting module name: roonmedia.DLL, version:, time stamp: 0x5af3b4a1
Exception code: 0xc0000005
Fault offset: 0x00000000002426d7
Faulting process id: 0x20cc
Faulting application start time: 0x01d3eee713bb1a42
Faulting application path: C:\Users\REALNAMEHERE\AppData\Local\Roon\Application\Roon.exe
Faulting module path: C:\Users\REALNAMEHERE\AppData\Local\Roon\Application\100500323\roonmedia.DLL
Report Id: 4c2b7ddb-200c-4285-83d5-cb77f42b1835
Faulting package full name: 
Faulting package-relative application ID:	


.NET runtime error is:

Application: Roon.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.AccessViolationException at Sooloos.Media.Native.soom_analyze(IntPtr, Boolean, Int32, CheckCancelDelegate, IntPtr, Int32 ByRef, Int32 ByRef, Int32 ByRef, Boolean ByRef, Double ByRef, Double ByRef, Double[], Double[], Int32 ByRef, Byte[], Int32 ByRef) at Sooloos.Media.AudioExtractionService.Analyze(System.String, Boolean, System.Func`1<Boolean>, Int32 ByRef, Int32 ByRef, Int32 ByRef, Boolean ByRef, Double ByRef, Double ByRef, Double[] ByRef, Double[] ByRef, Byte[] ByRef, Int32 ByRef) at Sooloos.Broker.Music.LibraryAnalysis+<>c__DisplayClass33_0.<_Analyze>b__0(System.Object) at ThreadUtil._WorkerThread() at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object) at System.Threading.ThreadHelper.ThreadStart() 

tried several times, rebooted, no change…

Basic details of my system:

Item	Value	
OS Name	Microsoft Windows 10 Home	
Version	10.0.17134 Build 17134	
Other OS Description 	Not Available	
OS Manufacturer	Microsoft Corporation	
System Manufacturer	TOSHIBA	
System Model	Satellite P70-A	
System Type	x64-based PC	
Processor	Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz, 2401 Mhz, 4 Core(s), 8 Logical Processor(s)	
BIOS Version/Date	Insyde Corp. 1.50, 18/04/2014	
SMBIOS Version	2.7	
Embedded Controller Version	1.30	
BaseBoard Manufacturer	Type2 - Board Vendor Name1	
BaseBoard Model	Not Available	
BaseBoard Name	Base Board	
Platform Role	Mobile	
Secure Boot State	On	
PCR7 Configuration	Binding Not Possible	
Windows Directory	C:\WINDOWS	
System Directory	C:\WINDOWS\system32	
Boot Device	\Device\HarddiskVolume3	
Locale	New Zealand	
Hardware Abstraction Layer	Version = "10.0.17134.1"	
Time Zone	New Zealand Standard Time	
Installed Physical Memory (RAM)	16.0 GB	
Total Physical Memory	15.9 GB	
Available Physical Memory	10.5 GB	
Total Virtual Memory	31.9 GB	
Available Virtual Memory	26.8 GB	
Page File Space	16.0 GB	
Page File	C:\pagefile.sys	
Kernel DMA Protection	Off	
Virtualization-based security	Not enabled	
Device Encryption Support	Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, Disabled by policy, TPM is not usable	
Hyper-V - VM Monitor Mode Extensions	Yes	
Hyper-V - Second Level Address Translation Extensions	Yes	
Hyper-V - Virtualization Enabled in Firmware	Yes	
Hyper-V - Data Execution Protection	Yes	


Hello @RicksterGNZ,

I apologize for the delay in getting back to you here and I want to thank you for the detailed information you have provided in your post. I want to ask you to perform a database refresh to see if that can trigger the crashes to disappear. To perform this action please take the following steps:

• First, please close out of the Roon application if it is running
• Then open Windows File Explorer and type this in the header address to navigate to your Roon folder:
• That %localappdata%/Roon should automatically translate to an address similar to YOUR_USER_NAME > AppData > Local > Roon
• In that translated folder, create a new sub-folder called “Roon_Old” and move all folders except the “Application” folder to that new Roon_Old subfolder
• Restart the Roon App and configure the new install
• Leave this configuration in place and see if Roon is still crashing

I’m hoping that this fresh database will allow you to enjoy Roon but if this fix doesn’t solve the issue at hand, please just let me know and we can take a closer look at what could be going wrong here.


Hi @support,

Appear that this process referred above by Norris has worked (was
tested running as desktop, now changed to server mode on same machine), where I had previously uninstall/reinstalled it did not work, I suppose because the DB is not cleared in the uninstall I did.

Thanks for the support, onward and upward!


Hello @RicksterGNZ,

I’m happy to hear that you’re up and running , and I do apologize once again about the delay in getting back to you. If there is anything else that doesn’t seem to be working right or if you have any issues at all with the App, just open a thread and make sure to flag support so that it can get on our radar :eyes:. I hope you enjoy our product and if there’s anything else you need, don’t hesitate to contact us!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.