Roon on ChromeOS

I just got a Google Pixelbook and I’m amazed at how good it is - its an almost perfect mix between a laptop and a tablet. Everything I need for both work and personal use is available to me (OneNote, Excel, Gmail, Netflix, Amazon Prime Video, etc., etc.) except for one thing - Roon.

As far as I can tell there is no web based way to use Roon and the Android app does not seem to work on the Chromebook.

Needless to say, I would LOVE a web based version of Roon or a Chrome app (which are often though not always the same thing - in this case it would be fine to be the same since you can’t use Roon offline).




+1 for this.

I am in the market for a new laptop and was looking at Pixelbook.

I was on the waiting list for the top spec pixelbook but when compared to a windows laptop at the same price it was simply terrible and I couldn’t justify it on Chrome OS alone.

I too wanted a Roon app for chrome OS but in the end gave up and got a top spec HP Spectre x360 instead and haven’t looked back.

Which spec pixelbook do you have?

I actually have two - I first bought the i5 256GB version and liked it so much I gave it to my wife and got the i7 512GB version for myself.

Highly recommend.

The latest Roon update for Android still does not work - PLEASE PLEASE PLEASE make this work.


1 Like

Afraid as a Linux or ChromeOS user you’re a leper in the land of Roon - headless seems to be as good as it’s going to get. I hate that we’re flatly ignored, but hey look at all the bells and whistles, aren’t they just grand.

1 Like

I’m not sure I understand by what you mean when you say “headless” in this context.

I am running Roon Server on my NAS - which works fine - all I’m trying to do is control it with my Chromebook.

Am I missing something here?

no, just meant that Linux is leveraged to provide the headless OS for ROCK and as a host for server, but desktop is flatly ignored despite OpenGL being no stranger to Linux and its derivatives.


Two different issues here.
Linux desktop is not supported, probably because it has tiny market share, I would guess. Android is the Linux derivative that got GUI market share.

Chrome, however, is a web browser thing. Doesn’t matter if there are Linux fragments underneath, you don’t run apps on it, you run a web browser. That’s where it gets its strength, and also its weakness. Roon has never done a web browser version. I can imagine some good reasons, but I have no insight.

I run the Roon app on my Chromebook Pixel. You need to manually put the ip address of your core. It is not perfect, you will have to re-enter ip address ever so often…but it works, at least for my setup.

Guessing you room the android app, so still deprived of a fully functional Roon UX.

Shawn - are you running the server on a computer or NAS? I tried doing this and it still couldn’t find the server. I will play with this tonight and report back.

My Roon core is on a Windows 10 desktop, which is connected to an Asus router via ethernet. My chromebook Pixel is the current generation of Pixel books. On your chromebook install Roon app from the Play Store. When it tries to connect to your core it won’t find anything until you add the ip address of your core manually…in my case it’s the Windows 10 ip address. I don’t have a NAS, but was looking into getting one, but if what you say is true and you cannot connect via NAS I think I will stick with my current setup. If it doesnt connect 1st try, keep trying. It sometimes takes me 2 or 3 times.

I run the app fullscreen and all functionality is there. Unless i’m missing something that i’m just not aware of. On my phone app for instance there is no alphabet menu so I have to scroll through artist, but on my Chromebook app in fullscreen it is there. If there is something else that is usually missing I will check and see if you want.

Shawn - been trying for a while - doesn’t seem to work on the NAS - pretty bummed right now - trying different things - will report back if I can get it to work.

Has anyone seen any updates or improvements on this? I’m really hoping this gets figured out.

Since version 1.6 (build 416) all Problems running Roon on my Chrome OS Asus C302c are gone (Roon Core on SonicTransporter). Most important: the Netbook now is seen as an Endpoint. Hope, that stays in the future)

Thanks to the Roon Team! Did you any changes (for Chrome OS) with the actual version?

Still not working for me and really never did. I’m using a Google Pixel Slate and a Pixelbook with Roon running on a Synology. All other things roon work great for me.

It’s a bit scary how much happier I will be when this start working (seems like I need to reconsider some life choices, but that’s a different point).

Josef - how is your Roon set up?


OMG - I take it back - I just got it to work - just had to put the IP address of the Synology and it worked - amazing.

Now - now to get on the with the rest of my life - so happy!

1 Like

Sad to say, but I also have to take it back! Yesterday it worked, today it refuses! Hope, the roon team will spend some time to fix this issue!
You asked for my setup: Core is on SonicTransport i5 with ext. HD played over multiple Android and iOS devices and Google Chromecast Audio to Creek Evolution Amp and Dynaudio Contour speakers. Works great for me (in general, but … you know)!

Greetings and: Hope your system works further on for the rest of your life! Good luck!
J. J.