Roon on DSM 7 No Longer Beta

I see that on, the DSM 7 version has been removed from Beta status and is now a standard release. It also mentions that the upgrade from DSM6 is now supported.

I am unclear as to the proper install steps. Do I still need to remove the old Roon install and then install the new DSM 7 version? Can I just do a direct upgrade? I am uncertain on these points.

Following along. I have the beta running already and have for some time.

@Paul_Whittaker , I just updated to DSM 7.0.1. Any issues running the update with this “Roon on NAS” version?

I just upgraded to that version of dsm too and I’m running a really old version of roon (20210727).

I just asked if its safe me to upgrade to the latest room package

1 Like

An uninstallation should not be necessary anymore. You can just update to the new DSM7 version and it should be “repaired” afterwards.

In the update process your RoonServer and RAATServer folder will be copied into a new RoonOnNAS folder. The original folder will be moved to a folder DSM6_RoonServer_Database_Backup as a backup and it can be removed if everything works as expected.

I will update the website soon to reflect the changes.


Thank you. It did indeed perform just as you describe. Wonderful! Thank you!

Flawless update on both.
1st NAS
2nd Roon

No issues at all


A few days ago, I finally dared to upgrade my Synology DiskStation to DSM7. I was afraid to lose the Roon functionality.

Upgrading from DSM 6.2.4 to DSM 7.0.1 went smoothly. Then I downloaded the Roon package from @crieke for DSM7 (version 20211105) and installed it via DSM Package Center. That also went without any problems. Roon is running like a charm again. :sun_with_face:

@crieke, thank you for your efforts. :+1:

Hi all,
I was waiting for this (no longer beta) and finally dared to upgrade to DSM7 as well, but in my case the result was not as good. The update to DSM7 alone didn’t “repair” Roon for me: I had to manually install using the installer, was asked to restore backup, and now – with the Roon remote on my Mac apparently seeing and able to connect to the Roon server (it shows the name of my Synology as Roon Core with the “Ready” green light on), I press the “connect” button to get the Roon logo loading endlessly.
Greatly appreciate if any of you can help.
My Synology is a DS416play upgraded to 8gb, and was working perfectly on DSM6.

1 Like

Just to let everyone know that I managed to solve the issue – I had to re-log in with my username, deauthorize my NAS, restore a backup and re-map the music folders (which for some reason were not accessible after the DSM7 upgrade.

1 Like

Hey, everyone.

My DSM7/Roon update went flawlessly except for the Roon database backups. To me, this looks like a permissions issue, but I have not been able to figure this one out.

Wondering if anyone has come across this yet?

Hi, Did you mange to fix this? It’s a permission issue with your Roon Backup folder.


No this is not fixed yet. It clearly looks like permissions, but it looks like they are set correctly, or at least, not changed from what they were under DSM6. Would you have any suggestions?

Thank you.

I placed the backup folder within my RoonCore folder; the permissions are then ok. This is working for me without problems.

See the picture. The folder “Backups” stays parallel with the folder “RoonOnNas”.
Schermafbeelding 2021-12-27 182527_LI

I’ve been puting off the DSM 7 update for a while due to the potential issues with Roon until I had some time on my hands.

This morning, her ladyship tested postive (lateral flow) for COVID and she’s symptomatic (I suspect the forthcoming PCR test will confirm), so plans up to and including New Year are now cancelled. My tests have thus far been clear, but I fear it’s now only a matter of time…

Anyhoo, DSM 7 update went swimmingly. I then installed the DSM 7 version of Roon - minor hiccup with the database backup (needed to give the Roon App system internal user read/write access to the DB Backup shared folder) and so far it’s all working perfectly.

Many thanks to @crieke for his sterling work in building a DSM 7 compatible Roon installation.

DSM 7 removed root permission for 3rd Party Apps (which includes Roon). You have to grant Roon permissions to any additional folders it uses. Go to Control Panel > Shared Folder and select your Roon backup folder location:

Click on Edit, then Permissions and click on the drop down which shows “local users”. Select “System internal user” and scroll down until you see RoonServer.

Select the Read/Write tick box and click Save:

This approach does get around the problem, however my Roon Backup folder is on a different volume (Volume 1 - 12 bay RAID 10 HDD array on the RS3617xs which is automatically backed up off-site to BackBlaze B2 bucket) from the RoonServer folder (Volume 2 - 2 bay RAID 0 SSD array on the RX1217), so I had to sort the permissions out properly to enable everything tio continue working as before.

Thank you for your replies, Alfred and Graeme.

Graeme, I hope things go well for you and the family is healthy again soon!

I followed your instructions, and it worked immediately. Thank you for that. I suspect we have a similar setup - I’m using B2 integration with my Synology as well. My database is on an external USB SSD, and the backup is a folder on the NAS. That folder, in turn, is currently going up to my B2 bucket.

Thank you again for your assistance!

Other than moaning about her symptoms (my wife really doesn’t do sickness very well :joy:), she seems to be reasonably OK. We’re both double-vaccinated and boosted, so the ill effects of COVID should be minimal.

Glad to hear that my suggestion worked.

BTW, I’m curious about your family name - from what I’ve read, it appears mostly in Germany (literally meaning one who comes from Eiching), though the earliest occurrences seem to date back to mediaeval Austria. My wife and I lived in Austria for a couple of years (2017 - 2019), hence Germanic names tend to pique my interest :slightly_smiling_face:

Yes, it is German in my case (I’m 3rd gen American) from my father’s side. Years ago, my wife and I traveled through Germany and Austria, and while in Vienna we happened upon an apartment building with a Dr. Eichinger as one of the residences. I rang it, but nobody was home :wink: