ROON on Lenovo Tab M8 HD

Just picked one of these up, to run dedicated for ROON. Can seem to get it to rotate, into Landscape.


Hi @Chris_Lehner. I can’t find the official word on this. I believe that the screen size is too small to support the rotation. In effect it’s treated like a phone screen. I seem to remember you need a large iPad screen for this to work.

Sorry; it’s actually a Smart Tab M8…but same size.

If that’s the reason, it’s a real heartbreaker. I bought it, JUST for that.

Actually…I did a Google; looks like 8" and above should be good.

Over apps on it, auto-rotate; so I guess that’s what I was asking. Is there a setting in ROON that enables it? I looked; LOTS of options…so that one didn’t jump out at me.

Ah; this might help. Especially since it also relates to a Lenovo unit.

I have the M10 - not good news from me, sorry. Not the screen - it is very hit/miss with Roon, sometimes connects, sometimes takes ages, sometimes won’t at all

I have an iPad Air - no problem at all. Also annoying for me - since I specifically got this for my second system - now I regularly have to run downstairs to get the iPad :neutral_face:

On the up side, it works much better for controlling Alexa and my other gadgets, no idea why


OK, well…

based on this thread Tablet stuck in phone mode [SOLVED: bad DPI from manufacturer] I feel fairly certain I’ve made the correct steps, to set my DPI to 160. But DisplayInfo still has it listed at 189.

While I didn’t check it before…only after, once ROON still wouldn’t go into Landscape; I say I feel confident my adb shell wm density "160” && adb reboot command worked…because the Tab did reboot. Just didn’t set DPI to 160.

Another thing I’m noticing…and man, I didn’t expect a science project; but DisplayInfo lists the ‘device class’…as Smartphone. $99, on sale for $59; I guess you get what you pay for…but I would have thought, it could run a single app. (FTR…I also think ROON could be a bit more flexible).

To make matters worse…I just found out, Auralic Lightning DS (the direct controller for my unit); isn’t supported for Android anymore. I’m wondering how much to chase this…considering Andy saying, even the M10…which is plenty big enough…is flaky :roll_eyes:

I paid very little for mine (~GBP50/US$60) including the Alexa dock, they were on sale, Lenovo (I’m a long-time Lenovo Carbon X1 fan), must be a bargain!

Caveat Emptor

Still, on the upside, it’s fine as a general browsing tablet and I didn’t need a mortgage :grinning:

Try this instead:
adb shell wm density 160 && adb reboot

^Damn; I was hoping that would work. No bueno

This is odd…changing the ppi did work for me (Lenovo M8 FHD - 8", 1900*1200) using these instructions:

BTW, for a 1280*800 8" tablet, the native resolution is 189 ppi - that’s what I would set it to.

Well…maybe that’s why it’s working for you? As I mentioned…I didn’t check it beforehand; so I don’t know if it was always 189, and therefore my changes haven’t made a difference. Or…if it’s not letting me go below 189 for some reason; because…that is where I’m at.

But I still can’t get ROON to Landscape.

I’ll look at your thread. (oh; that’s what I used)

Yeah; I tried going up. Also didn’t move off 189. My debug isn’t working (even though it reboots, and runs without an error in the command window).

Hmmm :thinking:

^Do I need to have my drivers, any place in particular??

I also just did a “size reset”. Still 189; so I think that’s how it came, and what I’ve done…hasn’t moved the needle a bit.

But, Rolf…are you saying you get Tablet Display on ROON, at 189?

Interesting. I did just notice…that in DisplayInfo, ‘device class’ changed from Smartphone to Tablet.


Tricky stuff, this. So…with DisplayInfo still saying 189 (but encouraged by the change, from Device = Smartphone to Tablet); I thought it might have to do with some of the Tablet settings themselves.

Went into Settings > Display > Display Size: Custom (160) :grin:

Opened ROON; lovely! So…$59, some Google-Fu, and some elbow-grease; gets 'er done.

1 Like


Sorry for going off topic a bit - but I kept getting that ‘TIDAL Login failed’ flag a couple of weeks ago

It seems to have fixed itself, but is there something to do - in case it comes back?

Log back in? LOL

I haven’t been using my ROON in a minute; but my recollection, is that it’ll drop your saved log-ins from time to time…as do most apps.