Roon on Mac OS using Synology NAS storing library

Core Machine (Operating system/System info/Roon build number)

iMac late 2014, 4 GHz quad-core I7, Mac OS 10.16.8, don’t know how to find Roon build #

Synololgy DSM1815+ on wired network

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Linn Klimax DS

Had signed up for free trial a few months ago but couldn’t use it at all because I couldn’t connect to my NAS drive where all my music is. New network, new location, few months later, wanted to try again. It says my free trial is expired, which I never could use. Took leap of faith and bought annual subscription. Trying to set it up, same old damn problem. I type in valid credentials for path and use to connect to the NAS drive and it comes back saying “not authorized.” I can log in directly with these credentials but not via Roon. Roon doesn’t allow me a way to browse from the mounted volume level as other upnps do so I can’t get to my music. Need either a way to get to my NAS drive or need subscription cancelled.


What network path are you entering in Roon? Have you tried directly with the IP address instead of hostname? Any special characters in the password?

Please post screenshots, one of your Finder/Explorer viewing your music folder on the NAS and one where we can see how you set up Storage locations in Roon.

And one tip, username and pass (if you use them) should only contain a-z, A-Z and 0-9
But on the other hand, i highly recommend setting up your NAS shares with ReadOnly Guest access, in which case you can disregard any user/pass in Roon…

Tried logging in as “Max Paley” and “Admin”. Both passwords are one-word with only a-z, A-Z and 0-9 and I can log into both on other apps with these credentials.

Try two things;
Use only forward slashes in the server path, and use it’s ip address rather than MaxNas?
And set guest access on that folder to read only. Then try again (without user credentials)

I also use a Synology. Get rid of the “SMB”, and as Mikael said, use all forward slashes. It should just look like this:


Assuming that’s where your music is. I see you also have a folder called Music, use that of course if that’s where your music files are located. Also If you haven’t yet, go to your router settings and assign that IP address so it doesn’t change.

Tried it all. All forward slashes logging in as Max Paley (which I now set to Read Only for that folder on the NAS) and Admin. Using the forward slashes only made it take longer and instead of “unknown host” it now, after a bit, comes back consistently with “There was an unexpected error”

You just need to mount the folder on NAS, then tell Roon to access it like a regular folder on your MM,
There won’t be any valid credentials to worry about because as far as accessing is concerned, this folder is just like a regular folder on your MM.

1 Like

That implies that the host was found but the credentials are wrong. Use admin instead of Admin. You should use backslashes as @QuinnT suggests too. Also, drop the full path and simply use \\maxnas (possibly \\maxnas.local) or \\ If that works in Roon you can browse to the correct folder.

1 Like

Thanks, Martin. Tried all that and also tried admin with lower case (although I log directly into the NAS as “Admin”. All yielded “unexpected error”

Quinn, I don’t understand how I can mount this differently. I have the NAS mounted as volume MaxNAS, but Roon doesn’t let me browse to that level in the hierarchy.

Why is this such a big deal when Linn Kazoo, Twonky, JMRiver, Asset, etc. have no problem letting me browse to it?

Quinn, you did lead me to the right place. I hadn’t noticed that in the browsing window for adding a folder to my library, there was an up-arrow that would allow me to go higher in the hierarchy. To get to my NAS I had to select VOLUMES and go past a big red warning that using Mac VOLUMES and Roon was NOT RECOMMENDED and that I wanted to proceed anyway.

So it looks like Roon is loading in my library (significant - about 10 TB of music) and I’m already playing some tracks.

This got me past all of the nonsense of authorization and credentials as you said.

Quinn, this is making this actually work for me!

1 Like

Nice, you have made it work.
Btw, I also have a Linn Klimax DSM 3 (with Katalyst).

Quinn, how do you play your Roon content on the Linn? Do you use an iPad app or similar? Does Roon show up on the Linn Kazoo app? My DSM is about a decade old and I’ve toyed with the idea of upgrading to one of the Katalyst models.

I use the Roon Control on an iPhone, an iPad and a MacBook Pro, whichever is handy at where I am in the house.

The Linn Kazoo app is a different control app, just like the Roon Control, but the user interface is much more primitive (relative to the Roon Control), and the user experience is not the great. But the Linn Kazoo comes with the Linn Klimax and it is free, actually quite a few people are just happy with the Linn Kazoo, and they do not need anything else.

As you already know, to use Roon, you need a Roon Server running on your MM, and a Roon Control app running on any smart phone or a laptop or a MacBook.

There’s a reason for this, you know?
Such as the need to connect to the NAS everytime you start your Mac before starting Roon. I cant see the reason you are unable to connect to your NAS from Roon Core, unless you disabled SMB1.0/2.0.
However, put a shortcut to the Volume in you user profiles startup objects if you intend to continue using mapped Volumes on your Mac

Nope, at least with Qnap, the folder on the NAS automatically mounted after the Mac machine rebooted, just like Windows PC.

Hi @Max_Paley,

Your case reached my queue a bit late, but it sounds like you got the issue sorted out with help from our fantastic community!

If you run into any other issues, don’t hesitate to reach out and we’ll try to get to the bottom of it. Hope you enjoy the music and the Roon experience @Max_Paley!

I did, but only by using the “Volumes” path, which I didn’t realize I could navigate to until I noticed the up-arrow on the search path. No other combination of userid, IP address, back slashes or forward slashes ever worked for the “Add Network Drive” option

Now that I’m using it, I’m quite liking it.

My only little quibble is that I went to some trouble to attach the album art that I wanted, but Roon is often substituting its own. Is there a way to change that?