Roon on new MacBook Pro cannot find Roon Core

Roon Core Machine

Mac Mini (late 2012), 2.3 GHz Quad-Core Intel Core i7, 16 GB DDR3
macOS Catalina 10.15.7

Networking Gear & Setup Details

ASUS router, core is connected via Ethernet, all other hosts via Wi-Fi (on same subnet).

Connected Audio Devices

3 different Bluesound devices, Roon remote on iPhone 11 and iPad mini,
all connected via Wi-Fi. These are all working fine and seeing the core.

New 2021 MacBook Pro cannot find core.

Number of Tracks in Library

10,000 tracks.

Description of Issue

I recently got a new MacBook Pro. Today I installed Roon on it, and when I launched it it defaulted to using itself as the Core. I clicked disconnect, and tried to find the Core. It just searches endlessly, and never finds it, even when I click Help and enter the IP address of the Core machine. Roon Remote on my iOS devices still sees the Core, no problem (and show that they are connected to the same IP address which I enter when trying to connect the MBP).

During initial setup of this MBP I migrated data from the Mac mini that the Core is running on. I searched for and deleted the Roon app and every Roon-related file that I could find in the Library and Application Data, but I suspect that I missed something, and that this Roon installation somehow thinks that it is the Core that is running on the Mac mini.

Can someone tell me what file(s) I would need to delete to make this new Roon installation lose any information that it thinks it has about its identity? (Or, of course, provide any other suggestions that might help make it find the Core?)

Thanks!

Have you tried turning off the firewall, or allowing incoming connections to Roon? It’s in pref-panes > security > firewall

Rename/delete the user > library > Roon folder to reset everything.

Thanks, @mikeb ! After deleting the Roon directory in my user Library, Roon started up and immediately prompted me to connect to my Core.

Now if only it would produce sound. Regardless of whether I select “System Output” or “CoreAudio”, I get no sound output from Roon. I have an external DAC that I could connect, but since these new MBPs supposedly have built-in high definition audio support, I wanted to try just playing through that, but alas, I hear nothing. :frowning:

You probably need to add the Mac as an audio output device in Roon’s Audio settings, details here:

Thanks for the suggestion, but System Output was enabled by default, and I enabled CoreAudio when I got no sound from System Output.

Well, this is getting stranger. I didn’t notice this during my initial testing, because the Mac Mini which serves as my Roon Core is in a different part of the house.

It seems that the two choices that I am seeing under “This Computer” in Roon on my MacBook Pro are not, in fact, on my MBP. Rather, they are on my Mac Mini. I realized this when I went to double check the settings on the Core. I had changed the name of the CoreAudio entry on my MBP during testing. When I looked at the audio settings on the Mac Mini, I discovered that the CoreAudio under “This Computer” on that system now had the name that I had given to CoreAudio on the MBP.

So, I launched Roon on the MBP. It said that it was waiting for connection to remote Core. Then it connected and looked normal. I selected System Output and started something playing. I heard no output. Then I went to the room where the Mac Mini is, and sure enough, it was playing the track.

In the Audio settings on my MBP the two entries under “This Computer” are not on this computer, they are on the Mac Mini which hosts the Roon Core. The only reference to the MBP in Roon on the MBP is as an Airplay device. What the heck?

Hey @Jeff_Melin,

Thanks for engaging on the Roon community and sharing both the wins and the challenges you’ve ran into. We’re sorry about the roadblocks in enjoying Roon.

Since you’re using the MBP as a remote to control your Roon Core (on the MacMini), I wonder if your MBP is set up as a private zone. Could you please check and disable the private zone?

Well, I checked, and no, neither System Output nor Built-in Output that appear under This Mac in the Audio settings in Roon on my MBP have private zone enabled. Note, however, that as confirmed by the test I mentioned above, these settings are not actually for my MBP, they are rather for the Mac Mini. I have no access to audio settings for my MBP in Roon. They simply do not appear.

And here’s another test to confirm that Roon is having some sort of personality crisis on my MBP.

  1. On the Mac Mini where my Roon Core is installed, I went into Audio settings in Roon.
    1a) I renamed System Output to MiniSO and enabled Private zone.
    1b) I renamed Built-in Output (CoreAudio) to MiniCA and enabled Private zone.

Per the link provided above, “The Private Zone setting prevents remote control of connected audio outputs. A private zone can only be controlled from the device that it’s connected to.” Therefore, having enabled Private zone on the Mac Mini it should now be impossible for me to control the Roon output of the Mac Mini from my MBP, right?

  1. On the MBP which is absolutely not my Roon Core (I have been using Roon on other devices for the past couple of days with Roon not running on the MBP, in fact with the MBP not even powered on) I opened Audio settings.
    2a) Under This Mac I see “MiniSO” and “MiniCA”. That’s all.
    2b) I select MiniSO as the output device and start a track.
    2c) I hear nothing from the MBP.
    2d) The track is playing on the Mac Mini.

Roon on my MBP is absolutely convinced that it is running on my Mac Mini. I think that it needs therapy.

Hey @Jeff_Melin,

It’s impossible not to mention that the humor infused in your post gave me a great laugh :laughing: . Thank you for taking this in stride.

I appreciate you running all these tests and helping figure out what might cause this. I am hopeful that trying the steps below on your MBP might clear the confusion. Here goes:

  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

Thanks a whole lot :nerd_face:

Hi, Rebeka,

Thanks for the suggestion. Unfortunately, though, I just checked and there is no Roon* folder to rename in my Library folder. If I remember correctly I did find one there after doing the initial data transfer to this MBP, but I deleted it before installing Roon.

Cheers,
Jeff

Thanks for the details, @Jeff_Melin and for looking for that folder.

Did you get to reinstall the Roon software? Did it help?

Hi, Rebeka,

No, since I didn’t find the folder that you wanted me to delete, I did not bother reinstalling. However, for completeness sake, here is what I just did:

  1. Reboot MBP.
  2. Search for Roon files with ‘find -x / -name ‘Roon*’ 2>/dev/null’
  3. sudo rm -rf /Applications/Roon.app
  4. rm -rf Downloads/Roon.dmg Library/Roon
  5. Same search again. This time it reveals only two diagnostic logs in /Library/Logs
  6. Reboot MBP again.
  7. Browse to Roon Software Downloads - PC, Mac, Linux, Android & iOS | Get it Now
  8. Click Download for macOS
  9. Save Roon.dmg in Downloads
  10. Mount Roon.dmg
  11. Drag Roon to Applications
  12. Unmount Roon.dmg
  13. Launch Roon.app
  14. Click Open on dialogue warning me that I downloaded it from the Internet
  15. Click I agree in Roon’s window
  16. Click Connect next to the listing for my Roon Core in the Choose your Roon Core window
  17. Navigate to Settings->Audio
  18. Under This Mac, see only MiniSO and MiniCA
  19. Quit Roon on MBP

Any other ideas?

Thanks,
Jeff

Thanks for sharing that. You’ve done so much already.

I’ve looped in our technical team, so they can decipher a lot more out of this than our team can. However, as it is closing in on today, please, expect a reply early next week.

In the meantime, I hope music will still play in your home :musical_note:

Hi @Jeff_Melin ,

Did you by any chance use a Time Machine or similar program to clone the Mac HDD? There’s a bit more involved troubleshooting we can try, I will send it via private message!

Hi, Noris. Yes, I used Migration Assistant during the setup of my MBP to copy data from my Mac Mini. Following the instructions in your private message did resolve the issue. I can now play music via Roon on the MBP, thanks.

Are those instructions available somewhere on the site, in case others should encounter this issue?

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.