Roon on new Synology 920+

Hi all, I got myself a new Synology 920+ and have installed Roon, I can’t get it running and was just hoping someone here might have an answer or might be having or have had the same issue, any help would be gratefully appreciated, thank you Jim

Did you use the package from @crieke and did you follow his manual? See this link Is it the first time that you installed Roon server on a Synology NAS?

I hope @crieke will jump into this thread and that he is willing to help you.

Thank you very much for your reply Alfred, I did use that very site to get the links from, tried both links with the one still being tested, I haven’t bothered trying to put Roon on my old Synology NAS DS214 Play, was hoping my new 920+ would work okay with it, anyway deleted the software a couple of times now and re installed but still won’t run, not sure what I’m doing or have done wrong or even if it’s me or the NAS, hopefully I can get to the bottom of it and get it working, Jim

For your information: I have looked at the specs of the DS214play processor. I think it is 32-bit. So Roon core will not run on that DiskStation.

Can you share with us if there any error-messages or warnings on your DS920+ and if yes what are that messages? Screenshot could be helpful.

1 Like

@crieke, is it possible that the OP is facing the same problem as in this link? If so what can he do about it?

Hi @jim_mcgann
Maybe you could provide some more info.

  • Did the installation succeed without any errors?
  • Did you set up the location for the database: A shared folder or an external volume with the name “RoonServer” (case-sensitive!)?
  • Are there any folders after installation at the “RoonServer” share/volume after installation (e.g. RAATServer, RoonServer…)
  • Does the package center indicate Roon Server as “running” or “stopped”?
  • Did you try to connect to the server with a remote device (laptop/smartphone)?

Kind regards

Hi Chris and thanks for your response

It seemed to install without any errors
the package centre indicates Roon has stopped
I have roon on my computer so am not sure if that clashes with my Synology or not

That should not be an issue. :wink:

Can you post a screenshot of your RoonServer shared folder like the one below?

1 Like

Jim – your Roon server directory is “Roonserver” not “RoonServer” as @crieke noted it should be. You may have other problems but this may be one of them.

1 Like

A post was split to a new topic: Synology 920+ setup issue

Hi Jerry, thanks so much for trying to help, the messenger section of this forum won’t allow me to send anymore messages as apparently I’ve reached the limit, sorry about that, Jim

Thank you Graig and well noted, I changed my mistake and got Roon up running on my 920+ and am very happy, seems to work well, upgraded the Cache so hopefully things will run smoothly, couldn’t respond today as I was locked out with a limit on my posts, thank you so much everyone for your help and glad to have my new 920+ up and running with Roon

1 Like

Hi @crieke I’m trying to install Roon on my Synology 420+ and facing a similar issue. Application is successfully installed, but does not run properly. Every time I run it manually, a few seconds later it stops and the message is “Manually Stopped”. Any clue on what’s going wrong here? Screenshots attached for reference:

Hi @Ishan_Raghava ,
I was wondering, did you specify a shared folder for the Roon Server database during installation. The installer should ask you, where you want to store your database and also in which shared folder your music files are located.
I can see in your screenshot, there is a “Music”, “Data” and “TimeMachine” shared folder. which one did you choose then for the installation?

Hi Chris, thanks for replying. I deleted the earlier installation and folder and redid the whole process, created a new RoonServer folder and app installation. And it’s working perfectly now! Just need to load up my last Roon backup from my Mac. Thanks a ton!

This is what I finally did

1 Like