Roon on Synology 218+ cant find Endpoint Denon AVR-4500H

Core Machine (Operating system/System info/Roon build number)

Roon is running fine one my DS218+ I can find my Notebook for Playing sound,
what I do not find is the DENON AVR-4500H as an Endpoint to play music.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Both are connected over a FritzBox 7590 in the same network connected over Ethernet. Tried it also over WifI.
Denon HEOS and Internetradio etc is running fine. All network options are enabled, and the AVR for itsself is running fine. But I cannot find the AVR over the Roon App. Its connected

What I already tried:
Switching from Ethernet to Wifi
Disabling Firewall on Diskstation 218+
Disconnecting Router/Denon/Diskstation from power/network
Enabling UPNP and Port opening on Router
Reconfiguring IP from manually to DHCP

Have to ask, does the Denon show up in Settings - Audio - Roon Tested, and if so is it enabled?

Welcome to the community.

No. There is no Entry which relates to Roon on the whole Denon AVR - 4500H Firmware. But its the latest one from 2nd April 2020

I was referring to Roon - Settings - Audio.

do you have this entry on your denon ? which firmware do u use? where exactly should this entry be?

No its not listed in the Roon app… So I cannot select it

From your Roon Remote screen, 3 horizontal bars in the upper left, select settings then Audio. You should see the Denon listed there under Roon tested. IS that entry enabled? It has to be enabled there before the zone shows up in the zone list.

Here is my view with the Denon listed at the bottom under Roon Tested. My receiver is connected via Ethernet to the router with the Roon Core.

okay. Yeah, thats exactly my problem. My Denon AVR is not listed… Thats what the threat is about

Ok, how is the receiver known to the Network? Is it connected with Ethernet or Wireless. I have not used the Denon receiver wireless feature and do not know how it works. But it would need to be on the Network for Roon to see it.

Its connected over ethernet over a router to the nas theres nothing more online, just a NAS and the Denon

Ok, hopefully someone that has experience with Roon running on the NAS will see this and have some advice. Sorry I wasn’t able to help you.

Do you by any chance have Open vSwitch enabled on the Synology? (It is enabled automatically when Virtual Machine Manager is installed and blocks Roon from seeing devices for most protocols).

1 Like

Hi @Majo,

Checking Open vSwitch is a good troubleshooting step:

I would also check for any firewalls on your PC. It seems like it’s a Windows PC from the screenshot, so I would use these instructions to verify this side as well:

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

Can you check both of those options and let us know if either help?

@RBM ! @noris
thanks !! really thanks! u are amazing! :slight_smile: turning off the VManager and after that turning off the OpenVSwitch is the solution:
On Diskstation side to find here:
I turned on vSwitch (Control Panel->Network->Network Interface->Manage->Open vSwitch Settings->Enable Open vSwitch)


Fantastic news @Majo, take care and let us know if there’s anything else we can do to help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.