Roon on Synology fails to enable chromecast and play internet radio


Cannot play radio stations or enable chromecast with Roon on Synology.
Tested on local PC (same network) both work.

All devices on the same network
Using Roon remote on PC/Android devices…

Synology DS1815+ DSM 6.2.1-23824
Firewall/DoS - disabled
Installed Version: 2018-03-07
LAN connected

PC - Windows 10 version 1803 build 17134.407
LAN connected
Roon Version: 1.5 (build 363) stable (64bit) - latest on both PC and Synology

Chromecast LAN and Wifi connected

Test Radio Station:
plays on PC, not on Synology. error: Transport Failed to load media

  • plays on PC with browser, directly via Chromcast Home and Roon on PC

Logs/errors from Synology:


Logs from Synology:

11/26 12:50:59 Info: [zone dontpanic (upstairs left computer)] OnPlayFeedback Stopped
11/26 12:50:59 Trace: [dontpanic (upstairs left computer)] [Inactive] [STOPPED @ 0:00] 88.5 KNKX
11/26 12:50:59 Warn: [zoneplayer] Remote Load Failure While Opening Sound: icy:// IcyAudioSignal: HTTP Request to URL[icy://] failed
11/26 12:50:59 Info: [dontpanic (upstairs left computer)] [zoneplayer]     Open Result (Playing):Result[Status=MediaTooSlow]

Chromecast errors not updated on the synology:
Can cast to them via Android and Roon on PC.
Roon remote connecting to Roon Server on Synology devices are discovered; cannot enable. Click on button, but don’t see the option to name. Nothing in the roon logs.

Let me know what other information would be helpful.

I just tried it on my Synology device and also on the QNAP. Both throw the same error.
I then tried to read the audio stream url from the tunein source code. When I paste this URL, it seems to work:

@support: Might there be an issue resolving streams from tunein urls on linux devices?

UPDATE: Same result with Ubuntu. It’s not connected to the chromecast. I can reproduce on any audio output.

Hello @bullclan & @crieke,

I have filed a ticket for the QA team to look into this behavior regarding the radio stations.

@bullclan - Have you tried restarting your Chromecast, Core & all networking gear yet to see if you are able to enable the Crhomecast afterwards? I would try this if you haven’t done so.

I will be sure to update you once I hear back from QA regarding the radio station resolving streams issue.


The audio stream URL ( worked on the synology (linux based system)

restarted network (also applied latest firmware), Core (including NAS - had to patch it) and all Chromecasts - same issue on Synology - still works on PC.

@support - so you are aware that both streaming URL (TuneIn) and Chromecast integration broken on synology roon core package.

Hello @bullclan,

Thanks for letting me know. I have made QA aware of this issue and they are still looking into it, I will be sure to let you know once I have more information to share.


Hello @bullclan,

Our QA team has looked into this and the good news is that we are able to reproduce the problem. This is almost always the first step in getting something fixed, so we’ve now passed the report to our dev team to investigate a fix.

I can’t make any guarantees about whether they’ll be able to resolve this, or how soon they’ll have feedback, but we are tracking this and hope to get it fixed soon. Thanks for the report!

– Noris


Update to let you know that you also don’t discover Kef LSX with the Linux version. It works fine on the PC version.

Also, lettting you know I signed up for a 2 week trial and it will start on the 10th (Monday); I will be cancelling it today. Image taken from PC (above configuration with KEF LSX version 3.0 firmware)


Hi @bullclan,
Any chance vSwitch is enabled on your Diskstation? Can you check if this happens as well, when vSwitch is disabled?

Virtual Machine Manager not installed (I did install to make sure no settings; it started at the wizard - I backed out an uninstalled). Only vSwitches I have on vSphere. I do have a docker bridge network (roon installed using the synology package not a docker image). Synology setup using a Bond (2 x 1GbE) with a Balance-TCP ip4; MTU 9000 and configured for a VLAN connection (pulling this apart isn’t worth it). I have a small 2-node Synology I could do some testing with, but will have to be today as my trial key is about to be charged - don’t want to pay for two Roon accounts.


Tried to install on a 2nd synology (DS213se - DSM6.2.1-23824 Update 1 with single 1GbE, no VLAN, no Jumbo frames) but package throws an unsupported hardware error. Existing Synology (DS1815+) that Roon is running on has the same version of DSM


update: saw that Roon installer requires 64-bit Intel (DS213se has Marvell Armada 370 88F6707 so not compatible).