Roon on Synology NAS (beta DSM7) does not see any local audio devices

Roon Core Machine

Synology NAS DSM7

Networking Gear & Setup Details

Netgear Router

Connected Audio Devices

ifi idsd via USB; Asus Soundcard Essence II …

Description of Issue

Hi, since I upgraded from Synology DSM6 to DSM7, Roon does not recognize my locally connected audio devices on my PC such as sound card and a USB connected DAC. The audio devices work fine with the PC, so there must be some issue between Roon and the PC preventing the former to communicate with the latter.
So far I did the following:

  1. Disabled windows firewall → same issue (and Roon/Raats was permitted anyway from the previous installation)
  2. Renamed the Raats folder to Raats_old (I found this advice here in the forum) → Same issue
  3. Reinstalled the Roon Windows app, just in case → same issue.

Any suggestions? Thank you!

Please try this:

Thank you, but I did not use Tidal for years. I also checked the folder, no Tidal data is present.

To ad some more Information, the same issue is on my Mac, so any “PC” related problems can be excluded. Thanks

A post was split to a new topic: Roon does not see any audio devices

Hi Roon Team and @Carl , thanks for your response and here a summary of what is going on.

Describe The Issue

Roon does not recognize my locally connected audio devices on PC or Mac such as the internal sound card or any USB connected DAC. When I start the Roon App on either PC or Mac, only “other network devices” (a Sonos System) show up. This now always occurs when I use Roon. Formerly used local devices are laptop soundcard, PC soundcard Asus Essence II, external USB DAC ifi Pro iDSD, ifi Micro BL and Chord Hugo2.

I do not use any streaming service, and my mid-sized library is on the Synology internal DIsk Drive in form of 4 folders, which are all fully authorised under DSM7.

Describe Your Setup

I run a Roon Server on a Synology DS1515+ on DSM7 using the beta installer by @crieke v20210809 using a folder called RoonServer on the internal drive. My Synology is connected by cable to my Netgear Cable Router C7000. The Router is only a bridge to my Wireless transmitter (also via cable), Netgear Nighthawk RAX80. I access the Roon Server from mobile devices, my PC and a Mac laptop … all of which worked in the past before I upgraded to DSM7.

Thsnks for your help, and please let me know if you need any further information.

Hi Jan,

Audio devices are displayed when accessible by the Roon core. Your Roon core needs to see the devices on the computers, and it doesn’t appear able to do so. Do you have a firewall on the Synology?

Thank you, good point. The firewall was enabled, but disabling it (plus restarting the NAS) did not make a difference. I also disabled the security features of my RAX80 router, which also did not make a difference, unfortunately.

Hi @Jan_Michael,
Could you check the following: Open FileStation on your Diskstation and navigate to your specified database directory. Open the RoonOnNAS folder there and right-click on “RoonServer” and select Properties.

A window will pop up. It includes an info about the “owner” of the folder. Can you check, if the folder is “owned” by RoonServer?

Hi @crieke , thank you very much for the detailed response. The folder is owned by RoonServer

1 Like

Great! Just wanted to make sure this is not related to any kind of permissions.
My second guess, was also a network related (or firewall) issue.
As you mentioned, you’ve already checked firewall settings of your diskstation and your router. Have you also checked your PC/Mac, where your DAC is connected?
are you able to see other audio devices (if there are other audio devices).

Just to clarify one aspect of your issue description: the audio devices are connected to your Computer (not to your diskstation)?

Yes, firewall on router and NAS are all disabled.

All audio devices show up correctly on their own with PC and MAC where they are directly connected to. In fact, no devices are connected to my NAS at all. Thanks!

Hi @crieke , I sent the log files you requested. Anything else I can do to support at this point? Thanks again for looking into it.

For users having similar issues, look into the NAS subnet and device connections. Once I reset and reassigned my device IPs, the audio devices were recognized. Thanks to @crieke for his fantastic help and advice to check the subnets.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.