Roon on Windows 10. Super slow to load initially. Fine thereafter

Hi @support
In the past few weeks my Roon has been crazy slow to load initially.
I get the splash screen with the quotation, then the blank screen with the loading symbol, but after about a minute the loading symbol freezes and can stay that way for about 10 minutes before the program’s actually loaded. After that it’s totally fine. Nice and responsive. So there’s something that’s happening as part the program startup that’s timing out or locking up.

It’s running on my laptop, which is Win10 64bit, i7 2.6ghz cpu 8gb ram and plenty of hard drive spare. Main music collection is on my network nas which is configured as a music source in the format \\flac and can be readily accessed without any issue. Wired network rather than wifi.

Can you suggest anything to try please?

Just so I understand your setup, Roon Core is running on your laptop and it is connected via ethernet not wireless. And the music is on the NAS. also connected via ethernet. And you are not using Tidal.

Check to see if you have any space left on the laptop drive. Slowness could come from lack of available hard drive space.

Also, is your hard drive an SSD? If not, then it might be that Roon’s database has gotten large and taking time to read. An SSD is recommended for any drive that is running Roon Core.

Eliminate the NAS as a suspect. Disable the NAS storage location. Restart roon, does it now load super slow? If no, then, I’d setup a new test location of the C drive of the laptop, copy some music there, set Roon Core to see the local music on the laptop, reboot and see if it is still slow. One option, which I do, is to have all music local to the Core and just use the NAS as a backup. Local USB hard drives are relatively cheap and work well (I use WD).

If the Core is not running all the time and is being shutdown, then it will run through checks to verify storage and files on boot up.

1 Like

If its the remote cliennt and not the core try the 32bit install…known issues exist with many intel HD graphics drivers

You might want to use the Roon Server install and 32bit roon as the client.

Hello @James_Robinson1,

I would give @Rugby’s suggestions a try, and if you haven’t done so yet you may want to reboot your Core and all networking gear as well. Let us know if that helps!

– Noris

Just as an indication

I have Roon on. Desktop, i7, 16 gb RAM, 256 Ssd, 3.3 g series cpu

All music files are on internal 3.5 HDD

I close down every night to avoid lightning strikes :joy:

It takes maybe 1 min after the splash screen to do its start up

But my Pc has all sorts starting up as well, SQL Server, JRiver etc so it could well be slower than if those were disabled. (Old devs never give up)

The SSD as suggested is a prime suspect, how many tracks, albums do you have

thanks all, sorry for the slow reply.
I have the single instance of Roon running on my laptop (nvidia graphics chipset). ethernet to the network. flac files mainly on a nas (70gb free there and it’s nice and responsive otherwise) which is also ethernet, but also a handful on my local laptop drive. I am using Tidal.
The laptop is more than fast enough for most stuff, has a big SSD and has more than 50gb free.

I’ve just tried disabling the NAS location, but the results are still the same - over 10 minutes until I have it loaded and responsive.

So I disabled the local file stores as well but no change.
I turned off the antivirus (bit defender)
I cleared the image cache
I disabled Tidal
At this point I had no music sources, so I backed up the library and ran the ‘clean up library’ which basically updated and cleared out the library.
Now it’s slightly faster to load, but not by much.
So I downloaded a fresh copy of the RoonInstaller64.exe and ran that incase any of the files got corrupted.
But it’s still more or less the same.
I’m baffled now…
Any suggestions gratefully received.

Currently, with no music in the library and all sources of music disabled it’s taking 8mins 30 to load:

splash screen with musician quote 4 secs
white screen with animated roon logo. logo freezes 25 secs
windows states the Roon window is ‘not responding’ 2 mins
animated roon logo has a brief wiggle then freezes again 6:15
logo starts moving again 7:00ish
fully loaded 8:35

It’s not as though there’s a lot of resources being used, or the HDD is being thrashed. The laptop is completely responsive and normal in all other respects during this time.

Hello @James_Robinson1,

I had a meeting with QA and some of the senior devs regarding your case and at this time we believe that this issue could be due to one of your networking shares on Windows.

As a test, can I please ask you to physically turn off all of you networking shares and then reboot your Core machine? I am hoping that this would reveal a useful data point and prevent any strange storage behavior that may be happening in the background. Please let me know your results when possible.


Thanks Noris,
I’ve just tried it and I can confirm that with networking shares disabled there seems to be no difference.
I also tried with no network connection at all, but this seemed to take even longer.
Not sure if it helps diagnose, but I’ve watched the processes as they start. In the first minute there is only the main roon.exe.
After about 1 minute, the RAATServer and Console Window Host processes appear and it is at this stage that the Roon application freezes and the animated Roon logo stops moving.

Something like this could be caused by a conflict with real-time anti-virus scanners. Are you using one of those?

Hi @James_Robinson1,

Thanks for trying that test. Just to confirm, you have physically powered off your network storage locations and then rebooted your Windows 10 core afterwards and the behavior is still the same? It is important that we test for this specific behavior to see weather the NAS is causing any issues here. If you have not done this yet, I would try my above test with them physically powered off.

If you have done the above test, I would like to verify how your Roon performs with a new database in place in case something has gone wrong on that end. Please use these instructions to generate a new database:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location:
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart the Roon App to generate a new Roon folder

This step should look like this in Windows:


Please do not configure your old storage locations just yet, just try using the new database “as-is” with TIDAL for a couple of hours and across a few restarts. If you can confirm that Roon is working as expected then I would try restoring from the old backup and see if everything is still ok. Let me know your findings when possible.


I have disabled my NAS and all local folders as music sources for now, so it’s just Tidal.
I renamed the %localappdata%\roon directory, but that’s the one that contains the main roon.exe so it wouldn’t run :slight_smile: So instead I renamed just the %localappdata%\roon\database directory and I can see on restart of the application it has created a new database directory. It’s taken 5 minutes of being frozen to now present me with the ‘I agree’ button and then ‘set up a core on this PC’
I’m setting up a new core now

I can see in the %localappdata%\roon directory that there are very detailed logs. Surely these are the most helpful route to diagnosing this? I’d post them here but they contain my login email and token

hmm, no improvement with a fresh database :frowning:

Do the windows error logs provide any hints?

Hello @James_Robinson1,

I don’t believe that you performed a clean test here, can you perform the steps again and instead of restarting Roon to generate a Roon folder rather reinstall Roon from the installer listed on our website? We just released Roon 1.6 so I’m curious if this issue is still happening with the updates.


Thanks Noris,
1.6 was loading a bit faster yesterday, but very slow this morning.
So, I closed it down, renamed the whole %localappdata%/roon directory, then ran the installer fresh from the website.
The first part of the installer ran really quick, but it’s then taken a loooog time with freezes and such (only of the roon app) to get to the stage where it’s even asking me about where the core is and whether I want to install one.


this page was unresponsive for some minutes, where if I rolled over the blue buttons with the mouse, they wouldn’t highlight to show they were clickable and clicking them had no effect. After a few minutes it became unfrozen. I haven’t gone any further than this for now and just closed the Roon application via the red X in the top right. It seems to me that whatever issue I have here is manifesting itsself here at a very early stage.
So at this stage, I don’t have any core running, there are no music sources configured and I have a completely fresh install. But it’s still hanging and taking 6 minutes to present me with a responsive interface. Running the application as Administrator doesn’t change things. Here’s my log file for one of these loads. It’s not until right at the end at 10:25 that I can do anything with the interface. I’ve changed my IP but nothing else:

01/24 10:19:35 Info: Starting Roon v1.6 (build 390) stable on windows
_01/24 10:19:35 Debug: looking for *old files in: C:\Users\James\AppData\Local\Roon\Application
01/24 10:19:35 Debug: looking for old numerical version dirs in: C:\Users\James\AppData\Local\Roon\Application
01/24 10:19:35 Trace: Checking if we are already running
01/24 10:19:35 Trace: Nope, we are the only one running
01/24 10:19:35 Info: Is 64 bit? True
01/24 10:19:35 Trace: [broo/imagecache] loaded 0 cache entries from C:\Users\James\AppData\Local\Roon\Cache\brooimages_1\index.db, current: 512mb / 0mb
01/24 10:19:35 Info: Loading broo project: ui.broox
01/24 10:19:35 Trace: [realtime] fetching time from NTP server
01/24 10:19:35 Trace: [realtime] Got time from NTP: 24/01/2019 10:19:33 (3757313973869ms)
01/24 10:19:35 Trace: [realtime] Updated clock skew to -00:00:01.6668140 (-1666.814ms)
01/24 10:19:35 Debug: OpenGL Version: 4.6.0 NVIDIA 388.57
OpenGL Vendor: NVIDIA Corporation
OpenGL ShaderLangerVersion: 4.60 NVIDIA
_OpenGL Extensions: GL_AMD_multi_draw_indirect GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compatibility GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_compute_shader GL_ARB_compute_variable_group_size GL_ARB_conditional_render_inverted GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_derivative_control GL_ARB_direct_state_access GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_ES2_compatibility GL_ARB_ES3_compatibility GL_ARB_ES3_1_compatibility GL_ARB_ES3_2_compatibility GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_layer_viewport GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4 GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_gl_spirv GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader_int64 GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_indirect_parameters GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multi_draw_indirect GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_parallel_shader_compile GL_ARB_pipeline_statistics_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_polygon_offset_clamp GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_query_buffer_object GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counter_ops GL_ARB_shader_atomic_counters GL_ARB_shader_bit_encoding GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote GL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_shader_storage_buffer_object GL_ARB_shader_subroutine GL_ARB_shader_texture_image_samples GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_include GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_sparse_buffer GL_ARB_sparse_texture GL_ARB_spirv_extensions GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_barrier GL_ARB_texture_border_clamp GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_range GL_ARB_texture_compression GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_filter_anisotropic GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transform_feedback_overflow_query GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bit GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXTX_framebuffer_mixed_formats GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset_clamp GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_shader_objects GL_EXT_separate_specular_color GL_EXT_shader_image_load_store GL_EXT_shader_integer_mix GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback2 GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_EXT_vertex_attrib_64bit GL_EXT_window_rectangles GL_EXT_import_sync_object GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KHR_context_flush_control GL_KHR_debug GL_KHR_parallel_shader_compile GL_KHR_no_error GL_KHR_robust_buffer_access_behavior GL_KHR_robustness GL_KTX_buffer_region GL_NV_alpha_to_coverage_dither_control GL_NV_bindless_multi_draw_indirect GL_NV_bindless_multi_draw_indirect_count GL_NV_blend_equation_advanced GL_NV_blend_square GL_NV_command_list GL_NV_compute_program5 GL_NV_conditional_render GL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_depth_buffer_float GL_NV_depth_clamp GL_NV_draw_texture GL_NV_ES1_1_compatibility GL_NV_ES3_1_compatibility GL_NV_explicit_multisample GL_NV_fence GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_framebuffer_multisample_coverage GL_NV_geometry_shader4 GL_NV_gpu_program4 GL_NV_internalformat_sample_query GL_NV_gpu_program4_1 GL_NV_gpu_program5 GL_NV_gpu_program5_mem_extended GL_NV_gpu_program_fp64 GL_NV_gpu_shader5 GL_NV_half_float GL_NV_light_max_exponent GL_NV_multisample_coverage GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_parameter_buffer_object GL_NV_parameter_buffer_object2 GL_NV_path_rendering GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_query_resource GL_NV_query_resource_tag GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_shader_atomic_counters GL_NV_shader_atomic_float GL_NV_shader_buffer_load GL_NV_shader_storage_buffer_object GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_multisample GL_NV_texture_rectangle GL_NV_texture_rectangle_compressed GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_transform_feedback GL_NV_transform_feedback2 GL_NV_uniform_buffer_unified_memory GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_attrib_integer_64bit GL_NV_vertex_buffer_unified_memory GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NVX_conditional_render GL_NVX_gpu_memory_info GL_NVX_multigpu_info GL_NV_shader_thread_group GL_KHR_blend_equation_advanced GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum GL_WIN_swap_hint WGL_EXT_swap_control _
01/24 10:19:35 Debug: Maximum OpenGl texture size is 16384
01/24 10:19:35 Info: Broo Debug Web GUI ready at http://localhost:6700/broo/
01/24 10:19:35 Trace: [brooengine] Loaded atlas list. 0ms
01/24 10:19:35 Trace: [brooengine] Window is running in scale 1
01/24 10:19:35 Trace: [brooengine] Using atlas scale 1
01/24 10:19:35 Trace: [brooengine] Loaded atlas texture ui_atlas@1x-1.png. 64ms
01/24 10:19:35 Trace: [brooengine] Loaded atlas texture ui_atlas@1x-2.png. 32ms
01/24 10:19:35 Trace: [brooengine] Loaded atlas texture ui_atlas@1x-3.png. 41ms
01/24 10:19:35 Trace: [brooengine] Loaded atlas. 142ms
01/24 10:19:35 Debug: render area size initial value: 284x261
01/24 10:19:35 Info: Loaded broo project: ui.broox, atlas: ui
01/24 10:19:36 Info: [stats] 5038mb Virtual, 107mb Physical, 16mb Managed, 704 Handles, 28 Threads
01/24 10:19:36 Debug: render area size changed value: 1024x687
01/24 10:19:37 Debug: render area size changed value: 1366x705
01/24 10:19:37 Debug: render area size changed value: 1366x705
01/24 10:19:37 Debug: trigger: appinitwasnotrun
01/24 10:19:37 Debug: trigger: do nothing
01/24 10:19:51 Info: [stats] 5203mb Virtual, 198mb Physical, 18mb Managed, 814 Handles, 27 Threads
01/24 10:19:59 Info: [broker] starting 8a096651-2b1c-4b39-ad5d-e80693c428d3
_01/24 10:19:59 Debug: [broker/filebrowser/volumeattached] initial listing found drive mounted at C:_
01/24 10:19:59 Info: [broker/locations] adding storage location: Internet:Name=Internet Media:Id=e268f098-04c4-4e65-af3f-38ba3c3fcecb
01/24 10:19:59 Info: [broker/locations] media availability: Internet:Name=Internet Media:Id=e268f098-04c4-4e65-af3f-38ba3c3fcecb is online
01/24 10:19:59 Info: [broker/locations] adding storage location: MetadataService:Name=Metadata Service:Id=13769258-b70b-4243-b1d6-bd46e8257ba8
01/24 10:19:59 Info: [broker/locations] media availability: MetadataService:Name=Metadata Service:Id=13769258-b70b-4243-b1d6-bd46e8257ba8 is online
01/24 10:19:59 Info: [broker/locations] adding storage location: Offline:Name=Offline:Id=f1e4b43f-f643-47ba-b875-fd93b32a6006
01/24 10:19:59 Info: [broker/locations] adding storage location: DefaultMusicFolder:Name=Music Folder:Id=29bdcae6-b5fd-d666-27bf-a1f6afceabac
01/24 10:19:59 Trace: [brokerserver] Enabling broker server
01/24 10:19:59 Info: [broker/distributed] HTTP server listening on port 9100
01/24 10:19:59 Trace: [broker/backups] initializing
01/24 10:19:59 Trace: [broker/accounts] file not found
01/24 10:19:59 Trace: [broker/accounts] Data updated. AccountStatus=NoAccountConfigured MachineStatus=NeedsAccount UserId=
_01/24 10:19:59 Debug: [broker/filebrowser/volumeattached] initial listing found drive mounted at D:_
01/24 10:19:59 Info: [libraryapi] loaded first run time 24/01/2019 10:03:03
01/24 10:19:59 Trace: [devicedb] initializing
01/24 10:19:59 Trace: [devicedb] refreshing, etag=W/“d3fd2-1687bd309ec”
_01/24 10:19:59 Debug: [broker/filebrowser/volumeattached] initial listing found drive mounted at E:_
01/24 10:19:59 Info: [broker/filebrowser/volumeattached] skipping drive E:\ because it is a CD-Rom
_01/24 10:19:59 Debug: [broker/filebrowser/volumeattached] initial listing found drive mounted at F:_
_01/24 10:19:59 Debug: [broker/filebrowser/volumeattached] initial listing found drive mounted at G:_
01/24 10:19:59 Trace: [devicedb] builtin device db found at C:\Users\James\AppData\Local\Roon\Application\100600390\
01/24 10:19:59 Trace: [devicedb] cached device db found at C:\Users\James\AppData\Local\Roon\Cache\
01/24 10:19:59 Trace: [devicedb] loading device db at C:\Users\James\AppData\Local\Roon\Cache\
01/24 10:20:00 Trace: [devicedb] loaded 57 vendors, 273 products from devicedb with timestamp 23/01/2019 17:47:34
01/24 10:20:00 Info: [raatserver] [runner] Start or Connect…
01/24 10:20:00 Info: ConnectOrStartAndWaitForExit RAATServer
01/24 10:20:00 Debug: [easyhttp] GET to returned after 624 ms, status code: 304
01/24 10:20:00 Trace: [devicedb] Not Modified. Nothing to do
01/24 10:20:00 Trace: [broker/services] refreshing metadata URL bits
01/24 10:20:00 Info: [broker/dropbox] no account configured
01/24 10:20:00 Debug: initialize backend in 25101ms
01/24 10:20:00 Info: [remoting] loaded protocol hash 136528c8117b084ad848871f5075f3fab5f12bad from C:\Users\James\AppData\Local\Roon\Application\100600390\Roon.Broker.Api.Remote.dll
01/24 10:20:00 Trace: [httpcache] loaded 0 cache entries from C:\Users\James\AppData\Local\Roon\Cache\httpcache_2.db, current: 0mb / 128mb
01/24 10:20:00 Info: [music] first pass through media thread is done
01/24 10:20:00 Info: [transport] initializing
01/24 10:20:00 Info: [roonapi] initializing
01/24 10:20:01 Info: [raatserver] [runner] Status: Started
01/24 10:20:06 Info: [stats] 5263mb Virtual, 217mb Physical, 20mb Managed, 1124 Handles, 42 Threads
01/24 10:20:16 Trace: [distributedbroker] Enabling remote broker tracking
01/24 10:20:21 Info: [stats] 5239mb Virtual, 247mb Physical, 21mb Managed, 1107 Handles, 36 Threads
01/24 10:20:36 Info: [stats] 5227mb Virtual, 247mb Physical, 21mb Managed, 1103 Handles, 33 Threads
01/24 10:20:51 Info: [stats] 5227mb Virtual, 245mb Physical, 20mb Managed, 1110 Handles, 33 Threads
01/24 10:21:06 Info: [stats] 5223mb Virtual, 245mb Physical, 21mb Managed, 1106 Handles, 32 Threads
01/24 10:21:21 Info: [stats] 5223mb Virtual, 245mb Physical, 20mb Managed, 1107 Handles, 32 Threads
01/24 10:21:36 Info: [stats] 5235mb Virtual, 245mb Physical, 21mb Managed, 1124 Handles, 35 Threads
01/24 10:21:51 Info: [stats] 5256mb Virtual, 245mb Physical, 22mb Managed, 1132 Handles, 36 Threads
01/24 10:22:06 Info: [stats] 5260mb Virtual, 246mb Physical, 21mb Managed, 1142 Handles, 37 Threads
01/24 10:22:21 Info: [stats] 5252mb Virtual, 246mb Physical, 22mb Managed, 1136 Handles, 35 Threads
01/24 10:22:36 Info: [stats] 5252mb Virtual, 247mb Physical, 22mb Managed, 1138 Handles, 35 Threads
01/24 10:22:51 Info: [stats] 5252mb Virtual, 247mb Physical, 23mb Managed, 1137 Handles, 35 Threads
01/24 10:23:04 Trace: [geoip] GET
01/24 10:23:04 Info: [loadstatus] IsLibraryLoading True => False
01/24 10:23:04 Info: [loadstatus] IsTransportLoading True => False
01/24 10:23:04 Info: [loadstatus] IsStartup True => False
01/24 10:23:04 Trace: [appupdater] initial check for updates
01/24 10:23:04 Debug: [base/updater] Checking for updates:
01/24 10:23:04 Info: [roonapi] listening on port 9150
01/24 10:23:04 Trace: [roonbridge] [sood] Refreshing device list
01/24 10:23:06 Info: [stats] 5341mb Virtual, 248mb Physical, 23mb Managed, 1268 Handles, 57 Threads
01/24 10:23:06 Info: Flushing kart data to server
_01/24 10:23:06 Debug: server said: _
01/24 10:23:16 Trace: [geoip] GOT {“country”:“GB”,“state”:“LUT”,“city”:“Luton”,“postalcode”:“LU2”,“latitude”:51.9114,“longitude”:-0.382,“ipaddress”:“”,“status”:“Success”}
01/24 10:23:16 Debug: [appupdater] Update not needed
01/24 10:23:21 Info: [stats] 5317mb Virtual, 249mb Physical, 24mb Managed, 1251 Handles, 51 Threads
01/24 10:23:36 Info: [stats] 5329mb Virtual, 250mb Physical, 24mb Managed, 1268 Handles, 54 Threads
01/24 10:23:50 Debug: ev_app_init: showing broker choosing window
01/24 10:23:50 Debug: app_init completed
01/24 10:23:51 Info: [stats] 5325mb Virtual, 251mb Physical, 25mb Managed, 1281 Handles, 53 Threads
01/24 10:23:51 Trace: Successful POST response from
01/24 10:23:51 Warn: [ui/slowness] widget win_choosebroker(793) > stackpanel(795) > vpanel(796) > hpanel(797) > label(799) took 305ms to OnLayout
01/24 10:23:51 Warn: [ui/slowness] widget win_choosebroker(793) > stackpanel(795) > vpanel(796) > hpanel(797) took 306ms to OnLayout
01/24 10:23:51 Warn: [ui/slowness] widget win_choosebroker(793) > stackpanel(795) > vpanel(796) took 309ms to OnLayout
01/24 10:23:51 Warn: [ui/slowness] widget win_choosebroker(793) > stackpanel(795) took 314ms to OnLayout
01/24 10:23:51 Warn: [ui/slowness] widget win_choosebroker(793) took 314ms to OnLayout
01/24 10:24:06 Info: [stats] 5441mb Virtual, 375mb Physical, 24mb Managed, 1277 Handles, 51 Threads
01/24 10:24:21 Info: [stats] 5433mb Virtual, 375mb Physical, 25mb Managed, 1270 Handles, 49 Threads
01/24 10:24:36 Info: [stats] 5445mb Virtual, 376mb Physical, 25mb Managed, 1282 Handles, 52 Threads
01/24 10:24:51 Info: [stats] 5437mb Virtual, 376mb Physical, 26mb Managed, 1278 Handles, 50 Threads
01/24 10:25:06 Info: [stats] 5429mb Virtual, 377mb Physical, 21mb Managed, 1273 Handles, 48 Threads
01/24 10:25:21 Info: [stats] 5425mb Virtual, 376mb Physical, 21mb Managed, 1269 Handles, 47 Threads
01/24 10:25:23 Trace: [push] connecting to
01/24 10:25:23 Trace: [push] connected

Hi James, can you specify the make/model of your laptop? That would allow support to verify it’s specs.

Sure. It’s an Asus X555LD but with an SSD fitted. It’s way fast enough for most stuff. it’s ran Room fine for a couple of years but has been very slow only in the past couple of months.
While Room is hanging, there’s plenty of resources available and the laptop is otherwise perfectly responsive and useable for other applications

Some ideas, you might try isolating the NIC interface by disabling it and using WiFi instead to see if there is a difference.

One thought, you might try to install RoonServer which has no GUI and see if it installs. I would verify it is running, by connecting in with a phone, tablet or another computer running Roon. If it does and works, then it points to an issue with the Graphic System.

I personally run Roonserver as the server portion and Roon (only as a control interface) on the same machine.

Also, the latest NVIDIA drivers are NVIDIA 417.71. Your logs show you are using NVIDIA 388.57.

1 Like

great ideas! It’s fixed! :man_mechanic::sunglasses:

So I went to disable my NIC interface and look what I saw :scream:
A whole page of extra TAP interfaces that windows had created somehow.

If I had to guess, I would say maybe the VPN software I use for work has created an extra one each time I use it? Anyway, I have uninstalled them, all in device manager and wow, that’s something of an improvement now. I have a fully loaded and responsive Roon control and server in 5 seconds! :slight_smile: That’s a bit better than 12 minutes!

Thank you all for your help and suggestions, we are fixed and back in business. Let the music flow freely once again :musical_note::notes::violin::trumpet::notes::guitar::musical_note::drum::violin::saxophone::radio::trumpet::guitar::sunglasses:



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.