Roon only shows a black window with Roon logo

Core Machine

Mac mini (Late 2012)
Processor 2.5GHz Dual -Core Intel Core I5
Memory 16GB 160 Mhz DDR3
macOS Catalina Version 10.15.7

Network Details

Ethernet LAN

Audio Devices

USB Mcintosh C2700

Library Size

2000 tracks

Description of Issue

After upgrade to macOS Catalina 10.15.7 Roon won’t load the albums and menu, it only shows a black window with Roon logo which looks like its trying to connect…

Tried to reinstall Roon and follow the installation instructions, checked firewall is off, permission on the library using Terminal was also done. Aerial font was also enabled as per instructions… Still Roon won’t load the albums, and all the menus on the left. just black window with Roon logo on the middle which looks like its trying to connect outside.

as its a weekend… and long one? support might be a few days into next week to respond.

when you did the upgrade was it just a normal update from the previous Catalina release or was it from a much older one?

just to confirm you didnt do a restore from a time machine image did you?

I’m not roon support, I’m just a user like yourself offering some help in the interim.

I did not do a restore, the Catalina which I used before teh issue was just one version away… I usually do regular updates.

Might be worth trying to just reinstall the application again…not remove anything but just download and reinstall over the existing one.

I’ll assume you have database backups just in case.

Yes tried the reinstall without removing, still the same… So I removed Roon on the Applications. I don’t have the database back up, only the actual folder which contains the songs and pictures on my Mac mini and a back up external Hard Disk… I also have a windows laptop which has the Roon working

Fixed it by installing a March 2020 Roon version that is luckily still on my download folder… So Catalina 10.15.7 has a problem with the latest Roon 1.8

this should not be the case, I’ve run Roon on most all of apples recent OS versions - you certainly wont be the only one with 10.15.7

You are right, I just updated to version 1.7 as there was an update notification. I did the upgrade and was surprised that the version is showing 1.8 now and I have the latest version… weird… I would not update it if it was showing 1.8… since it was showing 1.7 so I did update…and was surprised as its shows 1.8 now…

Hello @MrJoms,

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Thankfully, it looks like you able to work through the update successfully and get everything going. This issue could have due to an initial incomplete install. In any case we’re happy to see that you’re up and running! Happy listening! :+1:t2::loud_sound: